or Connect
New Posts  All Forums:Forum Nav:

Speaker problems

post #1 of 4
Thread Starter 

I recently got 2 new speakers, a receiver, and a turntable. They're pretty great (I think, at least). Only problem is the one on the right is much softer than the one on the left. I turned balance all the way to the right to test, and it was. So i switched it from stereo to mono, and then it sounds just as good as the left one. I feel like I'm missing something really easy here.

 

For reference, the speakers are Pioneer CS-G203's and the receiver is a Pioneer model SX-434. The turntable isnt in use, I jsut wanted to include it because I'm pretty excited I got one that actually works well without spending a small fortune.

post #2 of 4
Doesn't sound like this is a speaker problem. I would try test another audio device with your receiver to narrow down whether the problem is the receiver or your turntable.
post #3 of 4
Thread Starter 

Yeah, I resolved it, there is a magic spot in the balance knob to keep it at where they are equal volume, weirdly enough, mostly to the left. Thanks anyway though!

post #4 of 4
Quote:
Originally Posted by Wash View Post

Yeah, I resolved it, there is a magic spot in the balance knob to keep it at where they are equal volume, weirdly enough, mostly to the left. Thanks anyway though!

With an older receiver like that, might just need the connections on that pot cleaned, although I don't know how to tell you how to do it smily_headphones1.gif
New Posts  All Forums:Forum Nav: