or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Software for my headphones not found after it's been working fine for months.
New Posts  All Forums:Forum Nav:

Software for my headphones not found after it's been working fine for months.

post #1 of 2
Thread Starter 

So I have a problem with my headphones. I own the Sennheiser PC 333D surround sound headphones, and it required software to work properly. I installed that and it worked perfectly for the past three months (its a USB soundcard that is attached to the headphones) but when I started up my PC this morning, it was gone. Usually it always appeared in the audio devices when I right clicked the sound icon but now it's not there anymore. 

 

I have tried removing and reinstalling it but it still won't work. Does anyone know how I can get it to work again?

post #2 of 2
Can I assume the USB 'phones are still plugged-in to the computer? Try plugging them into a different USB port.

MacBooks are out of my realm. There must be a way to remove the device drivers? If you can uninstall the software and also remove all the devices related to the headphones, then maybe you can install from scratch. A lot of times just uninstalling the application doesn't uninstall the device drivers. You might also try seeing if there is a later version of the software you can download from the Sennheiser website.

Other than that - I don't know how we can possibly know what else is going on with your computer HW/SW.
New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Software for my headphones not found after it's been working fine for months.