Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Triple Fi's got quiet in one ear
New Posts  All Forums:Forum Nav:

Triple Fi's got quiet in one ear

post #1 of 3
Thread Starter 

Hi Folks -- 

 

I have a pair of ultimate ears Triple Fi 10's which I love. About six months ago the volume dropped in the right earpiece by about 40%. I cleaned it out, nothing. I posted to the interwebs and someone said the cable had gone bad, so I upgraded to the one with the microphone in it but the problem persists. I emailed tech support but they've never written back. 

 

Is it dead? Do I need to get a new earpiece? Or a whole new set? Is this a known issue? Is there someone who repairs this stuff? 

 

Thanks for your advice.

 

Listening in mono.

post #2 of 3
Sounds like one of the balanced armatures has started failing on that side or gone out completely, or the crossover is dying. If you've cleaned the nozzles, double checked the cable and connectors then all you can really do is use some Hydrogen Peroxide and let it clean the filters inside the nozzles. You'd need some pretty waxy ears to glog those however.

You can look for another earpiece or sell them on eBay to partially fund a new pair, someone like yourself is out there always looking for another earpiece. I doubt it can be fixed unless you send it to a reshelling service and have them test the drivers, even then if they work you'd need to reshell them.
Edited by H20Fidelity - 1/23/14 at 8:22am
post #3 of 3
Quote:
Originally Posted by kylecassidy View Post
 

Hi Folks -- 

 

I have a pair of ultimate ears Triple Fi 10's which I love. About six months ago the volume dropped in the right earpiece by about 40%. I cleaned it out, nothing. I posted to the interwebs and someone said the cable had gone bad, so I upgraded to the one with the microphone in it but the problem persists. I emailed tech support but they've never written back. 

 

Is it dead? Do I need to get a new earpiece? Or a whole new set? Is this a known issue? Is there someone who repairs this stuff? 

 

Thanks for your advice.

 

Listening in mono.


I had the sound fading from the right side. Got a new cable from Logitech, Back in business.

New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Triple Fi's got quiet in one ear