Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › SMSL SD-1955+ high pitch ringing
New Posts  All Forums:Forum Nav:

SMSL SD-1955+ high pitch ringing

post #1 of 2
Thread Starter 

Ive had my SD-1955+ for a while and after about two months it began to make a sort of white noise ringing that was just always present no matter what when its on, any volume level. At higher volumes you cant hear it as well but it sounds terrible. I stopped using the thing for a while, it is my first dac Ive ever and it wasn't that hard for us to go back to just regular built in pc dac's. I bought this for my brother's birthday last year and now I want to fix it by his birthday this year for him. I've seen that people change out the opamps but it seems everyone uses a different one so I'm not sure which to go with, there are three total. Some of the capacitors sometimes get replaced but I have no idea what goes into that because I've never done any custom work on a circuit board like this. Lastly in my research I found people saying changing the power supply is helpful for some reason, once again I'm not sure if that's just buying a different power cable or actually replacing a part. I've done a few hours of searching now and there is hardly any threads on this dac and I found none on the ringing, I only found it mentioned in one or two posts but those people are so vague when they describe the fix that it doesn't help me at my newb level of audiophileness. 

 

If anyone could help me figure out what parts to buy and replace I will use this as a learning project, I consider the thing scrap already so if I manage to fix it I would be stoked.

post #2 of 2
Thread Starter 

Ok so I ended up taking the unit to a TV repair store in my city and told the guy which caps people where replacing and he gave me all the necessary ones. This is my first time soldering anything to pcb but Ive done a bunch of audio installs in cars. I just replaced all the caps I was given but now the dac wont power on. No lights or anything, its not the wall socket. Before it would work and play sound but with that high pitched ringing I mentioned. None of the terminals got soldered together, so no shorting from that, I feel like I did a good job on soldering everything but still it has to be that since it powered on before I messed with it. I still have the stock crap opamps but I dont think that would keep it from powering on would it? Like I said the only variable was me soldering in the new caps. Ill post some pictures and maybe someone can catch something Im not seeing but Ive looked the thing over and checked polarity a bunch of times already. Any advice would be much appreciated! 

 

http://i.imgur.com/M5PxT0w.jpg

 

http://i.imgur.com/87RIuwT.jpg

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Dedicated Source Components
Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › SMSL SD-1955+ high pitch ringing