or Connect
Head-Fi.org › Forums › Equipment Forums › Computer Audio › EAC help please!
New Posts  All Forums:Forum Nav:

EAC help please!

post #1 of 11
Thread Starter 

Hi all,

 

Just getting back into ripping my cd's onto my hard drive. I have used EAC in the past (quite recently) and today it quit ripping mp3's. I used to keep the wav for archive and mp3 for my ipod.

 

I have EAC v1.0 beta 3 (2011) and LAME 3.99.5

 

I think it may have to do with compression options > additional command-line options. My kids might have touched my computer.

 

post #2 of 11
Thread Starter 

Did a search on Google! And any of the recommended settings produce an error. Example

 

-V2 --ta "%a" --tt "%t" --tg "%m" --tl "%g" --ty "%y" --tn "%n" %s %d

 

http://wiki.hydrogenaudio.org/index.php?title=EAC_and_Lame

 

post #3 of 11

replace the last 2 variables with

 

"%s" is now "%source%" and "%d" is now "%dest%"

post #4 of 11

Here's my EAC additional command line options although I'm using FLAC encoder:

 

-6 -V -T "ARTIST=%artist%" -T "TITLE=%title%" -T "ALBUM=%albumtitle%" -T "DATE=%year%" -T "TRACKNUMBER=%tracknr%" -T "GENRE=%genre%" -T "COMMENT=%comment%" -T "BAND=%albuminterpret%" -T "ALBUMARTIST=%albuminterpret%" -T "COMPOSER=%composer%" %haslyrics%--tag-from-file=LYRICS="%lyricsfile%"%haslyrics% -T "DISCNUMBER=%cdnumber%" -T "TOTALDISCS=%totalcds%" -T "TOTALTRACKS=%numtracks%" %hascover%--picture="%coverfile%"%hascover% %source% -o %dest%

 

Plenty to choose from!

post #5 of 11
-V2 --id3v2-only --pad-id3v2 --ta "%artist%" --tt "%title%" --tg "%genre%" --tl "%albumtitle%" --ty "%year%" --tn "%tracknr%/%numtracks%" %source%

 

You could try something like this.  

 

http://wiki.hydrogenaudio.org/index.php?title=EAC_and_Lame

post #6 of 11
Thread Starter 

I have tried using the new naming convention, and EAC still does not produce an mp3 any more. I get the wav, just no mp3.

 

In the mean time, I've been using Media Espresso to compress the wav's into mp3's. This is driving me nuts!!!

post #7 of 11

Try using CUETools it's much easier to configure than EAC.

post #8 of 11

SHIFT-F6 vs. F6? F6 will only produce the WAV. SHIFT-F6 invokes the WAV rip and after done with WAV automatically starts the compression add-on. Barring that, uninstall/reinstall.

post #9 of 11
Thread Starter 

Just uninstalled, deleted folder, used Ccleaner, rebooted and reinstalled. Posted encoder test:

 

Warning: Spoiler! Encoder Test (Click to show)
LAME 3.99.5 64bits (http://lame.sf.net)
CPU features: SSE (ASM used), SSE2 (ASM used)
Using polyphase lowpass filter, transition band: 20094 Hz - 20627 Hz
Encoding etmp!)2-2.wav to etmp!)2-2.mp3
Encoding as 44.1 kHz j-stereo MPEG-1 Layer III (4.4x) 320 kbps qval=2
    Frame          |  CPU time/estim | REAL time/estim | play/CPU |    ETA 
     0/       ( 0%)|    0:00/     :  |    0:00/     :  |         x|     :  
00:08--------------------------------------------------------------------------
   kbps      %     %                                                           
     0/308    ( 0%)|    0:00/    0:00|    0:00/    0:00|   0.0000x|    0:00    
00:08--------------------------------------------------------------------------
   kbps      %     %                                                           
   100/308    (32%)|    0:00/    0:00|    0:00/    0:00|   30.732x|    0:00    
-------------------------00:05-------------------------------------------------
   kbps        LR    MS  %     long switch short %                             
   200/308    (65%)|    0:00/    0:00|    0:00/    0:00|   30.914x|    0:00    
-------------------------------------------------00:02-------------------------
   kbps        LR    MS  %     long switch short %                             
   300/308    (97%)|    0:00/    0:00|    0:00/    0:00|   30.853x|    0:00    
-------------------------------------------------------------------------00:00-
   kbps        LR    MS  %     long switch short %                             
   308/308   (100%)|    0:00/    0:00|    0:00/    0:00|   30.945x|    0:00    
-------------------------------------------------------------------------------
   kbps        LR    MS  %     long switch short %                             
  320.0       97.7   2.3        98.1   1.3   0.6                               
Writing LAME Tag...done
ReplayGain: -6.9dB
 
post #10 of 11
Thread Starter 

^^^ seems to have worked....

post #11 of 11

happy days!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › EAC help please!