or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear ›  DX90. 2X Sabre,1st page: Downloads, info&inst. . ! Lurker0 FW Mod link 1st page !!. .NEW FW! 2.3.0 . . . . .
New Posts  All Forums:Forum Nav:

DX90. 2X Sabre,1st page: Downloads, info&inst. . ! Lurker0 FW Mod link 1st page !!. .NEW FW! 2.3.0 . . . . . - Page 334

post #4996 of 13841

Actually it is still the 15th here.  Holding out hope.

post #4997 of 13841
Quote:
Originally Posted by Mython View Post
 

 

Don't blame iBasso - blame Microsoft for their decades of indifference and incompetence


This is a topic for another forum, however I will say in MS's defense that they do not cherry pick what hardware they support like other companies and therefore have to develop drivers for everything instead of a minute amount of selected hardware.

post #4998 of 13841
Did anyone hear about the new firmware that was supposed to be released today??
post #4999 of 13841
Thread Starter 
Per an email very soon.
post #5000 of 13841
Quote:
Originally Posted by jamato8 View Post

Per an email very soon.
Do I have to sign up or register my product with ibasso or email them directly?
post #5001 of 13841
Quote:
Originally Posted by HeatFan12 View Post
 

Simple question without flaming please :D...I have used iBasso products through the years, so the faith is there, just don't want to go through this whole thread before pulling the trigger.

 

Does the DX90 handle gapless playback flawlessly?  No clicks, pops, gaps etc....Basically as good as the CD rip?

 

Thanks

 

Cheers!!!!!

 

No more clicks alright, but there is still some random 2 second cut the the end of each song. Sometimes it's noticeable sometimes not. It's sort of random thing.

post #5002 of 13841
Quote:
Originally Posted by jamato8 View Post

Per an email very soon.
Hope it can out today such that I can enjoy it on this weekend,
post #5003 of 13841
Quote:
Originally Posted by headwhacker View Post

No more clicks alright, but there is still some random 2 second cut the the end of each song. Sometimes it's noticeable sometimes not. It's sort of random thing.

Well I heard this 2 sec thing for quite some time but it never happened to the 300GB of files I tried playing on my dx90 thus far? Both gapless album (concerts mostly) and normal album never gave me this 2 second thing even once. Vast majority (90%) of my rips are in .flac and rest are mostly 320k mp3. I recall having early cutting issue with my ak100 but that was only for mp3 encoded in vbr and was told the variable bit rate screwed with the firmware trying to determine how long the track really is. I haven't tried any vbr mp3 on dx90 as I had almost reripped everything to flac over the years now. Wonder what kind of files are giving you issues?
post #5004 of 13841

I have finally ordered mine!:D

The price on mp4nation is great with the free gift but I do not really need another earphone.

 

Found it for sale at a store called eglobalcentral.com for $388. (I don't think I can post the link here, so please just enter the site and search DX90 if you like to).

 

Their customer service told me that they are shipping from Hong Kong with free UPS. I was born in HK and know the shops there are a little more trustworthy than those in China.

They have the standard 14-days return and 2-years "in-house" warranty. They said they will replace mine with a new one under warranty, but I am not very sure...

I paid with Paypal as I can use its buyer's protection if anything bad happened (on the first month).:rolleyes:

 

I will post updates and tell you guys how long it will take to arrive. Time to dig through the thread...:beerchug:

post #5005 of 13841
Quote:
Originally Posted by kkcc View Post

Well I heard this 2 sec thing for quite some time but it never happened to the 300GB of files I tried playing on my dx90 thus far? Both gapless album (concerts mostly) and normal album never gave me this 2 second thing even once. Vast majority (90%) of my rips are in .flac and rest are mostly 320k mp3. I recall having early cutting issue with my ak100 but that was only for mp3 encoded in vbr and was told the variable bit rate screwed with the firmware trying to determine how long the track really is. I haven't tried any vbr mp3 on dx90 as I had almost reripped everything to flac over the years now. Wonder what kind of files are giving you issues?

All my files are CD ripped ALAC and downsampled hi-res downloads also in ALAC. Problem is when I encounter the problem and try to recreate it, doesn't happen on the same files. Can't really pin down the exact condition when the issue exactly happens.

However, it seldom happens that it does not bother me. But when it happens I will certainly notice.
Edited by headwhacker - 5/15/14 at 7:04pm
post #5006 of 13841
Quote:
Originally Posted by headwhacker View Post

All my files are CD ripped ALAC and downsampled hi-res downloads also in ALAC. Problem is when I encounter the problem and try to recreate it, doesn't happen on the same files. Can't really pin down the exact condition when the issue exactly happens.

However, it seldom happens that it does not bother me. But when it happens I will certainly notice.

See... Don't have alac files now and can't try, but would be hard to nail down if it is not consistently reproducible. Does it happen to playlist, or shuffle, or album? I don't use playlist nor shuffle that much as I usually go album by album. In any case good that it is not happening much even for you and didn't bothered you.
post #5007 of 13841
Quote:
Originally Posted by kkcc View Post

See... Don't have alac files now and can't try, but would be hard to nail down if it is not consistently reproducible. Does it happen to playlist, or shuffle, or album? I don't use playlist nor shuffle that much as I usually go album by album. In any case good that it is not happening much even for you and didn't bothered you.

I don't do shuffle, just play by album from the folder view or DB.
post #5008 of 13841
Quote:
Originally Posted by headwhacker View Post
 

 

No more clicks alright, but there is still some random 2 second cut the the end of each song. Sometimes it's noticeable sometimes not. It's sort of random thing.

 

 

Quote:
Originally Posted by kkcc View Post


Well I heard this 2 sec thing for quite some time but it never happened to the 300GB of files I tried playing on my dx90 thus far? Both gapless album (concerts mostly) and normal album never gave me this 2 second thing even once. Vast majority (90%) of my rips are in .flac and rest are mostly 320k mp3. I recall having early cutting issue with my ak100 but that was only for mp3 encoded in vbr and was told the variable bit rate screwed with the firmware trying to determine how long the track really is. I haven't tried any vbr mp3 on dx90 as I had almost reripped everything to flac over the years now. Wonder what kind of files are giving you issues?

 

 

Thanks!!!

 

:beerchug:

post #5009 of 13841
post #5010 of 13841
Quote:
Originally Posted by headwhacker View Post


I don't do shuffle, just play by album from the folder view or DB.

Wait I can play via folder

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear ›  DX90. 2X Sabre,1st page: Downloads, info&inst. . ! Lurker0 FW Mod link 1st page !!. .NEW FW! 2.3.0 . . . . .