or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear ›  DX90. 2X Sabre,1st page: Downloads, info&inst. . ! Lurker0 FW Mod link 1st page !!. .NEW FW! 2.3.0 . . . . .
New Posts  All Forums:Forum Nav:

DX90. 2X Sabre,1st page: Downloads, info&inst. . ! Lurker0 FW Mod link 1st page !!. .NEW FW! 2.3.0 . . . . . - Page 333

post #4981 of 13841
Depends on what you want from a UI. For me the DX90 just works
post #4982 of 13841
Quote:
Originally Posted by nc8000 View Post

Depends on what you want from a UI. For me the DX90 just works

some of the guys in the bug thread are reporting issues with the Shuffle mode, all I need my DAP to do is shuffle music and MAYBE I WOULD FREAKING LOVE some Folder Structure play ability, you know select a folder and play everything inside of it including all sub folders 

post #4983 of 13841

Hmm...I really have to bang the drum for the DX90 in regards to it's usability. OK, it's not perfect (what UI is??) at this stage but if you have a qiute decent folder structure and/or a good file-tagging, you won't have any troubles. So far my DX90 never froze or showed an odd behaviour^^

 

Let's see what an upcoming firmware can do..:wink_face: 


Edited by droid23 - 5/15/14 at 2:13pm
post #4984 of 13841
Thread Starter 

What doesn't work on the UI of the DX90? I load the music. Can go by one of two methods to the music, go to the album, pick the song, it plays. There are many other functions as well but it all works. They will also have a new FW in a day or two for little things. Its all good. 

post #4985 of 13841

Has anyone problems with USB 3.0?

Any time I connect my DX90 to the USB 3.0 port on my Lenovo T420 (Windows 7 64bit) I get a popup asking "Do you want to scan and fix ..."

After I click on "Scan and Fix (recommended)", it tells me that it did not find any error.

This does not happen when I connect the DX90 to the USB 2.0 port on the same laptop.

 

My DX50 did not show any problem when connected to the same USB 3.0 port.

 

Thanks!

post #4986 of 13841
Quote:
Originally Posted by alias71 View Post
 

Has anyone problems with USB 3.0?

Any time I connect my DX90 to the USB 3.0 port on my Lenovo T420 (Windows 7 64bit) I get a popup asking "Do you want to scan and fix ..."

After I click on "Scan and Fix (recommended)", it tells me that it did not find any error.

This does not happen when I connect the DX90 to the USB 2.0 port on the same laptop.

 

My DX50 did not show any problem when connected to the same USB 3.0 port.

 

Thanks!

 

I get that B$ message from Win7 on loads of different USB storage devices. Windows is flawed, flawed, flawed, so please don't let it concern you about the DX90 itself.

 

 

I do notice that Win7 doesn't like a USB device being connected that has more than one memory chip, if the device in question is set to operate in 'MSC' mode, but tends to behave itself better if the device is set to 'MTP' mode. It happens like that with my Cowon J3 DAP, for example (32gb onboard memory + a 64gb MicroSD card)

 

But I just don't worry about it - I tell Win7 to shut-up every time it B$s me about needing to 'scan and fix', and I always decline the option to go ahead and 'scan & fix'. I would never trust Microsoft to 'fix' any storage device error - they're disgracefully incompetent. I was once told, by a programmer, that Windows Checkdisk (which tries to run during boot-up, if a Windows machine has been shutdown too quickly) simply deletes any truncated entries on the file structure table, rather than doing what any responsible program would do and either back up the truncated entries or attempt to actually fix them.

 

Seriously - NEVER allow Microsoft to check or alter any of your disks or files.

 

 

 

.


Edited by Mython - 5/15/14 at 3:17pm
post #4987 of 13841

Hello,

i have a problem :
i have formatted  per error, the internal memory of my DX90, on mac os.
i wanted to format the micro sd external card.
since, when i connect the DX90 to my mac, the internal memory is not visible, it can not be seen.
what shall i do now ?

reset factory, but nothing !!!
use pc windows 7 pro, nothing

need help please


sam

post #4988 of 13841
Quote:
Originally Posted by Samuel777 View Post
 

Hello,

i have a problem :
i have formatted  per error, the internal memory of my DX90, on mac os.
i wanted to format the micro sd external card.
since, when i connect the DX90 to my mac, the internal memory is not visible, it can not be seen.
what shall i do now ?

reset factory, but nothing !!!
use pc windows 7 pro, nothing

need help please


sam

 

 

First things first; try completely removing the memory card, and then try a factory reset.

 

Let us know what happens, and we can take it from there...

post #4989 of 13841

Simple question without flaming please :D...I have used iBasso products through the years, so the faith is there, just don't want to go through this whole thread before pulling the trigger.

 

Does the DX90 handle gapless playback flawlessly?  No clicks, pops, gaps etc....Basically as good as the CD rip?

 

Thanks

 

Cheers!!!!!

post #4990 of 13841
Quote:
Originally Posted by alias71 View Post
 

Has anyone problems with USB 3.0?

Any time I connect my DX90 to the USB 3.0 port on my Lenovo T420 (Windows 7 64bit) I get a popup asking "Do you want to scan and fix ..."

After I click on "Scan and Fix (recommended)", it tells me that it did not find any error.

This does not happen when I connect the DX90 to the USB 2.0 port on the same laptop.

 

My DX50 did not show any problem when connected to the same USB 3.0 port.

 

Thanks!

 

I had that happen when I initially got the unit. I was plugged into USB 2. I let Windows fix it and haven't had it happen since. In theory, you could get that if you don't do an eject before unplugging the DX90 from USB. This is similar to any USB stick; Windows may have write cache turned (or a write operation that hasn't finished) and it'll mark the disk dirty.

 

//TB

post #4991 of 13841
Quote:
Originally Posted by docBliny View Post

I had that happen when I initially got the unit. I was plugged into USB 2. I let Windows fix it and haven't had it happen since. In theory, you could get that if you don't do an eject before unplugging the DX90 from USB. This is similar to any USB stick; Windows may have write cache turned (or a write operation that hasn't finished) and it'll mark the disk dirty.

//TB

If only there were an improved firmware and driver...xD

Kojaku
post #4992 of 13841
Quote:
Originally Posted by Kojaku View Post


If only there were an improved firmware and driver...xD

Kojaku

 

Don't blame iBasso - blame Microsoft for their decades of indifference and incompetence

post #4993 of 13841
Quote:
Originally Posted by Mython View Post

Don't blame iBasso - blame Microsoft for their decades of indifference and incompetence

Well apparently its more of an issue of driver security approval (at least for Windows 8).

Kojaku
post #4994 of 13841
Quote:
Originally Posted by Mython View Post
 

 

 

First things first; try completely removing the memory card, and then try a factory reset.

 

Let us know what happens, and we can take it from there...

i removed the memory card and tried factory reset and it does not work.

the capacity of internal memory is appearing 0 GB

post #4995 of 13841

Any news about FW update or usb dac driver? the 15th has passed...

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear ›  DX90. 2X Sabre,1st page: Downloads, info&inst. . ! Lurker0 FW Mod link 1st page !!. .NEW FW! 2.3.0 . . . . .