Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › iPod Classic 5th Gen Sound Issues
New Posts  All Forums:Forum Nav:

iPod Classic 5th Gen Sound Issues

post #1 of 9
Thread Starter 

Hi there, new to the forums. 

 

I haven't found anything regarding my issue so I'm asking here.

 

After not using it for ~4 years, the sound just sounds bad.  I have multiple sets of headphones, from older bose to cheap over ears.  Even with my Meelec M9P's the bass is lacking, and the sound is sort of "mushy" and washed out.  Quite honestly, I'd rather listen to music on my crappy android.  Also, all music is high rate mp3, which shouldn't really matter when not using amazing headphones.  

 

So to my question, is there anything I am missing as to why my iPod sounds so bad,  like any "secret settings"?


Edited by bigeye135 - 12/19/13 at 10:07am
post #2 of 9
These are generally said to have good sonics (mine sounds great!). I'd check the EQ settings as it's also known that the EQ feature in IP's is awful. Make sure it set to 'flat' or 'off' (same thing).
post #3 of 9
Thread Starter 
Quote:
Originally Posted by Hijodelbrx View Post

These are generally said to have good sonics (mine sounds great!). I'd check the EQ settings as it's also known that the EQ feature in IP's is awful. Make sure it set to 'flat' or 'off' (same thing).

Weird, my EQ is set to off.  Do you know anyway of increasing the bass (without the terrible EQ) because that appears to be my main issue, the highs and mids are sounding better now.

post #4 of 9
Welcome to the forum bigeye135. The 5th gen iPod is quite highly regarded in terms of sound quality. What sort of player or players did you listen to for the four years you were not using your Classic? It could be that it has developed a fault although these units are very reliable. The bass is probably a slight weak spot on the 5th gen other players having a little more bass punch and better extension.
post #5 of 9
Thread Starter 

Thank you!

 

The only one's I have used are the iPod Touch 4g and my cheap android.  After listening for a while more, I can definitely tell how well the highs and mids sound, but as a basshead it seems nearly nonexistent.  I guess eventually I will just get used to it.

post #6 of 9
There's s various ways to change what you're hearing but they'll all require you spending money. I use a Fiio E12 amp that's really terrific and features a bass boost switch. Fiio makes other products that aren't too expensive that can help, there's quite a few threads here that you can check out.
post #7 of 9
If you like extra bass then the 5G is no use as it has diminished bass. The iPod Touch 4G is less suited to full sized headphones and more aimed at IEMs, its also fairly neutral. Other players like Sony, Cowon will give good sound quality with colouration and options for enhancing bass. Sennheisers HD485 had a lot of bass as does Beyerdynamics DT990 if you listen at home (both full size headphones). Fiio's X3 and Hifiman's HM601 are both warm players but high quality also.
post #8 of 9
Thread Starter 

If anyone sees this, I installed rockbox.  Sounds much better plus the EQ is a million times better than the default apple one.

post #9 of 9

Rockbox has a lot more EQ features than the standard ipod and some great xfeed functions to tweak with. I'm sure that's the change you are hearing. 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Dedicated Source Components
Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › iPod Classic 5th Gen Sound Issues