or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Tiamat 7.1 having trouble getting them to sound good
New Posts  All Forums:Forum Nav:

Tiamat 7.1 having trouble getting them to sound good

post #1 of 2
Thread Starter 

I have been thinking getting a pair of Tiamat 7.1 for awhile and when I saw they were $130 on Newegg on cyber Monday I picked them up along with an Asus DSX sound card. I installed the sound card np and I'm 99.9% certain I plugged everything in correctly, and simply put...they sound like crap. Default settings out of the box sounded like absolute garbage. I spent most of my night last night tweaking with the Xonar DSX audio settings (software that accompanies my sound card) and I was able to make them sound better than they were by messing with EQ and turning on some effects, but they still have this strange tinny, echoy, sort of tunnel sound to them and I can't stand it.

 

I'm not terribly knowledgeable when it comes to audio. Am I missing some magic button or check box somewhere or did I sadly make a bad purchase?

 

I've gone on google a hundred different times and it's either people saying they are super awesome or the worst ever. I don't know what to believe...

post #2 of 2
Check the jack, maybe you didn't push it all in.

Billson. smily_headphones1.gif
New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Tiamat 7.1 having trouble getting them to sound good