or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Sony XBA-C10 and XBA-1 suffering from left channel distortion.. Sony and left channel only? ( mystery! )
New Posts  All Forums:Forum Nav:

Sony XBA-C10 and XBA-1 suffering from left channel distortion.. Sony and left channel only? ( mystery! )

post #1 of 7
Thread Starter 

I own both of these Ba iems and both of them distorts in the left channel on some mid bass notes. I find it odd since i have not played them very loud and i don´t have this problem with any other IEMS or headphones. And why is it only the left channel that distorts and crackles? I can´t imagine its a BA-thing, and since it is only audible with the Sonys.. It makes me wonder.

 

It´s a mystery that i was hoping the forum could solve for me :P

post #2 of 7

Do you have the eq or bass turned way up? I have the C10s and when messing with the Rockbox equalizer they distorted when some bass freqs were turned up way higher than I would actually use.

post #3 of 7
Thread Starter 

No EQ what so ever, not on my phone or with my headstreamer or any other source..The funny thing is, that i hade this problem with my Sony zx-700 also.. Starting to doubt my sanity tbh :/

post #4 of 7

I have the same problem with XBA H3 :blink::confused_face_2: 

post #5 of 7
Thread Starter 
Quote:
Originally Posted by Navneet773 View Post
 

I have the same problem with XBA H3 :blink::confused_face_2: 

That the left driver sounds like its busted?

post #6 of 7

yea ... its seems like it cracks when bass heavy tracks come this is damn weird bro

post #7 of 7

but only left one :(

New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Sony XBA-C10 and XBA-1 suffering from left channel distortion.. Sony and left channel only? ( mystery! )