Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Left earbud went out for 2 headphones at the same time? Read more for juicy details
New Posts  All Forums:Forum Nav:

Left earbud went out for 2 headphones at the same time? Read more for juicy details

post #1 of 2
Thread Starter 

Ok so check this, I left two pairs of headphones one being a monster turbine pro gold and the other a Meelectronics M9 on my desk.  I left my MTPG connected to the ipod touch while the M9 was just chilling next to it on the wooden table.  My ipod was connected to my computer and was playing music to try and burn in the MTPGs at a medium sound level.  It sat there for about 6 hours.  Then when it came time to listen to my turbines, the left earbud was barely emitting any sound!!?  Mind you these are only a week old and I didn't even touch the things cause they've been sitting there on my desk.  So already pissed off, I try listening to my M9s which are about a month old and guess what the left earbud in that is screwed up as well...  Same exact problem.  Both new headphones screwed up in the same way when they've just been chilling on my desk...  Do you guys have any idea how the heck this is possible?  

post #2 of 2
Thread Starter 

Also I've been babying my MTPGs, aka not tying it around my ipod and both were in working condition before I left them on the table...  As far as the headphones look, there's no damage on the cord whatsoever for both.


Edited by Ascension646 - 11/17/13 at 4:36pm
New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Left earbud went out for 2 headphones at the same time? Read more for juicy details