or Connect
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Just upgraded my video card from a GTX 470 to a GTX 770 and I'm getting ASIO and WASAPI dropouts
New Posts  All Forums:Forum Nav:

Just upgraded my video card from a GTX 470 to a GTX 770 and I'm getting ASIO and WASAPI dropouts

post #1 of 11
Thread Starter 

Hey guys. I just posed this to what I thought was the main ASIO thread but I just realized that thread hasn't been posted to in a long time so I thought I better start a new thread:

 

 

 

I've been using ASIO for some time now (currently running ASIO4ALL v2.11 Beta2) and I love it. It does sound better than going through the Windows sound mixer (although not a huge difference) and I've gotten into the habit of always using ASIO when I'm listening to music. I have the HRT MS2 and MS2+ USB DACs as well as an iBasso D-Zero.

 

I just upgraded from an Nvidia GTX 470 to a GTX 770 and I'm getting a lot of dropouts, clicking, and buzzing through both ASIO and WASAPI. It seems to be worse when I'm listening to larger files (24/96 for example). It appears to me that the GTX 770 is introducing too much latency into the system. I've already given away the GTX 470 to a friend but I put an old 8500 GT that I had lying around into the computer and the problem went away and everything worked fine, as it did on the GTX 470. So it appears the GTX 770 is causing too much latency and pretty much ruining my ability to listen to bit-perfect streams because while the static and dropouts are not constant its enough to really bother me.

 

By the way, I'm using the MSI Gaming N770 TF 2GD5/OC. When I have the 770 in, LatencyMon shows a higher max execution time for nvlddmkm.sys, the Nvidia driver. With the 8500 GT in it maxed out at about 0.45ms and was the 2nd in the list. With the 770 it maxes out at about 0.7ms and on other occasions has reported well over 2ms and is always at the very top of the list.

 

So I'm wondering if anyone else has come across something like this? Currently my plan is to order a new GTX 770 today, this time an EVGA branded GTX 770, and hope that that doesn't have the issue but in the back of my mind I can't escape this worry that this is something all of the 700 series struggle with. One of the recommendations I found online for dealing with ASIO/WASAPI/realtime audio dropouts is to disable CPU power management or downclocking so that makes me wonder if Nvidia's new GPU Boost 2.0 is causing the problem (GPU Boost constantly adjusts the GPU frequency based on usage). GPUs tend to not be very different from one manufacturer to the next, at least for the same GPU chip, but the MSI does have a custom PCB and cooler. I'm really hoping a GTX 770 from a different brand won't have the same problem.

 

Anyway, any thoughts on this would be appreciated. I've tried everything else I can think of so its looking like I'll have to buy a new one and see if the problem goes away and then return the MSI 770 to Amazon. I'll let you guys know if I do that and what happens, in case others run into the same problem.

 

Thanks

 

BTW, I'm on Windows 7 SP1 64bit

Gigabyte EX58-UD3R motherboard

Intel i7-920, not currently overclocked

MSI GTX 770 (N770 TF 2GD5/OC)

16 GB RAM

 

HRT Music Streamer II

HRT Music Streamer II+

 

The ASIO & WASAPI crackling, buzzing, and dropouts that happen with the GTX 770 happen equally on both the MS2 and MS2+. I haven't tried the D-Zero but I'm assuming it will have the same issues.

 

Things I've tried so far:

 

* Updated to the latest BIOS for my motherboard, didn't help.

* I'm using the latest Nvidia drivers. I am going to try an older driver today so I'll let you know.

* I was originally overclocking the card to roughly 1100MHz base clock. Using its original settings makes no difference. BTW, the card has a slight factory overclock of ~ 1080Mhz base.

* Plugged the card into a different PCI-Express slot, didn't help.

* Used a different set of power cables to connect to the card's two 8-pin PCI Express power connections, didn't help.

* Uninstalled MSI Afterburner (overclocking and GPU monitoring app), didn't help.


Edited by devhen - 11/13/13 at 1:47am
post #2 of 11
Thread Starter 

It just occurred to me that what might be most helpful would be to find others with GTX 770 cards. I'm hoping there are some other head-fi'ers out there that have this card and can tell me how ASIO and WASAPI perform for them.

post #3 of 11

Have you tried increasing the buffer length?

 

Are you using a lot of programs that pole your system (measuring temps, clocks, etc)? Those would definitely cause jitter. Download this and see if your DPC is high: http://www.thesycon.de/deu/latency_check.shtml

 

I don't think it's your GPU. It sounds like a software issue.

post #4 of 11
Quote:
Originally Posted by ohhgourami View Post
 

It sounds like a software issue.

 

Agree with that.

 

Did you try another music player?

post #5 of 11
Thread Starter 

Thanks for the responses guys.

 

Yeah I've been using DPC Latency Checker all along (as well as LatencyMon). The problem seems to have gone away. I think what did it was disabling HPET in my BIOS which resulted in much lower values in DCP Latency Checker. I went from averaging around 100-150µs with HPET enabled to averaging 15-35µs with it disabled. It does still spike up to 100-150µs occasionally though. I haven't heard any more buzzing or significant dropouts since doing that. I do use MSI Afterburner and it does a lot of polling but it never made a difference in how much buzzing and dropouts I got. I tried uninstalling it several times for extended amounts of time and it didn't make a difference.

 

What made it hard to debug in the end was that apparently both my MS2 and MS2+ have some kind of bug where when you first switch into 88.2khz mode it will start skipping but if you restart the song it goes away. I eventually realized what was happening and did a ton of testing and found that it only ever happens when switching from another sample rate to 88.2khz and both the MS2 and MS2+ do it but the D-Zero does not. I think the MS2's use the same USB chip so that kind of makes sense. Anwyway, I have a few HD albums in 88.2 so I was noticing that in testing and I originally assumed it was related to the buzzing and dropouts.

 

So at this point ASIO seems to be working fine for me. Now that I'm aware of that 88.2khz bug its easy enough to deal with and other than that ASIO seems to be working as well as it did before I got the GTX 770. That is, it works 99.9% of the time. Very occasionally there will be a small click thats very minimal, as if a single bit failed, and that I can deal with.

 

I still feel like the GTX 770 is causing more latency than the GTX 470 did. For one thing, the 470 didn't require HPET to be disabled. But I'm just happy its working. For those with similar issues I recommend looking into disabling HPET. I've read that some ASUS motherboards don't give you the option in their BIOS but GIGABYTEs do, which mine is, and most others probably do as well. It will be under power management options in the BIOS.

 

Anyway thanks for the responses guys and I'll let you know what happens since unfortunately I've probably not had my last run-in with latency issues. Now that I'm aware of it and how to monitor it and listen for dropouts, I notice every little imperfection and it can be frustrating at times but all in all my system is running quite well and ASIO is streaming very well so I'm happy.


Edited by devhen - 11/14/13 at 3:37am
post #6 of 11
Thread Starter 

A bit of an update..

 

I've been running my i7-920 at default clocks because the cheap plastic clips securing my huge air cooler gave way and I had to go back to the stock cooler. Today I finally got a new cooler and I've got it overclocked again, at a very stable 3.8GHz like it was before. I noticed while overclocking that by default when you overlclock the CPU in the BIOS it disables the CPU's power saving / downclocking features. So its running at a constant 3.78GHz at all times which bothered me at first until I looked at DPC Latency Checker. I'm floating around 10 - 13 µs, sometimes as low as 8 µs with virtually no spikes at all. These are definitely the lowest latency numbers I've seen yet. When i re-enabled the power saving / downclocking it went back to 100-150 µs and I was getting buzzing again. With those disabled the latency is now as low as its ever been on this machine and all of my ASIO problems are gone.

 

Moral of the story: if you're having latency issues try disabling any CPU power saving features in the BIOS. For a typical computer I would probably leave them on for the slightly better idle power consumption but for a head-fi station I'd much rather have the lower latency.


Edited by devhen - 11/14/13 at 5:21pm
post #7 of 11
Quote:
Originally Posted by devhen View Post
 

A bit of an update..

 

I've been running my i7-920 at default clocks because the cheap plastic clips securing my huge air cooler gave way and I had to go back to the stock cooler. Today I finally got a new cooler and I've got it overclocked again, at a very stable 3.8GHz like it was before. I noticed while overclocking that by default when you overlclock the CPU in the BIOS it disables the CPU's power saving / downclocking features. So its running at a constant 3.78GHz at all times which bothered me at first until I looked at DPC Latency Checker. I'm floating around 10 - 13 µs, sometimes as low as 8 µs with virtually no spikes at all. These are definitely the lowest latency numbers I've seen yet. When i re-enabled the power saving / downclocking it went back to 100-150 µs and I was getting buzzing again. With those disabled the latency is now as low as its ever been on this machine and all of my ASIO problems are gone.

 

Moral of the story: if you're having latency issues try disabling any CPU power saving features in the BIOS. For a typical computer I would probably leave them on for the slightly better idle power consumption but for a head-fi station I'd much rather have the lower latency.


If you're worried about having your CPU run at max OC, you might need a better cooler. Or maybe provide better airflow.

 

Rule of thumb for audio; disable the following:

-All power saving features

-Onboard sound

 

You might also want to reinstall your nvidia drivers.

post #8 of 11
Thread Starter 
Quote:
Originally Posted by ohhgourami View Post


If you're worried about having your CPU run at max OC, you might need a better cooler. Or maybe provide better airflow.

 

Rule of thumb for audio; disable the following:

-All power saving features

-Onboard sound

 

You might also want to reinstall your nvidia drivers.

 

Good advice.

 

I'm not worried about my CPU running at max OC, the new liquid CPU cooler I got is working great (Corsair H55 with Noctua NF-S12A fan).

 

On the Nvidia drivers..... I can't tell you how many times I uninstalled them, reinstalled them, installed older versions, etc, while trying to figure this latency issue out. None of that ever helped but its worth a try if someone is having problems. For me the only things that reduced latency enough to solve my ASIO dropouts was disabling HPET and CPU power saving features in the BIOS.

 

BTW, I've got onboard sound enabled because I've got my Klipsch ProMedia 2.1 PC speakers connected to it and it doesn't cause any issues, latency-wise or otherwise. I like to keep it enabled so I can periodically use my PC speakers when I want to quickly listen to something without having to disable ASIO's exclusive lock on my DAC.

post #9 of 11
Quote:
Originally Posted by devhen View Post
 

 

Good advice.

 

I'm not worried about my CPU running at max OC, the new liquid CPU cooler I got is working great (Corsair H55 with Noctua NF-S12A fan).

 

On the Nvidia drivers..... I can't tell you how many times I uninstalled them, reinstalled them, installed older versions, etc, while trying to figure this latency issue out. None of that ever helped but its worth a try if someone is having problems. For me the only things that reduced latency enough to solve my ASIO dropouts was disabling HPET and CPU power saving features in the BIOS.

 

BTW, I've got onboard sound enabled because I've got my Klipsch ProMedia 2.1 PC speakers connected to it and it doesn't cause any issues, latency-wise or otherwise. I like to keep it enabled so I can periodically use my PC speakers when I want to quickly listen to something without having to disable ASIO's exclusive lock on my DAC.


You could always have your PC speakers connected to your DAC. That's what I do.

post #10 of 11
Thread Starter 
Quote:
Originally Posted by ohhgourami View Post


You could always have your PC speakers connected to your DAC. That's what I do.

 

Yeah I had just been thinking about doing that. I'd rather not have to swap out the RCA cables depending on whether I'm listening to my headphones or PC speakers but now that I have two DACs (MS2 & MS2+) I'll probably go ahead and disable onboard sound.

post #11 of 11

Maybe using an RCA splitter would simplify things. Then have an dual RCA to 3.5mm adapter for the speakers.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Just upgraded my video card from a GTX 470 to a GTX 770 and I'm getting ASIO and WASAPI dropouts