Head-Fi.org › Forums › Equipment Forums › Computer Audio › Computer is not automatically switching audio devices when plugging in a MODI
New Posts  All Forums:Forum Nav:

Computer is not automatically switching audio devices when plugging in a MODI

post #1 of 10
Thread Starter 

I hope this is in the right forum.. if not, mods, please move it.

 

When I plug the Modi into the USB 2 port of my windows 7 laptop, like I always have, the computer no longer automatically switches audio devices from the realtek audio (internal speakers) to the schiit usb audio.
 
When searching for audio devices, the schiit no longer shows up. However, if I disable the internal speakers, and the Modi is plugged into the usb2 port, the computer solves an error, autonomously, and suddenly it uses the schiit usb audio device.
 
I have to reverse the process (disabling the schiit device) and click the volume button (now with a red cross over it, no audio device selected) for the computer to self correct and enable the realtek audio device.
 
Does anyone know what I should do? I'm not computer savvy enough to diagnose myself, and I already contacted Schiit, who couldn't help...
 
Thanks!
post #2 of 10

Might try installing that latest chip-set drivers.

post #3 of 10
Thread Starter 

Thanks for the response, but I have no idea what drivers to load, where to get them, or how to do that...

post #4 of 10

what laptop are you using?

 

Also just to be sure i understand. When you have the realtek audio enabled and the Modi plugged in at the same time, only the realtek is shown in control panel > sound?


Edited by A_Man_Eating_Duck - 11/8/13 at 1:57pm
post #5 of 10
Thread Starter 

ASUS X54L-BBK2 15.6" Laptop Intel i3-2330M 320GB 4GB ram...

 

When I have the Modi plugged in, and I'm listening to my headphones, the only audio device shown is "Schiit USB Audio Device"

 

When I have the Modi plugged in, realtek enabled, listening to computer speakers, both Speakers choices are showing... (2-Schiit USB Audio Device- ready, and Realtek High Definition Audio Default Device) Both seem to be enabled.

 

I must manually (in some capacity) enable or disable the realtek device, depending on how I want to listen.

post #6 of 10

So you want audio to go to both soundcards at the same time?

 

or do you want the sound to go to the Modi only when it's plugged in?

post #7 of 10
Thread Starter 

I want it to only use the Modi. (When plugged in) Until two weeks ago, I didn't have this problem...

 

I would just plug the Modi in, and the audio device would switch to the Modi. Then when I wanted to use the laptop speakers again, I'd simply unplug the Modi USB. Simple as that.

 

I want the computer to switch like that for me again. 

post #8 of 10

I had a similar problem with my DAC and onboard sound, this is how i fixed it.

 

Make sure both the Modi and realtek are plugged in\enabled.

 

open up control panel > sound and right click on the Modi and set it as the default device.

 

Then unplug the Modi, the default device should change to the realtek. plug the modi back in and the modi will be the default device.

post #9 of 10
Thread Starter 

Ah, thank you!

 

I wonder how it stopped being the default in the first place...

post #10 of 10
Quote:
Originally Posted by headsounds View Post

Ah, thank you!

I wonder how it stopped being the default in the first place...

Windows is flaky. LOL

On my HTPC, Windows is often slow to properly enable the HDMI output to my receiver. On desktop computers, I've seen Windows change the default sound card after some kind of OS update. I just chalk it up to Windows being a little cantankerous smily_headphones1.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Computer is not automatically switching audio devices when plugging in a MODI