Head-Fi.org › Forums › Equipment Forums › Computer Audio › WASAPI.. Am I doing it right?
New Posts  All Forums:Forum Nav:

WASAPI.. Am I doing it right?

post #1 of 4
Thread Starter 

I just read about WASAPI and got it set up in foobar2k. Everything seems to be okay, the volume control isn't working, I have bit-perfect audio checked in record mode, the output is exclusive etc.etc.  However, I read about how X-FI sound cards (I have a Titanium HD) aren't compatible. 

 

My point of confusion is that I am using the X-FI for the optical port which is feeding my Gungnir. I know this stops the effects from working, so does this mean WASAPI works this way?

 

Am I golden? Or do I have to switch to ASIO?

post #2 of 4

Right, as default anything you playback with an X-Fi gets auto converted to whatever sample rate/bit depth you specify under the sound properties.  I.e. control panel / sound properties / "SPDIF Out" / advanced tab / set say "2ch, 24bit, 48khz".  Anything you play back will bypass the onboard DSP (so no cmss, X-Fi crystalizer, EAX effects etc) and get put out the SPDIF output in that format to your external DAC. i.e. up sampled or down sampled.

 

If you play a DVD with Dolby Digital content it will get sent out the same SPDIF interface in the Dolby native format, so if your external DAC happens to be a home AV receiver (i use a Pioneer VSA) it will light up like an xmas tree and output Dolby Digital 5 channel audio + LFE in its native format. If you play a game it can package surround audio into a Dolby stream and upload that to your AV amp giving surround sound if you like that kind of thing. *insert maybe, sometimes, not the most reliable disclaimer.   I don't use it personally as there is only X amount of bandwidth over SPDIF so dolby reduces the sample rate of the channels and then compress's it to fit, just stick to 2ch stereo for a pure audio stream.

 

Now for bit perfect playback, open the "Creative Audio Control Panel", under the "Mode" tab select "Audio Creation Mode", then under the "Bit-Matched" tab you will have an option for "Enable Bit-Matched Playback", this will then output audio via the SPDIF interface in its native bitrate/bit depth.  E.g. if your AV receiver can only do 24bit/48khz and you play a 24bit/96khz audio file you will get silence. Whatever format the file is = the format output. Note: The option for "Enable Bit-Matched Playback" is ONLY AVAILABLE under the "Audio Creation Mode".  Under "Entertainment mode" you only have the option for "Enable Bit-matched Recording", not playback.  Same for "Game Mode", however you must be in this mode for EAX and direct-x acceleration to function in games.

 

Now for WASAPI, once you select "WASAPI (event): SPDIF Out (Creative SB X-Fi)" in foobar, the onboard DSP, AND the windows mixer / audio stack gets bypassed and your audio files get transported directly out the SPDIF port.  Windows volume control will not work (however foobars will), and no other programs in windows will be able to use the audio interface and play any sounds while Foobar has control. As with the above bit-matched playback if your external DAC cannot support the bitrate/bit depth of the file you are playing you will get silence. Note: the audio mode set in the creative audio control panel is irrelevant while using WASAPI, the data just gets dumped out the SPDIF interface so it doesn't matter what mode its in.

 

I think that just about covers it.. the way i used mine for years was with WASAPI in foobar for Music playback, "Audio Creation Mode" with "Bit-matched playback" enabled for watching movies, and "Game Mode" for playing games.  All three were outputting to the Pioneer AV receiver via optical port. Since i bought an O2/ODAC i now only use the X-Fi/Pioneer for Gaming.

 

Hope that helps..


Edited by mcandmar - 11/7/13 at 6:57pm
post #3 of 4
Thread Starter 

Thanks for getting that all in one place for me. I was getting confused searching between threads while I was trying to figure that all out. 

 

I was confused on whether or not the WASAPI would work on the optical. I assumed it was since I noticed a bit of a playback quality increase in some places (I think). I'll investigate tomorrow when I have more time. 

 

What is with the (event) (push) settings? I get an error when I use event. 

post #4 of 4

Yeah and Creatives documentation is less than helpful, i had to figure all that out the hard way so thought i would save you the headache.

 

I cant remember the technical difference between event and push mode, but from memory only one of them is supported so just use whichever of them works.

 

The easiest to verify it is working (apart from the audible difference) is to download a 192khz or 384khz file that your DAC dosent support, if you cant play it your golden.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › WASAPI.. Am I doing it right?