or Connect
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Just bought a pair of Sennheiser HD 598 and right channel doesn't work, suggestions or should I return?
New Posts  All Forums:Forum Nav:

Just bought a pair of Sennheiser HD 598 and right channel doesn't work, suggestions or should I return?

post #1 of 4
Thread Starter 

Just purchased a pair of HD 598s from Amazon. I don't have an amp to play them from, so I'm using

the 3.5mm adaptor (not sure if I'm using it right but it looks like it is just male --> female from the 6mm jack).

 

I've tried it in all of my audio devices, and I cannot get the right channel to play, only the left.

Crud.

Suggestions?

post #2 of 4

Sounds like a defective pair.

post #3 of 4

I've not had great luck with Sennheiser durability-wise, but they're great performance for a budget.

 

Complimentary of the company, their warranty process through the website is very awesome.

 

 

I had/have a pair of px-100 II and one of the ears went out after a few months of purchase (from Amazon).

post #4 of 4

And yes, if I understand right, the black rings around the jack are the left channel and right channel respectively, headsets with a mic attachment get an extra ring.   Judging by that, and experience, more than likely one of the speakers went out.  

New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Just bought a pair of Sennheiser HD 598 and right channel doesn't work, suggestions or should I return?