or Connect
Head-Fi.org › Forums › Head-Fi Special Forums › Premier Sponsor Forums and Sponsor Forums › Premier Sponsor Forums › FiiO › X3 has worked only two months.
New Posts  All Forums:Forum Nav:

X3 has worked only two months.

post #1 of 7
Thread Starter 

Now I have to send it to China for repair - I have bought it from mp4nation.

My previous mp3 player Sansa Fuze (with rockbox) still working from year 2009 - very well that I was not presented my old Sansa to someone after X3 buing.

Yesterday x3 just stopped to turned on with the full battery (green light after charging).

post #2 of 7

I had a similar problem with my Fiio e10. I sent it to China and after more than 2 months so far no news about the device. Try contacting mp4nation first.

post #3 of 7
Quote:
Originally Posted by otaran View Post
 

Now I have to send it to China for repair - I have bought it from mp4nation.

My previous mp3 player Sansa Fuze (with rockbox) still working from year 2009 - very well that I was not presented my old Sansa to someone after X3 buing.

Yesterday x3 just stopped to turned on with the full battery (green light after charging).

 

 

did you try to reset the X3 first ?

post #4 of 7
Thread Starter 

you're a magician!

Thank you very much James!

I have completely forget about reset button, because due to silicon case usage.

Now X3 is working.

 

after all there are only two issues:

1. gapless playback,

2. sometimes X3 did not recognized .cue files, which foobar recognizes, for example http://rutracker.org/forum/viewtopic.php?t=4014438 (you have to download files from torrent for check)

post #5 of 7
Quote:
Originally Posted by otaran View Post
 

you're a magician!

Thank you very much James!

I have completely forget about reset button, because due to silicon case usage.

Now X3 is working.

 

after all there are only two issues:

1. gapless playback,

2. sometimes X3 did not recognized .cue files, which foobar recognizes, for example http://rutracker.org/forum/viewtopic.php?t=4014438 (you have to download files from torrent for check)

please undate to 2.05 firmware, http://fiio.com.cn/news/index.aspx?ID=100000110684794

post #6 of 7
After working well for a couple of months, Fiio X3 stopped functionning correctly.  When I turn the X3 on, the back light turns on but no text or images show up on the display.  I tried to reset the device but it did not fix the problem.
 
Do you have another suggestion to fix the problem?
post #7 of 7
Quote:
Originally Posted by inFocus View Post
 
After working well for a couple of months, Fiio X3 stopped functionning correctly.  When I turn the X3 on, the back light turns on but no text or images show up on the display.  I tried to reset the device but it did not fix the problem.
 
Do you have another suggestion to fix the problem?

 

maybe try to reset again , and contact the dealer for the warranty issue if it still can't work.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: FiiO
Head-Fi.org › Forums › Head-Fi Special Forums › Premier Sponsor Forums and Sponsor Forums › Premier Sponsor Forums › FiiO › X3 has worked only two months.