or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › New JH Audio flagship! "Siren Series Roxanne"
New Posts  All Forums:Forum Nav:

New JH Audio flagship! "Siren Series Roxanne" - Page 395

post #5911 of 8278
Quote:
Originally Posted by techadd View Post

and its not even funny anymore...
I can't believe we paid them 1.5k, they have not delivered for 7 months and they are joking about it. I am starting the I love JH thread...NOT.
post #5912 of 8278
I'm still waiting on my CF Roxannes

BF order #11942

Impressions on file from a previous order
post #5913 of 8278
I'm still waiting, too, but they didn't receive my impressions until January 9th. In other words I'll "only" be at 5 months next week.

//TB
post #5914 of 8278

Seem like Andrew Regan is a big liar. He said that mine will be shipped last week. But I still got no information or update about my Roxanne. What a let down.

post #5915 of 8278
Quote:
Originally Posted by king8888 View Post
 

Seem like Andrew Regan is a big liar. He said that mine will be shipped last week. But I still got no information or update about my Roxanne. What a let down.

 

i had couple of replies of  'shipped next week' before it finally arrived..

post #5916 of 8278

I'm also still waiting on my and my friends CF Roxannes
 

11/30/2013 12166 Impressions Received & Order processed 12 $3,039.56


DJ Hessler
Pär Hessler
www.djhessler.se

post #5917 of 8278

its not even one day old and the music keeps cutting off on the left side... memory cable problem i suspect..the day just keeps getting better, i hope i don't have to send the whole unit back to replace new cable..and i thought the new cables were all replaced with aluminum nut now or was i handled an old cable by mistake??

post #5918 of 8278
Quote:
Originally Posted by techadd View Post

its not even one day old and the music keeps cutting off on the left side... memory cable problem i suspect..the day just keeps getting better, i hope i don't have to send the whole unit back to replace new cable..and i thought the new cables were all replaced with aluminum nut now or was i handled an old cable by mistake??


 



What do you mean by memory cable problem?. It should not affect signal transmission no matter how much you twist, turn or knot the cable as long as the connectors are properly seated on each monitor's socket and the plug is properly aligned/fitted in the source's jack.

Losing sound on one monitor is most probably a symptom of a plug is not fully inserted (inserted halfway) into the jack or the connectors not properly seated on the socket. Worst case scenario, your monitor has a problem. If you have a DMM it's easy to check the cables for any breaks.
post #5919 of 8278
Quote:
Originally Posted by techadd View Post
 

its not even one day old and the music keeps cutting off on the left side... memory cable problem i suspect..the day just keeps getting better, i hope i don't have to send the whole unit back to replace new cable..and i thought the new cables were all replaced with aluminum nut now or was i handled an old cable by mistake??

 

My brother had the same problem & it turned out his thread wasn't long enough to keep the cable in place & the connection secure. Check to see if you have any play with the cable above the thread. With the connection screwed in correctly there will be no play. With a thread that is too short there will be movement. If this is the case you need a whole new earpiece....

 

Hoe you can understand what I mean. I'll post a video if you don't...

post #5920 of 8278
Good news! Mine are on their way!
Expect them this week so already made an appointment with my dealer to pick them up Friday smily_headphones1.gif!! Will post pictures and first impressions asap
post #5921 of 8278
Quote:
Originally Posted by JonathanCandel View Post

Good news! Mine are on their way!
Expect them this week so already made an appointment with my dealer to pick them up Friday smily_headphones1.gif!! Will post pictures and first impressions asap

Congrats!!!!
post #5922 of 8278

Believe me dude, when i said its a memory cable problem, i have enough CIEM's to know if its a jack/connector/cable problem.

 

I've already tried removing and repushing and twisting the connector several times and yet the sound cuts off with a slight movement and i have to nudge the memory cable and then it comes and after a minute it cuts off again, i certainly hope JH is not expecting me to walk on the street with one hand on my memory cable??!!

 

I've already tested the cable on another universal roxanne of my friend and it gave the same result, he had to nudge the memory cable, when i used my friends roxanne cable to try on mine, it worked without any problem, so it has to be my cable. by the way, are the old cables nut fixed already as it seems that mine is not aluminum nut on my black cable but the same old plastic nut on the black cable.

 

I'll be extremely pissed if they send me a defect old cable without checking probably!!

 

Already send an email yesterday asking them to send me a replacement cable immediately, i didn't wait 7months just to find out my roxanne is still incomplete!!

post #5923 of 8278
Spoke to Angie yesterday after 8 missed calls. Supposedly mine are being shipped this week or next, along with about 30 others.

We shall see!
post #5924 of 8278
Quote:
Originally Posted by dleblanc343 View Post

Spoke to Angie yesterday after 8 missed calls. Supposedly mine are being shipped this week or next, along with about 30 others.

We shall see!
What is your order number if I may?
post #5925 of 8278

thank god, got a reply that they are already sending me the replacement cables. kudos! at least they handled this problem real quick!

New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › New JH Audio flagship! "Siren Series Roxanne"