Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › my left monitor for Shure 846 died mid song !!
New Posts  All Forums:Forum Nav:

my left monitor for Shure 846 died mid song !!

post #1 of 7
Thread Starter 

So I was listening to music from my iPhone and all of a sudden no sound comes out from left monitor . I change source same issues .

 

Anything I can do before sending it back ?

 

I live in India and sending it back to US will be very very expensive for me

post #2 of 7

Shure does business globally.  I am sure there is service place for warranty work near you.  You can call the international site or contact local authorized Shure at your country.

post #3 of 7
Thread Starter 

Yeah , I've contacted them . Let's hope this is resolved quickly

post #4 of 7
Perhaps it's just the cable? Take it out and clean the connectors.
post #5 of 7
Quote:
Originally Posted by lin0003 View Post

Perhaps it's just the cable? Take it out and clean the connectors.

 

alcohol wipe around the male connector, inspect for dirt.

post #6 of 7
Quote:
Originally Posted by Mooses9 View Post
 

 

alcohol wipe around the male connector, inspect for dirt.

 

Yeah, this.

Also, try it with other sources because it might just (hopefully) be your iphone. 

post #7 of 7
Thread Starter 

It was the left monitor , Shure replaced it :D

New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › my left monitor for Shure 846 died mid song !!