Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › New Ultrasone Edition 5 hinted in the Fujiya Avice Autumn Festival 2013
New Posts  All Forums:Forum Nav:

New Ultrasone Edition 5 hinted in the Fujiya Avice Autumn Festival 2013 - Page 19

post #271 of 278

Sorry to hear this bmichels.  Unfortunately I have no experience with the Romeo or any of the newer Edition series.

 

One thing that always did cross my mind when I looked at the connectors used on these newer Edition series was that I couldn't help but think that the connectors themselves looked as if they could have used a bit more meat on the bone.

 

Hope you get it sorted either through warranty or as you suggest a hardwire.

post #272 of 278
Quote:
Originally Posted by Mortalcoil View Post
 

Sorry to hear this bmichels.  Unfortunately I have no experience with the Romeo or any of the newer Edition series.

 

One thing that always did cross my mind when I looked at the connectors used on these newer Edition series was that I couldn't help but think that the connectors themselves looked as if they could have used a bit more meat on the bone.

 

Hope you get it sorted either through warranty or as you suggest a hardwire.

 

the connectors indeed offer quite a weak fix.

post #273 of 278

As beautiful as the Ed 5 is, there's no way I could ever justify that price. But just today I saw the unlimited version today while browsing the net... Half the price? This might be the one to dethrone my mighty Sig Pros. I'll have to see what my favorite reseller is asking for these... Even so, by the time I can justify them they'll probably have an Edition 3, lol.

post #274 of 278

I just bought ED 5 unlimited, but it needs some days to arrive, my headphones are ATH-M50 and Sig DJ which I love ,,,,

 

 

IMPORTANT INFO:

 

Maximum input power:
Ultrasone Signature PRO =                        120 mW (40 mW RMS)
Ultrasone Signature DJ =                           200 mW (80 mW RMS)
Ultrasone Edition 5 (limited/unlimited) =      120 mW (40 mW RMS)
 
Cheers,,

Edited by BA_D_R - 12/7/14 at 10:08am
post #275 of 278
Quote:
Originally Posted by Mortalcoil View Post
 

Sorry to hear this bmichels.  Unfortunately I have no experience with the Romeo or any of the newer Edition series.

 

One thing that always did cross my mind when I looked at the connectors used on these newer Edition series was that I couldn't help but think that the connectors themselves looked as if they could have used a bit more meat on the bone.

 

Hope you get it sorted either through warranty or as you suggest a hardwire.

 

The german importer from who I bought the ED 5 was very helpfull: At his cost he sent UPS to collect the headphone from me, and he have it will fix ASAP.  He also asked that I include the 3rd party balanced cable to make sure that this one also has a good connection.

 

I hope that this will solve the issue.   If not, then I will make a hardwiring of the 3rd party cable to the headphone to eliminate those stupid weak plugs.

post #276 of 278
Quote:
Originally Posted by bmichels View Post
 

Damned... I have false contact with my ED5 ! :mad:   The removable MMCX plug seems to be the weak part of the ED5. 

 

  

 

 

 

-->  I am therefore considering hardwiring my balanced Red WyWyres cable to it instead of using those MMCX plug.  

 

- has someone experienced such problem with the ED5 (or Edition 8 ROMEO & Edition 8 JULIA headphone that use the same plugs ? )

 

- does someone know how to open those headphone to see where the wires are disconnected from the plugs ? 

I had the exact problem with my ED5's (serial #200+ ) after a week of using them the sound started to cut out erratically. I complained to the dealer and they said they could not find anything wrong with them. In turn they sent them to the distributer in Hong Kong who also said they did not find anything wrong but apparently replaced the cable. Since receiving them back, the problem has occured less than a handful of times. Then just last week I decided to buy new cables for them and then reluctantly tried some ALO MMCX>2.5mm cables at a store in Hong Kong. ( I have had very bad experiences with two ALO cables on my JH IEM's with little support from the retailer to fix them )  The store had 3 sets of ALO cables, and every single one had a weak connection to the ED5's. They also cut out erratically just by moving the cables around. When I visually compared them to the male connectors of the stock ED5's, they were noticeably shorter.

 

In the end, I bought a pair of MMCX>2.5mm cables from a Taiwan manufacturer that hasnt had any issues since. Im debating which cables to fit on the ED's next, so any recommendations are appreciated.

 

Also for the record, they had the new half priced unlimited ED5's that I was able to AB test with my pair and there is no audible difference in sound.

post #277 of 278
Quote:
Originally Posted by ShanghaiT View Post

I had the exact problem with my ED5's (serial #200+ ) after a week of using them the sound started to cut out erratically. I complained to the dealer and they said they could not find anything wrong with them. In turn they sent them to the distributer in Hong Kong who also said they did not find anything wrong but apparently replaced the cable. Since receiving them back, the problem has occured less than a handful of times. Then just last week I decided to buy new cables for them and then reluctantly tried some ALO MMCX>2.5mm cables at a store in Hong Kong. ( I have had very bad experiences with two ALO cables on my JH IEM's with little support from the retailer to fix them )  The store had 3 sets of ALO cables, and every single one had a weak connection to the ED5's. They also cut out erratically just by moving the cables around. When I visually compared them to the male connectors of the stock ED5's, they were noticeably shorter.

In the end, I bought a pair of MMCX>2.5mm cables from a Taiwan manufacturer that hasnt had any issues since. Im debating which cables to fit on the ED's next, so any recommendations are appreciated.

Also for the record, they had the new half priced unlimited ED5's that I was able to AB test with my pair and there is no audible difference in sound.
That's a shame about those connectors but wonderful to hear about the new unlimited version.
post #278 of 278
Quote:
Originally Posted by bmichels View Post
 

 

The german importer from who I bought the ED 5 was very helpfull: At his cost he sent UPS to collect the headphone from me, and he have it will fix ASAP.  He also asked that I include the 3rd party balanced cable to make sure that this one also has a good connection.

 

I hope that this will solve the issue.   If not, then I will make a hardwiring of the 3rd party cable to the headphone to eliminate those stupid weak plugs.

 

 

 

Good to hear that you are getting it sorted out and that the importer is being accommodating (as should be the case).  The hardwire route seems like a logical plan considering the post just above mine ..... seems like a common issue.

 

 

Quote:

Originally Posted by BA_D_R View Post
 

I just bought ED 5 unlimited, but it needs some days to arrive, my headphones are ATH-M50 and Sig DJ which I love ,,,,

 

 

IMPORTANT INFO:

 

Maximum input power:
Ultrasone Signature PRO =                        120 mW (40 mW RMS)
Ultrasone Signature DJ =                           200 mW (80 mW RMS)
Ultrasone Edition 5 (limited/unlimited) =      120 mW (40 mW RMS)
 
Cheers,,

 

 

Congrats BA_D_R.  Keep us posted with impressions. 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphones (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › New Ultrasone Edition 5 hinted in the Fujiya Avice Autumn Festival 2013