or Connect
New Posts  All Forums:Forum Nav:

New WESTONE W-SERIES - Page 26

post #376 of 1121
Quote:
Originally Posted by Ivabign View Post
 

None of the ones in the pics are UM series - the ones made in the USA.

So how do you explain my one week old UM Pro 50 have a lose connector on one side? The two very thin signal wires that soldered on the connector are moving with it too, it is just matter of time they break off. The finish of earpiece on same side with lose connector is not showing it is a $650 gear with glue all round it, but the other earpiece has perfect fit and finish. That tells me they are actually capable to make good quality product, but...


Edited by Seamaster - 4/25/14 at 4:46pm
post #377 of 1121
Quote:
Originally Posted by AndrewH13 View Post
 

 

How long you had yours? I've had them 6 weeks, replaced cable first day and never since. Probably wouldn't have noticed crack if it hadn't been mentioned here, but now I have, best to get it sorted, emailed retailer who wants them returned for repair/replacement. But if new ones can show a crack it's a bit worrying.

I've had mine for about 4 weeks.  I replaced the cable once as well.  I didn't notice the crack until it was mentioned in this thread.  I'm probably going to wait it out for a little while and see if it gets worse, plus I would like to hear what Westones' response is for the others with the same issue.

post #378 of 1121
Quote:
Originally Posted by AndrewH13 View Post

What exactly did your dealer say it is then? Very interested what Westone respond with. Three of us now here with same problem.

My dealer ask me to sent them a closeup photo after they looked at the photo I posted here..after they looked at the closeup photo...they said that is not a crack...sounds like they don't want to exchange for me. So I contact Westone... They said I should contact my dealer for the first 30 days...or deal with Westone after the 30 days of purchase. I am not too happy about this.
post #379 of 1121
Ah crap. My w40s have got the same cracks.
post #380 of 1121
This is getting more worrying as even if we get replacements, this seems widespread now. Especially as W30s and W40 involved.
post #381 of 1121
Nelson, what have you started, LOL. I would never have looked until reading your post! Do let us know as soon as Westone respond.
post #382 of 1121
For US$499. Its pretty poor IMHO
post #383 of 1121

I have emailed Westone music@westone.com to see if they are aware of the problem. Might be an idea for others with cracked housings to do the same. I don't want to send back to dealer and a replacement to be the same within a few weeks.

post #384 of 1121
Quote:
Originally Posted by AndrewH13 View Post

I have emailed Westone music@westone.com to see if they are aware of the problem. Might be an idea for others with cracked housings to do the same. I don't want to send back to dealer and a replacement to be the same within a few weeks.

I emailed Earphone Solutions today. Hopefully hear back on Monday. I asked how I could go about getting a refund. They do refunds with a restocking fee (change of minds only I assume?) and exchanges. I don't want an exchange if there's a risk the same thing will happen again. Would prefer to wait for a few more months until they iron out the production issues.

If I can't get a straight refund. I will then contact Westone and see what they say.
post #385 of 1121
Got a reply:
"Those are not cracks.
That is the sonic welding point of the 2 halfs. They were noticed on all the W series products. Westone's engineering confirmed."



Guess there's nothing wrong with them then...

Moving on, I am selling mine. Need/want something with a smaller housing.
Edited by ads1107 - 4/26/14 at 6:28pm
post #386 of 1121
Quote:
Originally Posted by ads1107 View Post

Got a reply:
"Those are not cracks.
That is the sonic welding point of the 2 halfs. They were noticed on all the W series products. Westone's engineering confirmed."



Guess there's nothing wrong with them then...

Moving on, I am selling mine. Need/want something with a smaller housing.

I'm getting rid of my W4R soon, before it becomes $300+ junk!

post #387 of 1121
Quote:
Originally Posted by AUDIOBREEDER View Post
 

I'm getting rid of my W4R soon, before it becomes $300+ junk!

 

Because of aesthetic (around the MMCX connector) the W-Series suddenly became a junk?

post #388 of 1121
Quote:
Originally Posted by AUDIOBREEDER View Post
 

I'm getting rid of my W4R soon, before it becomes $300+ junk!

 

 

Quote:
Originally Posted by uelover View Post
 

 

Because of aesthetic (around the MMCX connector) the W-Series suddenly became a junk?

I would hold on to the W4R if I were you, as the MMCX connector is know to be less reliable than the old design.

post #389 of 1121
Quote:
Originally Posted by ads1107 View Post

Moving on, I am selling mine. Need/want something with a smaller housing.

W50 or W60?

post #390 of 1121
Quote:
Originally Posted by DrSheep View Post

W50 or W60?

W40.
New Posts  All Forums:Forum Nav: