Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › "The New" Fiio X3 with USB DAC
New Posts  All Forums:Forum Nav:

"The New" Fiio X3 with USB DAC - Page 4

post #46 of 139
Quote:
Originally Posted by cattlethief View Post
 

All is well explained in the instruction download!!

Ah, thanks. Didn't see the manual. Works now.

post #47 of 139

:-)  Really enjoying the USB DAC function,  Seems to work well with my Laptop and JRiver.  The USB connection seems limited to 96KHz sampling, since JRiver reports that it is downsampling from 192Khz, not that anyone will really hear the difference.   Will compare SQ with my E07K later, but I am happy with the sound so far.

 

So far, so good.  The X3 just became more versatile and even better value :-)

 

Well done FiiO.

post #48 of 139

Did anyone managed to get the USB DAC function working on mac?

post #49 of 139
Quote:
Originally Posted by docentore View Post
 

Did anyone managed to get the USB DAC function working on mac?

Yup, plug and play

post #50 of 139

It is recognised by my Macbook 10.9, but won't play unless i do few steps (just got it working few seconds ago):

 

1. Connect the player when it is off to mac.

2. Turn off and on again

3. Open your music player application

 

Works, thanks for the DAC function  FiiO

post #51 of 139

How is the sound quality? Can it do justice to my high resolution files?

post #52 of 139
Sound quality is great. I listen using beyer dt880 and i think it has a fuller, more pleasent and powerfull sound than as standalone player. Maybe it is placebo or because i use EQ in foobar or power delivered by usb is bigger and these headphones have 250 ohms. But i like it better as USB DAC. I'd really like that one day fiio will implement a good parametric eq for dap.
Edited by LightBlue77 - 10/26/13 at 2:29am
post #53 of 139
Wow, I'm using a DT 880 with the same impedance as well! Thanks for the response. This means I'm getting one. Mind if I ask a couple of questions? Does it play 192Hz files with no problem? Does it suffer from a problem where there seems to be a slight delay when playing music files? I get that with my Fiio E10 with 16 bit only files. Thanks.
post #54 of 139
I have to test 192Hz, on X3's display bitrate and freq is automatically updated when playing in foobar with wasapi. When i use youtube it shows 192/24 because this is what i set in windows. I don't know if it really helps improving sound quality in this case. as for delay, i set up some buffers in foobar and yes, there is a slight delay when song starts. But i cannot say it's X3's fault or foobar. But i don't mind.
Edited by LightBlue77 - 10/26/13 at 7:32am
post #55 of 139
Quote:
Originally Posted by docentore View Post
 

Did anyone managed to get the USB DAC function working on mac?

On my Mac (10.9) all goes fine.  I need to go to "system preference > sound" and enable the out with X3 name.

Again may be that in software it needs another setting

post #56 of 139
Quote:
Originally Posted by lime51 View Post
 

On my Mac (10.9) all goes fine.  I need to go to "system preference > sound" and enable the out with X3 name.

Again may be that in software it needs another setting


Same thing here, though I was using my friend's Macbook Air and it worked without a flaw.

post #57 of 139

Guys sorry for the double post, but what are the best settings for the USB DAC? What does the "USB Streaming Mode" and "ASIO Buffer Size" mean in the "USB Audio Class Driver Control Panel" when you click on the "T" icon in the taskbar? Care to give an explanation?

post #58 of 139
The settings won't alter fidelity.
post #59 of 139
Would you care to explain? I need to know why something is that way and not just accept an answer without any meaning behind it. Thanks.
post #60 of 139

I'm experiencing af problem with the DAC functionality of the X3. When using it as DAC from my laptop i get drops in sound, where windows suddenly loses connection to the usb DAC (in device manager i can see that it disapears and reapears. I've tried all my USB ports on the laptop (2xUSB2 and 1xUSB3, the usb doesn't work at all with the X3), but it's the same problem. Anyone else experiencing this? If i use my oDAC i don't experience any of these problems.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › "The New" Fiio X3 with USB DAC