New Posts  All Forums:Forum Nav:

x3 - Freeze while playing

post #1 of 29
Thread Starter 

Hi everybody,

 

since I upgraded to the latest firmware 1.31 the device froze twice. Music keeps on playing but all buttons are "out of order", the screen as well. Does anyone of you have this issue as well?

 

I'm playing .flac files b.t.w.

 

Cheers,

 

M

post #2 of 29

is this just happen with some sound tracks?  maybe you can contact support@fiio.net and send the files to us to figure out what happen.

post #3 of 29
Thread Starter 

Hi,

 

thx for the prompt reply! I could not yet find out whether this happens only with some tracks. That would be surprising, though, as all those files are converted with the same tool in the same format (.flac). I'll try to figure out how to localize this a little bit better and get back to you.

 

Cheers!

post #4 of 29
Thread Starter 

Hi again,

 

since your reply I tested your theory. The last time the device froze I pushed the reset-button and played the previous file (which I played prior to the freeze) again and nothing happened - I could still use all buttons etc. So I'm not sure if this problem is due to bad files...

 

Cheers!

post #5 of 29
Quote:
Originally Posted by MMadmaXX View Post
 

Hi again,

 

since your reply I tested your theory. The last time the device froze I pushed the reset-button and played the previous file (which I played prior to the freeze) again and nothing happened - I could still use all buttons etc. So I'm not sure if this problem is due to bad files...

 

Cheers!

 

OK, please contact us if you can help us located which music files cause the problem.

post #6 of 29

I'm having the same problem with my new X3.



The device freezes and won't respond to any button presses. The song will continue playing until it is finished and then the screen will turn off. Then if I hold down the power button, the device will start up again.



It seems to only be happening when I play FLAC files and attempt to then select an MP3. The device will be playing the FLAC file and when I select the MP3 it will freeze and continue playing the FLAC file.



It's happened 3 times so far. I've only had the device for 1 day. It has happened with firmware 1.31 and the new 2.1.


Edited by alex8337 - 12/14/13 at 3:19am
post #7 of 29

I am getting a similar problem. All my files are ALACs however. And the freeze happened typically when I browse/select new songs while one is in play. My X3 stops responding to any button but the current song continues to play until the end. I have to use the reset button on top to reset it. This happened when I use either my 32GB SDHC or 64GB SDXC. This had happened more than 10 times already, and It is hard to find a pin to reset the unit outside =(

 

I have emailed fiio support but I have not heard anything for 5 days.

post #8 of 29

Just to let you know, you don't have to use that reset button... All electronic devices, including the X3, always should have a forced shutdown option by holding the power button anywhere from 10 to 30 seconds. In fact, in the X3 manual, it states you can hold the power button down for 10 seconds for forced shutdown.

 

This works even when frozen, because it is a hardware-based shutoff.

 

Also, for anyone who has a PS3, this works for them too. Don't just unplug your system. That's how corruption happens. It is safer to hold power buttons down than to cut the power entirely.

post #9 of 29

I tried pushing the power button for > 30 seconds, and it did not seem to work. The reset button on top worked every time. 

 

After a few freezes I did not bother to long press the button button anymore. Will try it next time.. it's just a matter of time. I would love to see a fix to the freeze problem though.

post #10 of 29
During an 8 hour drive today my Fiio X3 froze 3 times. Each time I had to reset it by holding down the power button.
A whole folder of MP3's refused to play but they play on my android phone when I swap the sd card over.
I've also experienced the player simply refuse to play a song until I skip forward to the next track then back again, then it plays the song.
Last but not least... The player will freeze but continue to play the current song until it finishes.

Settings where...
Gapless playback on
Treble 0
Bass 1
Storage mode
Brightness set to max
Firmware 2.1 with the black and red honeycomb theme

This is really disappointing. I'm contemplating returning it for a refund. It seems like a firmware related fault so I'll have a play around with different firmwares first but I need this as a DAC as well as a portable player which limits the firmware I can test.
I'll be pretty angry if Fiio stops releasing firmware updates for the X3 when the X5 comes out.
This does not feel like a finished product yet.
post #11 of 29

Same thing happened to me. I turned off the Gapless Playback and it does not freeze again. I know it probably is not ideal but give it a try...

post #12 of 29

I am new to the X3, just received mine this week.  I upgraded the firmware to 2.1 before doing anything else. I am using a Sandisk 64GB microSD card formatted to FAT32.   I loaded it with all my WMA and MP3 files and they seem to all play without issues.

I then found some free FLAC HD files and they all play well and sound fantastic.  I then purchased The Who's "Tommy" and Traffic's "John Barleycorn Must Die" from HDtracks. The Traffic files all play ok, but "Tommy" causes the X3 to freeze if I play the tracks with gapless play set to "ON. When it does freeze, it is always between tracks.  I need to push the reset to unlock it. If I set gapless play to "OFF", the "Tommy" tracks play fine.

 

This seems to be a glitch in the X3.  Maybe the next firmware release will address it.

 

Thanks for the tips in this forum . . . . . . 

 

 

gflash

post #13 of 29

My X3 seems to freeze allot less with gapless playback set to off and resume playback set to track instead of position.

It still freezes while continuing to play a track until that track has finished, then its unresponsive until I reset it.


Edited by alex8337 - 1/7/14 at 12:23am
post #14 of 29

Start up.  Play, say,  folder 1 song 1, after skip to folder 2 song 2... After about 10 selection the player freeze.  Had to do a hard reset and when boot up, it's at folder 1 song 1 position.  Is this a memory issue?

 

BTW, i have 2 X3 having the same problem.

post #15 of 29
Quote:
Originally Posted by gflash View Post
 

I am new to the X3, just received mine this week.  I upgraded the firmware to 2.1 before doing anything else. I am using a Sandisk 64GB microSD card formatted to FAT32.   I loaded it with all my WMA and MP3 files and they seem to all play without issues.

I then found some free FLAC HD files and they all play well and sound fantastic.  I then purchased The Who's "Tommy" and Traffic's "John Barleycorn Must Die" from HDtracks. The Traffic files all play ok, but "Tommy" causes the X3 to freeze if I play the tracks with gapless play set to "ON. When it does freeze, it is always between tracks.  I need to push the reset to unlock it. If I set gapless play to "OFF", the "Tommy" tracks play fine.

 

This seems to be a glitch in the X3.  Maybe the next firmware release will address it.

 

Thanks for the tips in this forum . . . . . . 

 

 

gflash

 

I have found that some sound tracks from HDtracks included a very large cover , you can resize the cover.

 

BTW, sorry for the late reply cause I can't work for couple weeks 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: FiiO