Head-Fi.org › Forums › Equipment Forums › Computer Audio › Need help with Foobar2000 and WASAPI
New Posts  All Forums:Forum Nav:

Need help with Foobar2000 and WASAPI

post #1 of 6
Thread Starter 

I've read everything I could find on Google and on this forum, and tried switching all settings back and forth.  Unfortunately, nothing helped.

 

 Whenever I start playing a file on Foobar2000, I get a message telling me "Unsupported stream format: 44100 Hz / 24-bit / 2 channels".

 

My system is a Windows 7 based laptop with an on-board Realtek soundcard with 3.5mm optical SPDIF output.

 

My soundcard only supports 48,000hz and 16bit (so it's written in the "Playback Devices" menu on Windows).

 

I don't know if I have to also use ASIO4ALL.

 

For what it's worth, I used to play music on this laptop, using Foobar2000 with WASAPI running Windows XP, and have been doing this for like a year without a problem.  Actually, I can't really remember whether or not I used WASAPI as Foobar's digital output though, but I did use the SPDIF output via my V800 DAC.  Yesterday, digital audio output suddenly disappeared from Foobar's output list, and after running around looking for a solution, I decided to install Windows 7 hoping that would solve the problem.

 

Also FWIW, if I switch to "DS: Realtek Digital Output (Realtek AC'97 Audio)", on Foobar's output list, it works fine and I can listen to music through my DAC.  This implies the problem is with the WASAPI component, I guess.

 

 

Technical details:

Windows 7 (SP1 32bit)

Foobar2000 (v1.1.7)

WASAPI plugin

ASIO4ALL (v2)

Realtek on-board sound card - only supports 48,000hz 16bit output

 

 

What I tried:

using the old WASAPI .dll component I had used with Windows XP

switching to 24bit on Foobar

running with ASIO4ALL and without it

re-installing the original audio driver I used to have

updating audio driver to latest

 

 

It's been really frustrating until now, as none of these solved my problem.

 

Let me know if any other info is necessary.

 

 

Thank you for reading.  Cheers

post #2 of 6

Try updating to the latest version of Foobar2000, see what happens.

post #3 of 6
There are setting in Windows for the soundcard and within Foobar where you can select the max bit/sample rates. Have you checked those to make sure they're not set at 16/44.1 (typically the default setting)?
post #4 of 6

If his dac doesn't support 24 bit audio then wasapi won't work right? Isn't the only reason it works with realtek digital output is because windows is turning it into 16/48 and then sending it to the dac? Or maybe I'm missing something.

post #5 of 6
Thread Starter 

Hi everyone,

 

It's working now:

 

I installed the latest version of Foobar2000, as PurpleAngel suggested.

 

jcn3:  If you're reading this, please let me know what setting on Foobar2000 you mean.  Is that the resampler that comes with the program (aka PPHS) ?

Also, are you talking about this setting in Windows ?  Looks like I can't change it - it would be great if I could however ...

 

LINK

 

Regarding linglingjr's post:  my DAC supports 24bit/192khz for optical SPDIF input (link).

 

 

Thank you all

 

Cheers

post #6 of 6

Foobar > File > Preferences > Playback > Output >

 

All the devices available are listed in the Device drop down menu. If WASAPI isn't listed the rivers are not installed correctly.

 

Select your preference here and then check the Output Format drop down menu is set correctly. (bit depth).

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Need help with Foobar2000 and WASAPI