Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › DX50 Bug List, Wish List Fix
New Posts  All Forums:Forum Nav:

DX50 Bug List, Wish List Fix - Page 79

post #1171 of 1176
Hello Mactire, and all Head-fi people!
I been reading HeadFi for several years, but never registered.

Mactire's issue with DX50 made me register. I have exactly the same issue. I bought the DX50 yesterday in Bangkok at MunkongGadget, ibasso dealer in Thailand. Reason to buy, I spend winters here but forgot to bring my Fiio e18, so needed something to drive my Grado PS500.
DX50 is nice, I liked the line out, for the money DX50 is nice. Until this morning, it went silent in the middle of a song while I was adjusting volume. FLAC file that playing was on 32Gb SD card. Same black screen that Mactire described. The screen is black, I can see it is back lit, but nothing on the screen.
Tryed all the usual, power button and volume up - unit reboots to same black screen. Remove\replace battery - same black screen. Holding down power button for 7 sec, same black screen. Connect USB charger and repeat all of the above - black screen.

Mactire says his issue with DX50 must be one off, cos Google search does not bring any match to similar experience. Well, it does now, I found Mactire's post, and ragged to post this. Why post? Because this is unacceptable! DX50 had numerous bugs when first released, we are now at firmware 1.5! Yet this machine functions like $20 mp3 player that streets vendors in Bangkok are offering on every corner.
DX50 is inexpensive, no doubt. Cost in Thailand is 8500 baht, rufly $300. It should play music, it is not too much to ask from a day.

Since Mactire bought his unit recently as well,logic tells this is a bad batch.
I will return my brick of a DX50 tomorrow morning, walk straight to Sony Center and get a ZX1. No more beta testing questionable Chinese Daps for me!
post #1172 of 1176
Quote:
Originally Posted by whitemouse View Post

Hello Mactire, and all Head-fi people!
I been reading HeadFi for several years, but never registered.

Mactire's issue with DX50 made me register. I have exactly the same issue. I bought the DX50 yesterday in Bangkok at MunkongGadget, ibasso dealer in Thailand. Reason to buy, I spend winters here but forgot to bring my Fiio e18, so needed something to drive my Grado PS500.
DX50 is nice, I liked the line out, for the money DX50 is nice. Until this morning, it went silent in the middle of a song while I was adjusting volume. FLAC file that playing was on 32Gb SD card. Same black screen that Mactire described. The screen is black, I can see it is back lit, but nothing on the screen.
Tryed all the usual, power button and volume up - unit reboots to same black screen. Remove\replace battery - same black screen. Holding down power button for 7 sec, same black screen. Connect USB charger and repeat all of the above - black screen.

Mactire says his issue with DX50 must be one off, cos Google search does not bring any match to similar experience. Well, it does now, I found Mactire's post, and ragged to post this. Why post? Because this is unacceptable! DX50 had numerous bugs when first released, we are now at firmware 1.5! Yet this machine functions like $20 mp3 player that streets vendors in Bangkok are offering on every corner.
DX50 is inexpensive, no doubt. Cost in Thailand is 8500 baht, rufly $300. It should play music, it is not too much to ask from a day.

Since Mactire bought his unit recently as well,logic tells this is a bad batch.
I will return my brick of a DX50 tomorrow morning, walk straight to Sony Center and get a ZX1. No more beta testing questionable Chinese Daps for me!


I got mine early and it took forever to load my 64gb Sandisk card, even freezing most of the time.  The same card use din the fuze and my Cowon D3 with no problems.  I'm so glad I got out early.

 

Why get the overpriced ZX1? when the A17/A10 is available now?

post #1173 of 1176
@Whitemouse, I'm sorry to hear you also have issues with the DX50.
They are however not the same as my issues. It seems yours doesn't boot and function at all. Mine didn't boot correctly, but was functional for the rest of it.
And while it's true that iBasso had a lot of issues with the DX50 (just look at the size of this thread) the do have great customer support. That's something sony can learn a thing or two about.
But perhaps that's just my experience with Sony. I do love their players though, I've had three of them in the past.

The issue with my iBasso made me consider a different player, but it has a lot of things going for itself. Like user replaceable battery and a huge supported capacity. And it sounds really nice, that's the most important part ^_^
post #1174 of 1176
True, Mactire! I really, I REALLY love the industrial design of ibasso, I wish their software was as great as the design and the ease and functionality was on same level.

So I walked to dealer, they replaced the defective unit for new.
Also, my email to ibasso was replied within a day, impressive! Ibasso says go to dealer, they replace your unit on spot.

So I give the little DX50 another go, I really hope my bad unit was a one off.
Ibasso drives ps500 really nicely, the line out of DX50 is just enough to drive Grado PS500. I find dx50 line out MUCH cleaner than headphone out.. I wonder why that is.. The line out is unquestinably superior, not even close to headphones out. But not many headsets can be driven by dx50s line out low output.

DX is oustanding dap for the money! I hope it wont go dead again.. In Bangkok I can get it replaced, but back home in Eastern Europe no ibasso dealer, sending it to factory in China, waiting months for China Post is not an option, I will just buy another dap if dx50 decides to go dead again... Hopefully it wont smily_headphones1.gif
post #1175 of 1176
Wow, you must have money to spare willing to get a new dab that easely eek.gif
I have to work more on a budget beyersmile.png
But I hope you have more succes with the new unit. The v1.5.0 is good. I've been using it continuesly for the past days and it performs flawlessly.
I'm considering an amp for the DX50, but at the moment it drives all my portable gear with ease.
Anyway, good luck and let's hope we can stay away of this Bug List thread ^_~
post #1176 of 1176
Quote:
Originally Posted by Mactire View Post

Wow, you must have money to spare willing to get a new dab that easely eek.gif
I have to work more on a budget beyersmile.png
But I hope you have more succes with the new unit. The v1.5.0 is good. I've been using it continuesly for the past days and it performs flawlessly.
I'm considering an amp for the DX50, but at the moment it drives all my portable gear with ease.
Anyway, good luck and let's hope we can stay away of this Bug List thread ^_~

 

I fail to see how I gave up that easyly, as you say!

 

The thing died on me after only few hours of use, and no reset made it come back to life, so I wouldn't say I gave up easyly. 

There is Ibasso distributer in Thailand, but there isn't in my home country. In Bangkok I can get it replaced, or warranty repaired, not so after I return home.

 

As for having money to spare, I am missing what you say. Sony zx1 is hardly a hi end priced item, every other guy here at Head Fi uses top quality daps and headphones. I have Grado RS1, PS500, and Audeze lcd2, that is not anything out of the ordinary here, so I really dont understand the 'money to spare' comment.

 

Anyways, Mungkong refused refund, but they replaced the dx50. I received email reply  to my message to  ibasso customer service the very next day, very nice!

So I am using the replaced dx50 now 5th day with no issues. DX50 drives the Audezes nicely, ZX1 amp is not able to drive the Audezes, not nearly enough gain.

 Grado ps500 and zx1 is a beautiful match, possibly 2nd best sound from portable rig ever!

I hope my replaced ibasso will not die, with Audeze it is a beautiful!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › DX50 Bug List, Wish List Fix