Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Ultrasone Headphones Right Side Stopped Working
New Posts  All Forums:Forum Nav:

Ultrasone Headphones Right Side Stopped Working

post #1 of 4
Thread Starter 

So I'm new, just made this to ask this question. I've had Ultrasone 2500's for about 10 months, since last Christmas when my dad tried to buy me off with them, and like an hour ago I was listening to Nine Inch Nails new album, the last song on it, which was super bass-heavy, not too much though. I have an iPod classic and this FiiO amplifier thing with eq and gain so the volume would go up on the headphones, cause they're kinda quiet and not good quality sound with just the ipod... well I was listening to the song at probably 75% max volume with the amplifier thing and ipod and all the sudden I heard a kind of static crack sound for a second and the right side just stopped working, no sound at all... I mean the crackling might have been part of the music cause nin makes crazy sh*t but I don't think so. I've handled them well before so it wouldn't be that they were damaged before, the right side works completely fine... So did I blow the ride side out or what happened? I know nothing about the specifics of headphones and details and all that. I use skullcandy earbuds and these headphones. SO i guess my questions are,..

 

What happened to the right speaker on the headphone?

What can be done about it?

 

and...

I don't want to mess with them at all or it voids the warranty, and I can't find anything about the warranty of the headphones so... also...

 

Does anyone know about the kind of warranty these things have?

 

 

Thanks in advance I really appreciate it!

post #2 of 4

They most likely have at least 12 months warranty (depending on where you live - in the EU all electronic products have 24 months warranty) so it should be safe to return them to the shop to have them repaired under warranty. You could have indeed blown out the driver although it is more likely that the cable inside the headband simply got damaged. These things happen even if you're careful with your headphones... If you're willing to open them up and recable them, you could probably fix them yourself. If you'd rather not mess around with them, just get them repaired under warranty.

post #3 of 4
Thread Starter 

Thanks I live in the US and I got them from some Amazon retailer, I emailed Ultrasone on their website about if I had a warranty, but should I email the Amazon retailer I got them from also?

post #4 of 4

Well, you should have a document confirming your purchase from the retailer, right? There should also be a date on this document. As long as the date is below 12 months in the past, you can send the headphone to the retailer or to Ultrasone for warranty service.

New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Help and Getting Started › Introductions, Help and Recommendations › Ultrasone Headphones Right Side Stopped Working