or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.5 - June 30, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.5 - June 30, 2016 - Page 890

post #13336 of 18446

So my DX50 is still having mental problems sorting songs in order.

Sometimes it will play fine right through an entire album, but at random I'll start an album, play track 1, then instead of going to track 2 after it jumps straight to the last track. Or another example would be I was playing track 5, skipped to the next by hand and it went to track 1.

Firmware 1.2.8
Directory: micro sd card (folder browsing)
Format: 16/44 FLAC

I've checked the repeat, order, shuffle, everything I can think of  but the problem remains and it's really random with all albums. It might play one album fine once then the next day have this sorting problem. I've tried changing cards, I cannot work out if it's a tagging problem.

Anyone who's had it occur or has any ideas let me know please. I've contacted iBasso.

I'd sure like to get to the bottom of it as it's just silly. :P
 

post #13337 of 18446
Guys I need help, I wish to use DX50 with a portable hard drive. After reading this thread, some posters have gotten OTG mode to work by powering the portable hard drive externally. What are the steps I need to go through to get it to work? Do I need a USB battery charger for the portable hard drive? What OTG cables would I need?

I wish to use the Seagate Expansion 2TB USB 3.0 Portable External Hard Drive (STBX2000401) with the DX50

http://www.amazon.com/gp/aw/d/B00ILALU9G/ref=aw_wl_ov_dp_1_11?colid=1HNU6PQVCA7TJ&coliid=I31TIQY1A40MKQ&vs=1
post #13338 of 18446
Thread Starter 
Quote:
Originally Posted by DTSxJP View Post

Guys I need help, I wish to use DX50 with a portable hard drive. After reading this thread, some posters have gotten OTG mode to work by powering the portable hard drive externally. What are the steps I need to go through to get it to work? Do I need a USB battery charger for the portable hard drive? What OTG cables would I need?

I wish to use the Seagate Expansion 2TB USB 3.0 Portable External Hard Drive (STBX2000401) with the DX50

http://www.amazon.com/gp/aw/d/B00ILALU9G/ref=aw_wl_ov_dp_1_11?colid=1HNU6PQVCA7TJ&coliid=I31TIQY1A40MKQ&vs=1

You need to separate the signal from the DC power when feeding the DX50. There are cables which have a USB micro connector split to a micro USB data connector and a regular USB male power connector. Search the net for that configuration and I am pretty sure you'll find cable providers that manufacture those.

You plug the single micro USB connector to your drive (I assumed it used micro USB) and the other end which has two connectors, one to your DX50 (data connector) and the other to a DC source, either your PC or the female connector of a wall plug charger.

Good luck with your project!
post #13339 of 18446
Quote:
Originally Posted by H20Fidelity View Post
 

So my DX50 is still having mental problems sorting songs in order.

Sometimes it will play fine right through an entire album, but at random I'll start an album, play track 1, then instead of going to track 2 after it jumps straight to the last track. Or another example would be I was playing track 5, skipped to the next by hand and it went to track 1.

Firmware 1.2.8
Directory: micro sd card (folder browsing)
Format: 16/44 FLAC

I've checked the repeat, order, shuffle, everything I can think of  but the problem remains and it's really random with all albums. It might play one album fine once then the next day have this sorting problem. I've tried changing cards, I cannot work out if it's a tagging problem.

Anyone who's had it occur or has any ideas let me know please. I've contacted iBasso.

I'd sure like to get to the bottom of it as it's just silly. :P
 

One idea that comes to my mind is that the DX50 could be playing in the order in which it SEES the songs, which, in turn, might just be the order in which they have been added to the sd card in the first place (which, if you copied them over with windows can be any order at all, really)… maybe you can try re-copying one of the albums which gives you problems with CopyInOrder? If that solves the problem, it might be just that...

post #13340 of 18446
Thread Starter 
Quote:
Originally Posted by H20Fidelity View Post

So my DX50 is still having mental problems sorting songs in order.


Sometimes it will play fine right through an entire album, but at random I'll start an album, play track 1, then instead of going to track 2 after it jumps straight to the last track. Or another example would be I was playing track 5, skipped to the next by hand and it went to track 1.

Firmware 1.2.8
Directory: micro sd card (folder browsing)
Format: 16/44 FLAC


I've checked the repeat, order, shuffle, everything I can think of  but the problem remains and it's really random with all albums. It might play one album fine once then the next day have this sorting problem. I've tried changing cards, I cannot work out if it's a tagging problem.


Anyone who's had it occur or has any ideas let me know please. I've contacted iBasso.


I'd sure like to get to the bottom of it as it's just silly. :P

 

Along with tagging all the necessary library tags, I have tagged my titles and the file name with the following format using the mp3tag app:

TT - Track title

Where TT is zero based track number

E.g. 01 - my song
02 - my second song ...
12 - my last song

I do not use the library but I believe it works the same as well. Have you tried this configuration?
post #13341 of 18446
Quote:
Originally Posted by musicheaven View Post

You need to separate the signal from the DC power when feeding the DX50. There are cables which have a USB micro connector split to a micro USB data connector and a regular USB male power connector. Search the net for that configuration and I am pretty sure you'll find cable providers that manufacture those.

You plug the single micro USB connector to your drive (I assumed it used micro USB) and the other end which has two connectors, one to your DX50 (data connector) and the other to a DC source, either your PC or the female connector of a wall plug charger.

Good luck with your project!

Thanks!

Could I just use a portable charging device/hub instead of the DC or Wall Charger? If yes do you know any

EDIT

I found cables and a charger,
Could you let me know if these are right for the project?

Micro USB Host OTG Cable with Micro USB Power for Samsung i9100 i9300 i9220 i9250 by AtomicMarket

http://www.amazon.com/gp/aw/d/B009YPYORM/ref=aw_wl_ov_dp_1_2?colid=1HNU6PQVCA7TJ&coliid=I2ZRE18HHCG48W

Anker® Astro 3E 10000mAh Portable Charger Dual USB External Battery Power Pack

http://www.amazon.com/gp/aw/d/B009USAJCC/ref=aw_wl_ov_dp_1_1?colid=1HNU6PQVCA7TJ&coliid=I3I48GL1X1MF1E&vs=1
Edited by FiJAAS - 5/28/14 at 9:53am
post #13342 of 18446
Thread Starter 
Quote:
Originally Posted by DTSxJP View Post

Thanks!

Could I just use a portable charging device/hub instead of the DC or Wall Charger? If yes do you know any

I guess you could but I don't know how long you'll be able to run the hard drive on the power pack. You'll most likely need a powerful power pack at least 10000 mAh and above. I saw a few head-fiers going for Anker or Energizer products but those are not the only ones, here is an example of a relatively powerful power pack:

http://www.amazon.com/gp/aw/d/B00FDK2G2C/ref=mp_s_a_1_5?qid=1401295554&sr=8-5

You'll have to experiment and if there is anyone who had tried that combination, please speak up.
post #13343 of 18446
Quote:
Originally Posted by musicheaven View Post

I guess you could but I don't know how long you'll be able to run the hard drive on the power pack. You'll most likely need a powerful power pack at least 10000 mAh and above. I saw a few head-fiers going for Anker or Energizer products but those are not the only ones, here is an example of a relatively powerful power pack:

http://www.amazon.com/gp/aw/d/B00FDK2G2C/ref=mp_s_a_1_5?qid=1401295554&sr=8-5

You'll have to experiment and if there is anyone who had tried that combination, please speak up.

Thanks!
And yes other users please speak up
Edited by FiJAAS - 5/28/14 at 10:50am
post #13344 of 18446
Quote:
Originally Posted by polyrhythm View Post
 

 

 

Also, try it without E12 if your earphones don't need the power. This is where I feel this firmware has made the most difference....the HO.


I know, by its own, the dx50 have good dynamics with iems like the shure se425, but my ex600 benefits the most with the amp

anyway will test them both (LO and HO)

cant wait to get home:atsmile:

post #13345 of 18446
Quote:
Originally Posted by geagle View Post
 

One idea that comes to my mind is that the DX50 could be playing in the order in which it SEES the songs, which, in turn, might just be the order in which they have been added to the sd card in the first place (which, if you copied them over with windows can be any order at all, really)… maybe you can try re-copying one of the albums which gives you problems with CopyInOrder? If that solves the problem, it might be just that...

 

 

Quote:
Originally Posted by musicheaven View Post


Along with tagging all the necessary library tags, I have tagged my titles and the file name with the following format using the mp3tag app:

TT - Track title

Where TT is zero based track number

E.g. 01 - my song
02 - my second song ...
12 - my last song

I do not use the library but I believe it works the same as well. Have you tried this configuration?




Thanks guys,


The main issue here is, sometimes it will play the album(s) without a problem maybe 2-3 times then totally at random have this issue.

I think numbering the tracks to try and lessen confusion might be something worth trying. I might attempt this with one album as a work around and test it.


I've been given a debug file from iBasso to try but apart from that they say it's very unheard of issue and no-one has ever mentioned it before. 

I'm also going to try with gapless off and reinstalled the firmware last night.

I iBasso said, if the playmode is in "order" it is impossible for DX50 to do it. :tongue_smile: 

post #13346 of 18446

To help you drive out the evil spirits lodged somewhere deep in your DX50.  

post #13347 of 18446
Quote:
Originally Posted by H20Fidelity View Post
 

 


I iBasso said, if the playmode is in "order" it is impossible for DX50 to do it. :tongue_smile: 

I would agree, and in my experience, when it is "in order", the DX50 sees and plays files in the order in which they were first copied on the card … but if, in your case, on a given album sometimes it does and sometimes it does not, well, I'm pretty much stumped:confused_face_2:...

 

If you go to an album that you are having problems with on the My Music library either through the "Album" or the "Artist"=>"Album" selections, are the songs in order? And, then, do they play in the order in which you can read their names in the library?

 

In my case, for albums that were copied with windows but not with CopyInOrder, I can see that the library often has songs like:

 

03 - Third Song.flac

….

12 - Last Song.flac

01 - First song.flac

02 - Second song.flac (I too adopt the same naming convention as MusicHeaven)

 

and yeah, it plays them in that order...

post #13348 of 18446
Quote:
Originally Posted by geagle View Post
 

I would agree, and in my experience, when it is "in order", the DX50 sees and plays files in the order in which they were first copied on the card … but if, in your case, on a given album sometimes it does and sometimes it does not, well, I'm pretty much stumped:confused_face_2:...

 

If you go to an album that you are having problems with on the My Music library either through the "Album" or the "Artist"=>"Album" selections, are the songs in order? And, then, do they play in the order in which you can read their names in the library?

 

In my case, for albums that were copied with windows but not with CopyInOrder, I can see that the library often has songs like:

 

03 - Third Song.flac

….

12 - Last Song.flac

01 - First song.flac

02 - Second song.flac (I too adopt the same naming convention as MusicHeaven)

 

and yeah, it plays them in that order...




Hi thanks for your help.

I checked what you asked under my "My Music" library in Windows and the albums are in order there. Has me really stumped as to why, it's hard to trigger.... well impossible to trigger manually. I can say since I reinstalled the firmware last night and turned gapless off it has not played out of order yet. Though, that means nothing really considering how random it is.


Once (if) it plays out of order one more time I'm going to run the debug tool iBasso gave me and start completely fresh after flashing the unit.

Really apprecaite you putting some thought into it though, we need more members like yourself. :)

post #13349 of 18446
Quote:
Originally Posted by H20Fidelity View Post
 




Hi thanks for your help.

I checked what you asked under my "My Music" library in Windows and the albums are in order there. Has me really stumped as to why, it's hard to trigger.... well impossible to trigger manually. I can say since I reinstalled the firmware last night and turned gapless off it has not played out of order yet. Though, that means nothing really considering how random it is.


Once (if) it plays out of order one more time I'm going to run the debug tool iBasso gave me and start completely fresh after flashing the unit.

Really apprecaite you putting some thought into it though, we need more members like yourself. :)

My pleasure mate:smile:… but I'm not sure if I understand you correctly about the library in Windows: if you look at the files on your sd card on Windows, it will display them in the order in which you are telling the OS to display folders - quite probably alphabetical;)

 

What I meant by looking at the Music library, is, look at what the library on the DX50 (the internal database it constructs by scanning) has, by touching "My Music" on the bottom left corner of the DAP, then either "Album" and select an album, or "Artist", then select Artist and the same album … what order are the songs in? And are the songs in the same order in both views (they should be, of course)… Also, if, still on the DX50, you go to Directory, and then wherever the same files are stored, are they in the same order (this is the view on which you actually see the filenames, like 01 - xxxx.yyy, while in the other views the DX50 displays only the tags)?

 

And if everything seems in order (and in the same order) in all 3 views through the DX50, I am really completely stumped:confused_face_2: ...

post #13350 of 18446

i have downloaded and tried the new port over from DX90.

 

It works fine on the DX50.

 

but on the audio part i think i need to take a longer listen.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.5 - June 30, 2016