or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 65

post #961 of 18427
Quote:
Originally Posted by Levanter View Post

Seems they will be fixing all the bugs within 2 days. Not sure if that is true or just a crowd control response. Its a bit hard to believe they could fix all bugs in such a short time frame. With new bugs being reported almost everyday

 


Sure they could fix it, but I doubt they'd be able to thorougly QA it as well, probably leaving the job to us (well us that have it, I'm still on the fence :p)

post #962 of 18427
Quote:
Originally Posted by sensui123 View Post

I've been pretty lucky I guess?  I haven't heard the reversed channel issue yet, my unit actually remembers the volume level after I turn it back on after I shut off.  I've dealt with one freeze the first time after the initial scan and another time where the touchscreen couldn't respond.....both cases did a battery pull.  Most of the bugs reported seem to be tag related and reading certain symbols in filenames/tags (I got some Japanese music that can't be listened to because the artist name is something that can't be read).....other than that, the player has been solid and extremely quick in response.  I don't think it's going to take more than a couple firmware releases to get this thing fairly solid and then just add back the features like everyone wants like search/playlist etc.  Most important thing, I've been enjoying the sound more and more the more I listen to it.


 



Sensui I think most of the weird bevhaviors reported to some degreed are caused by the DX50 hanged/forzen by the special characters it failed to handle.


My experience is that if the folder/file have no special char, the DX50 play nice and I have zero issue. Hack even gapless for flac, aac, m4a, etc all worked out of the box, which is already better than ALL my previous experience with audiophile DAPs.


HOWEVER, once I tried to play a file with the ' quotation mark, all hell broke loose and I got the various issues people reported: track won't play (obviously), scanning media screen keep popping up, volume reverted to 120 after restart, there was even one occassion of channel reverse. These issues are "fixed" with long press to shutdown and start up again AND avoiding the problematic track/folder. These periphiral issues also happen after say I tried to use coaxial to output high bit rate tracks.


This behvaior/finding gave me hope that these are indeed fixable relatively shortly as the ROOT cause seems to be the special character handling, and if I put on my aged old programmer hat on the special character 'error"/"event" weren't properly handled and branched off into all sorts of unexpected issues. Then of course it would be much easier if they had handle the special characters in the first place then to put a lot of exception handling codes into the firmware. This is what I suspect the "in 2 days" patch is going to do. They'd probably try to fix this one main issue, and see if they can mitigate a large portion of periphiral issues.


Of course these are all speculation based on my usage with DX50 and I could be way off. FWIW I didn't bother to re-tag or change the filename etc (as I had ALREADY PAINSTAKINGLY done that more than once for the AKs) and will just see how the next firmware handle them. I got enough tracks without issue to enjoy for now.



Cheers
Edited by kkcc - 9/11/13 at 1:51am
post #963 of 18427
Quote:
Originally Posted by kkcc View Post
 
Quote:
Originally Posted by sensui123 View Post
 

I've been pretty lucky I guess?  I haven't heard the reversed channel issue yet, my unit actually remembers the volume level after I turn it back on after I shut off.  I've dealt with one freeze the first time after the initial scan and another time where the touchscreen couldn't respond.....both cases did a battery pull.  Most of the bugs reported seem to be tag related and reading certain symbols in filenames/tags (I got some Japanese music that can't be listened to because the artist name is something that can't be read).....other than that, the player has been solid and extremely quick in response.  I don't think it's going to take more than a couple firmware releases to get this thing fairly solid and then just add back the features like everyone wants like search/playlist etc.  Most important thing, I've been enjoying the sound more and more the more I listen to it.

 



Sensui I think most of the weird bevhaviors reported to some degreed are caused by the DX50 hanged/forzen by the special characters it failed to handle.



My experience is that if the folder/file have no special char, the DX50 play nice and I have zero issue. Hack even gapless for flac, aac, m4a, etc all worked out of the box, which is already better than ALL my previous experience with audiophile DAPs.



HOWEVER, once I tried to play a file with the ' quotation mark, all hell broke loose and I got the various issues people reported: track won't play (obviously), scanning media screen keep popping up, volume reverted to 120 after restart, there was even one occassion of channel reverse. These issues are "fixed" which long press to shutdown and start up again AND avoiding the problematic track/folder. These periphiral issues also happen after say I tried to use coaxial to output bit bit rate tracks.



This behvaior/finding gave me hope that these are indeed fixable relatively shortly as the ROOT seems to be the special character handling, and if I put on my aged old programmer hat the special character 'error"/"event" weren't properly handled and branched off into all sorts of issues. Then of course it would be much easier if they had handle the special characters in the first place then to put a lot of exception handling codes into the firmware. This is what I suspect the "in 2 days" patch is going to do. They'd probably try to fix this one main issue, and see if they can mitigate a large portion of issues.



Of course these are all speculation based on my usage with DX50 and I could be way off. FWIW I didn't bother to re-tag or change the filename etc (as I had ALREADY PAINSTAKINGLY done that more than once for the AKs) and will just see how the next firmware handle them. I got enough tracks without issue to enjoy for now.



Cheers

 

man that means i better go clean up those tags of mine! problem is i spend too much time listening to it rather than taking my ciems off and go about with the house cleaning of the tags :P

post #964 of 18427
Thread Starter 
Cleaning up the tags/file names definitively makes a huge difference with the dap experience and enjoyment, too bad it's something they did not catch off the bat, it would have made a bigger impact on the first dap impression.

For me though I wanted to clean them up but always put it off because of my players not caring about their quirkiness, although a quote is just normal should not choke over that.
Edited by musicheaven - 9/11/13 at 1:35am
post #965 of 18427
Quote:
Originally Posted by azarel View Post
 

 

man that means i better go clean up those tags of mine! problem is i spend too much time listening to it rather than taking my ciems off and go about with the house cleaning of the tags :P

 

Let's not forget you were suppose to use that time to actually clean the house ;).

post #966 of 18427

What is the optimal size for album art to be displayed on the DX50?? Since all my album art is 600 X 600 and I read somewhere that DX50 does not recognize album art above the size of 500 X 500...Is that correct??

I would really appreciate if someone could confirm this, so that I can go about downloading new artwork before my DX50 arrives.

post #967 of 18427
Quote:
Originally Posted by kkcc View Post
 
Quote:
Originally Posted by sensui123 View Post
 

I've been pretty lucky I guess?  I haven't heard the reversed channel issue yet, my unit actually remembers the volume level after I turn it back on after I shut off.  I've dealt with one freeze the first time after the initial scan and another time where the touchscreen couldn't respond.....both cases did a battery pull.  Most of the bugs reported seem to be tag related and reading certain symbols in filenames/tags (I got some Japanese music that can't be listened to because the artist name is something that can't be read).....other than that, the player has been solid and extremely quick in response.  I don't think it's going to take more than a couple firmware releases to get this thing fairly solid and then just add back the features like everyone wants like search/playlist etc.  Most important thing, I've been enjoying the sound more and more the more I listen to it.

 



Sensui I think most of the weird bevhaviors reported to some degreed are caused by the DX50 hanged/forzen by the special characters it failed to handle.


My experience is that if the folder/file have no special char, the DX50 play nice and I have zero issue. Hack even gapless for flac, aac, m4a, etc all worked out of the box, which is already better than ALL my previous experience with audiophile DAPs.


HOWEVER, once I tried to play a file with the ' quotation mark, all hell broke loose and I got the various issues people reported: track won't play (obviously), scanning media screen keep popping up, volume reverted to 120 after restart, there was even one occassion of channel reverse. These issues are "fixed" with long press to shutdown and start up again AND avoiding the problematic track/folder. These periphiral issues also happen after say I tried to use coaxial to output high bit rate tracks.


This behvaior/finding gave me hope that these are indeed fixable relatively shortly as the ROOT cause seems to be the special character handling, and if I put on my aged old programmer hat on the special character 'error"/"event" weren't properly handled and branched off into all sorts of unexpected issues. Then of course it would be much easier if they had handle the special characters in the first place then to put a lot of exception handling codes into the firmware. This is what I suspect the "in 2 days" patch is going to do. They'd probably try to fix this one main issue, and see if they can mitigate a large portion of periphiral issues.


Of course these are all speculation based on my usage with DX50 and I could be way off. FWIW I didn't bother to re-tag or change the filename etc (as I had ALREADY PAINSTAKINGLY done that more than once for the AKs) and will just see how the next firmware handle them. I got enough tracks without issue to enjoy for now.



Cheers

 

It's not just that symbol that is the problem. There are problems with numerical numbering of tracks, and there is absolutely something else going on with flacs. I played 320 mp3's without a problem that have a ' but not flacs? Then there are tracks with simple names like BELIEVE.flac that I have that won't play, but another flac will play. I've sent song examples to them so we'll see what they have to say. 

post #968 of 18427
Can anyone tell me how long this will take to get to Australia if I buy now and its shipped on Monday?
post #969 of 18427
Quote:
Originally Posted by dryvadeum View Post

Can anyone tell me how long this will take to get to Australia if I buy now and its shipped on Monday?

Maybe you'll receive by the end of that week?
post #970 of 18427

SkyBleu is correct, about 3-5 days using EMS to Australia.

post #971 of 18427
Quote:
Originally Posted by BadBoySimran View Post

What is the optimal size for album art to be displayed on the DX50?? Since all my album art is 600 X 600 and I read somewhere that DX50 does not recognize album art above the size of 500 X 500...Is that correct??



I would really appreciate if someone could confirm this, so that I can go about downloading new artwork before my DX50 arrives.


 




The 500x500 limitation is for AK100/AK120.

Since I've "cleaned" all of mine to 499x499 for the AK, I cannot confirm if larger artwork works on DX50.
post #972 of 18427

Any sound comparison between iBasso DX50 vs Colorfly C3?

 

I read C3 forum that it have a very neutral, bright, detail, good separation and wide sound stage but less bass.

It is 50% price of DX50.

post #973 of 18427
Quote:
Originally Posted by H20Fidelity View Post

SkyBleu is correct, about 3-5 days using EMS to Australia.

So it will be sent through ems and not dhl?
post #974 of 18427
Quote:
Originally Posted by dryvadeum View Post

So it will be sent through ems and not dhl?

Pretty sure it will be DHL. Either way it's about the same amount of time. Just hang in there a while. Crack a tinny or throw a shrimp on the barbecue.
post #975 of 18427
Quote:
Originally Posted by H20Fidelity View Post

Pretty sure it will be DHL. Either way it's about the same amount of time. Just hang in there a while. Crack a tinny or throw a shrimp on the barbecue.

I only ask cos Im not going to be home on Thursday and Friday and didnt want it left on my doorstep or something.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016