or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 63

post #931 of 18427
Quote:
Originally Posted by shigzeo View Post
 

 

The main difference is that iBasso are pretty open about what they do and about their spec. Maybe HiSound have changed since the early days, but they really blew it with the AMP3. iBasso really are on another level.

 

Hard to disagree on that point. Between hisound and ibasso's level of willingness to communicate, the difference is as different as day and night. In this aspect HiSound really do need to buck up. They should set IBasso as the benchmark in communications and strive towards that.

post #932 of 18427
Quote:
Originally Posted by TekeRugburn View Post
 

yeah; just experienced the channels being reversed.  I hope they fix this asap.  Kinda unacceptable to have the channels reversed


I've sent iBasso an email asking with a few links to people reporting this. If anyone has heard back from them regarding this please tell us. So does yours it just happened randomly does it? I am guessing it's not a hardware issue if it occurs randomly. It's something I would not be able to live with personally, well not without going crazy........

post #933 of 18427
post #934 of 18427
Quote:
Originally Posted by H20Fidelity View Post


I've sent iBasso an email asking with a few links to people reporting this. If anyone has heard back from them regarding this please tell us. So does yours it just happened randomly does it? I am guessing it's not a hardware issue if it occurs randomly. It's something I would not be able to live with personally, well not without going crazy........

Yeah its random. Sometimes the song is fine... Other times it's switched.
post #935 of 18427
Quote:
Originally Posted by TekeRugburn View Post


Yeah its random. Sometimes the song is fine... Other times it's switched.

 

Although disappointing that suggests to me it's simply a firmware bug. Hopefully corrected in the update coming very soon.
 

post #936 of 18427
Quote:
Originally Posted by DMinor View Post

Looks like your iMod needs to be remodded or more burn-ins. LOL.
Or more likely let it retire peacefully and let the young ones take over. Oh sorry. Lol.
post #937 of 18427
Quote:
Originally Posted by Mimouille View Post


Or more likely let it retire peacefully and let the young ones take over. Oh sorry. Lol.

 

Sorry for what?

post #938 of 18427
Quote:
Originally Posted by DMinor View Post

Sorry for what?
Nothing just joking.
post #939 of 18427
Quote:
Originally Posted by Mimouille View Post


Nothing just joking.

 

Me too. Now i need to order the DX50 and throw away my diyimod.

post #940 of 18427

I received a reply back from iBasso (in good time I might add)

This is regarding the reverse channel issue people are experiencing. 


 

Quote:
Hi,
Thank you for your email.
We have noticed the reverced channels problem. We will fix this bug and release the new firmware in two days.
 
Sincerely

 

post #941 of 18427

Anyone got word on when they will make the playlist feature available? 

post #942 of 18427
Seems they will be fixing all the bugs within 2 days. Not sure if that is true or just a crowd control response. Its a bit hard to believe they could fix all bugs in such a short time frame. With new bugs being reported almost everyday
post #943 of 18427

i gave up trying and revert back to my x3 for the time being...lucky i havent sell it :D

post #944 of 18427
If somebody experiencing track skips due to special symbols like ' in the title can get the id3 or metadata as an example off to ibasso they will have a look. I've been discussing this issue in particular with them and they're keen to resolve it. I'm at work now so cannot send an example unfortunately. Will happily forward the emails on if required

Cheers
post #945 of 18427

for those who keen to bring spare battery and swap to your dx50 when the 1st battery run out....you will have the battery indicator display wrong battery status..and here is the replied from ibasso~

 

Quote:
Hi,
The power management chip needs a complete charge and discharge cycle to set the battery indicator.
After you replaced the battery, the battery indicator is incorrect on the first discharge cycle. It would be corrected on the second cycle.
 
Sincerely
iBasso Audio

 

 
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016