or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 617

post #9241 of 18426
Quote:
Originally Posted by Skp44 View Post


You are right, some users said you could hot swap cards but I found this problematic even when it was scanning properly. My files are all meticulously tagged and organized, but I bought a new 32gb card and used it to eliminate my other cards as being the problem.
Yes I have reset it a number of times. It will scan and come back with a few of files on the card, but with nothing in the folders. It worked great straight out of the box and I have not changed anything, same cards and same files it scanned fine at first. I would be very happy with the DX50 if it operated, it sounded great on it's own and and fantastic with my PB2. The gapless worked great as well!. Thanks for your replies gents.

Cheers,
Shawn

I would install the firmware again. Maybe install the most recent FW. I haven't been having any problems with the latest. 

post #9242 of 18426

Just installed 1.2.6 yesterday, the media scanning is a lot better for a messy tagger like myself...Most of the files appear now and playing from the file browsing mode also does not result in hanging... really satisfied with the player now!

post #9243 of 18426
Quote:
Originally Posted by youkeum View Post

yepp- It is the Dignis case-

Thats good news for DX50 users. They did a good job with the leather cases for AstellKern. They must have seen a market for the DX to jump in as well smily_headphones1.gif
post #9244 of 18426

My PB2 amp arrived on the 23rd so I haven't had time to actually listen to it yet - half an hour, tops. But me being busy means time for burn-in! This offered me a perfect chance to test how stable my DX50 is with my carefully tagged FLAC library. During the day it's on my desk in our bedroom, plugged into a 2A power supply, connected to the PB2 that's driving an old pair of Steelseries 4H while hooked up to it's own PSU. At night, the rig is placed in the kitchen, running on batteries. So far it has played non-stop for 75 hours, cycling through all my music. Not a single pause, lockup or hickup. Just keeps going :)

post #9245 of 18426
Quote:
Originally Posted by Sorensiim View Post
 

My PB2 amp arrived on the 23rd so I haven't had time to actually listen to it yet - half an hour, tops. But me being busy means time for burn-in! This offered me a perfect chance to test how stable my DX50 is with my carefully tagged FLAC library. During the day it's on my desk in our bedroom, plugged into a 2A power supply, connected to the PB2 that's driving an old pair of Steelseries 4H while hooked up to it's own PSU. At night, the rig is placed in the kitchen, running on batteries. So far it has played non-stop for 75 hours, cycling through all my music. Not a single pause, lockup or hickup. Just keeps going :)

Good work Soren. Can't wait to hear about how it sounds after burn in

post #9246 of 18426
Thread Starter 
Quote:
Originally Posted by Sorensiim View Post

My PB2 amp arrived on the 23rd so I haven't had time to actually listen to it yet - half an hour, tops. But me being busy means time for burn-in! This offered me a perfect chance to test how stable my DX50 is with my carefully tagged FLAC library. During the day it's on my desk in our bedroom, plugged into a 2A power supply, connected to the PB2 that's driving an old pair of Steelseries 4H while hooked up to it's own PSU. At night, the rig is placed in the kitchen, running on batteries. So far it has played non-stop for 75 hours, cycling through all my music. Not a single pause, lockup or hickup. Just keeps going smily_headphones1.gif

Does not surprised me, I have been playing my DX50 for weeks, every day from morning to evening, constantly changing tunes and nota single luck up. Never had to reboot. Pretty stable little bundle of joy.

Congrats Soren, let us know how your new balanced rig sound. cool.gif
post #9247 of 18426
Quote:
Originally Posted by spurxiii View Post
 

Good work Soren. Can't wait to hear about how it sounds after burn in

 

 

Quote:
Originally Posted by musicheaven View Post


Does not surprised me, I have been playing my DX50 for weeks, every day from morning to evening, constantly changing tunes and nota single luck up. Never had to reboot. Pretty stable little bundle of joy.

Congrats Soren, let us know how your new balanced rig sound. cool.gif

I might be able to get my hands on some Hirose connectors tomorrow, so I can try the balanced output. It'll have to be pretty damn good to oust the Quickstep, that's for sure!

post #9248 of 18426
I tried to order some Hirose connectors from iBasso but they cancelled my order and refunded me due to no stock.

Anyone know where I can get some?
post #9249 of 18426
Quote:
Originally Posted by Sorensiim View Post
 

My PB2 amp arrived on the 23rd so I haven't had time to actually listen to it yet - half an hour, tops. But me being busy means time for burn-in! This offered me a perfect chance to test how stable my DX50 is with my carefully tagged FLAC library. During the day it's on my desk in our bedroom, plugged into a 2A power supply, connected to the PB2 that's driving an old pair of Steelseries 4H while hooked up to it's own PSU. At night, the rig is placed in the kitchen, running on batteries. So far it has played non-stop for 75 hours, cycling through all my music. Not a single pause, lockup or hickup. Just keeps going :)

nice Soren now i could follow your settings into it. had it delivered at the office last day. DB2 + PB2 (stock opamps) really pairs well. using my DX50 as a pure transport just for that dual WM.

post #9250 of 18426
Quote:
Originally Posted by spurxiii View Post

I tried to order some Hirose connectors from iBasso but they cancelled my order and refunded me due to no stock.

Anyone know where I can get some?

Mouser and Digikey are 2 US electronic parts houses that stock the Hirose connectors.
post #9251 of 18426
Hello all,
My player came with 1.2.6, and every time I go out side and put it in my pocket and go mobile,the player freezes up. It is like the second the player experiences the climate change,
(In my case NYC ) the cold freezes it up.rolleyes.gif I leave the player on shuffle don't know if this has anything to do with it!? I push down the power and play button at the same time and it fixes it. Is this the correct way to do a factory resets, or is that just a hard boot?


Regards
Jeff
post #9252 of 18426
Quote:
Originally Posted by jamato8 View Post

I would install the firmware again. Maybe install the most recent FW. I haven't been having any problems with the latest. 
I took your advice jamoto8, and discovered the problem. The progress bar on the media scan screen was inactive after I started a scan. The problem is in the card slot, either the spring or the latching mechanism. When I insert a card it makes a good connection, the connection gets broken shortly after insertion. If I keep my finger on the card it scans fine. So for the time being I take an old micro card and put it behind the other and it stays connected. There is no bar in 1.2.5 so I had no way of knowing it was not actually scanning.
Back in business, the DX50/PB2 combo sounds great even just using the line out.

Cheers,
Shawn
post #9253 of 18426
Quote:
Originally Posted by Olanzky View Post
 

nice Soren now i could follow your settings into it. had it delivered at the office last day. DB2 + PB2 (stock opamps) really pairs well. using my DX50 as a pure transport just for that dual WM.

I followed this setup shared by Spurxii:

 

It's the buffers and opamps that came with the PB2 and I must say I really like the sound of it! I'm picking up two Hirose connectors tomorrow so I can finally get to make some balanced cables :smile:

 

79 hours of non-stop playback and counting, by the way. 1.2.6 firmware, flac files with clean tags.

post #9254 of 18426
1.2.6 seems good and stable apart from the broken gapless
post #9255 of 18426
Quote:
Originally Posted by nc8000 View Post

1.2.6 seems good and stable apart from the broken gapless

Gapless will be fixed in the 1.2.7 update that'll be out in a couple of days :smile:

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016