or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 62

post #916 of 18426
Quote:
Originally Posted by TekeRugburn View Post
 

 

i would say no.  She's more high class; AK120 more like it

 

Or maybe a power generator, Cantata, KGSSHV, SR009 on a dolly with Mr. Park rolling it around and Queen listening while walking. :}

post #917 of 18426
Quote:
Originally Posted by 00lunar View Post
 

I'm aware that comparison pictures were flying around here for a while. Still, I took some pictures for people here to see EXACTLY how big/small is DX50 among other, popular DAP-s. Enjoy. Btw. That thing is a beast regarding its SQ. Was able to compare it to my ol' faithful DYIMod, which had his a** kicked.

 

 

 

 

 

 

 

 

 

Amazing work. 

post #918 of 18426

Yes, added to OP with credits. Thanks!

 

Waiting for additional post 100hr impressions to add to OP ~~~~

post #919 of 18426
Quote:
Originally Posted by Room40 View Post

Can peeps post some pics of the line out combo please. I cant get any line out working with the supplied cable at all in any combination but I could well be doing it wrong. Ta

The supplied cable is not for the line out. It is for the coax output
post #920 of 18426
Quote:
Originally Posted by icefalkon View Post


How are you guys loading music onto your units? This is what's going on and it's weird...

I load a Sd card up with tunes using MM...pop it into the DX50 and it scans the card. However...say I go to My Music / All Music and pick a song. It plays the song.

HOWEVER...when I hit forward...it just plays the song again. Now I have set it to Random Play...so it's not on repeat...

So...I go BACK into My Music / All Music and select another song...it plays the song.

When I hit forward, it plays the previous song (the first one) again!

So...I go BACK into My Music / All Music and select a THIRD song...it plays the song.

When I hit forward...wait for it...

You guessed it...it now plays the previous songs only. The unit isn't forwarding to any songs that I haven't manually hit PLAY on.

So i'm thinking...maybe I'm doing something wrong here. I tried this with 2 Sandisk cards so far and it's the same thing. 

My next experiment is to just create a folder on the microSD card and throw some music into it and see what happens. 

Has anyone else had this, or does anyone have a solution to it?

Thanks!

I'm having the same problem and have not found a solution yet. My micro SDHC cards have folders (each is an album) containing FLAC files (44.1/16 CD's ripped with dbPoweramp). When inserting a card, the DX50 seems to read it fairly quickly. But then I have to manually select each song/file in the folder for it to play. After I've selected a song, it will then play in the proper sequence along with any other songs in that folder that I have manually selected and played. I've been unable to get it to play through a folder without doing this.

I'm very happy with the SQ though. It sounds terrific using it as a player/DAC and feeding line out to my ALO Rx-Mk3-B+ portable amp.

Just need some firmware that's not so buggy!
post #921 of 18426

Is there a "Resume" option anywhere to have the DX50 resume play at the last played track?  I don't see such an option anywhere but may have missed it.

post #922 of 18426
Quote:
Originally Posted by icefalkon View Post

LOL you're kidding right? This little product has been watched by all eyes since it's announcement. and iBasso has just as many mouths touting their goodness as iRiver does. What is fact is that iRiver has more "flash" than iBasso does...hell it's a bigger enterprise. 

What makes me laugh is all the hypothesis of what direction the company should take. You know...for a cheap ass unit that can play hi fidelity files there sure is a lot of....they should make this, they should make that nonsense going on. How about guys just try to figure the damn thing out, let iBasso catch up with all the glitches and run with the unit in hand instead of mind wandering about what "could" be done. 

As for working together...? Again...is that naivety or are you joking? They are competitors for the same niche group of individuals...one is trying to undermine the other by coming out with a product that does "almost" the same thing at a third of the cost. If there are issues with the cheaper product...hell...deal with it. It only costs 1/3 of what an AK costs. 

Now...if I may...

How are you guys loading music onto your units? This is what's going on and it's weird...

I load a Sd card up with tunes using MM...pop it into the DX50 and it scans the card. However...say I go to My Music / All Music and pick a song. It plays the song.

HOWEVER...when I hit forward...it just plays the song again. Now I have set it to Random Play...so it's not on repeat...

So...I go BACK into My Music / All Music and select another song...it plays the song.

When I hit forward, it plays the previous song (the first one) again!

So...I go BACK into My Music / All Music and select a THIRD song...it plays the song.

When I hit forward...wait for it...

You guessed it...it now plays the previous songs only. The unit isn't forwarding to any songs that I haven't manually hit PLAY on.

So i'm thinking...maybe I'm doing something wrong here. I tried this with 2 Sandisk cards so far and it's the same thing. 

My next experiment is to just create a folder on the microSD card and throw some music into it and see what happens. 

Has anyone else had this, or does anyone have a solution to it?

Thanks!

This should be corrected on the upcoming firmware ...mine does the same thing. The FWD and BACK buttons work OK when playing from the Directory.
post #923 of 18426

Thanks to all the folks who already purchased this, discovered the bugs and made ibasso aware of them - it will make life easier for a lot of people down the road. I'll definitely be getting one of these in the future.

post #924 of 18426
Quote:
Originally Posted by DMinor View Post
 

 

Steve you need to clarify which one kicks first. They can't kick at the same time.:wink_face:

 

LOL touche' 

 

Ok...first I thought the iMod was totally ass kicking...

 

Then I got  a C3...and that kicked ass too...

 

But then I swapped for a Cowon J3...and well...there was some serious kick ass sound coming out of it when paired with that little C&C amp...

 

Somehow I ended up with both a DX100 AND a RWAK and they both are champion ass kickers in their own rights...

 

However...when it works...the DX50 kicks some serious ass over everything but the DX100 and the RWAK100...

 

So I guess my ears tell me:

 

DX100 - still Reigning Champion

RWAK100 - Heir to the Throne (of my personal collection)

DX50 - What do you call the 2nd Prince? He's not the Heir...he's the...wait for it...the SPARE...ha ha..

J3/C&C Amp Combo - Next in line

C3 - hmmm can't even find the bugger...

RWA iMod - retired oldie but goodie

 

Steve from NYC


Edited by icefalkon - 9/10/13 at 7:53pm
post #925 of 18426

OK...good. I'm not the only guy with these problems. Thank god. I certainly don't want to go through the fiasco of sending another iBasso product back to China multiple times. 

 

I'm confident that the iBasso team will fix our issues. They have a LOT riding on this. Hell, it's a game changer...for OUR pockets benefit to be honest here...the sound out of this thing, for it's price point is absolutely awesome. They've literally just made hi fi audio available to a ton of people who would never have been able to purchase a $600 - $1200 dollar unit. Seriously. This is great for all of us. I mean...holy crap...a great sounding unit...that yeah...may need some tweaks...but still great sounding...

 

That's AFFORDABLE? 

 

OMG did I just write the taboo word here...??!!!?? 

 

:wink_face:

 

Steve from NYC

post #926 of 18426

yeah; just experienced the channels being reversed.  I hope they fix this asap.  Kinda unaccaptable to have the channels reversed

post #927 of 18426

lol yah. actually i think both hissound, fiio, ibasso have done the headfi community a great service by providing fantastic sounding daps for affordable prices. Granted there's alot of problems with the firmware and UI, but generally its a very positive step for the hobby itself. Hats off to them.

post #928 of 18426
Quote:
Originally Posted by icefalkon View Post
 

 

LOL touche' 

 

Ok...first I thought the iMod was totally ass kicking...

 

Then I got  a C3...and that kicked ass too...

 

But then I swapped for a Cowon J3...and well...there was some serious kick ass sound coming out of it when paired with that little C&C amp...

 

Somehow I ended up with both a DX100 AND a RWAK and they both are champion ass kickers in their own rights...

 

However...when it works...the DX50 kicks some serious ass over everything but the DX100 and the RWAK100...

 

So I guess my ears tell me:

 

DX100 - still Reigning Champion

RWAK100 - Heir to the Throne (of my personal collection)

DX50 - What do you call the 2nd Prince? He's not the Heir...he's the...wait for it...the SPARE...ha ha..

J3/C&C Amp Combo - Next in line

C3 - hmmm can't even find the bugger...

RWA iMod - retired oldie but goodie

 

Steve from NYC

 

Looks like your iMod needs to be remodded or more burn-ins. LOL.

post #929 of 18426
Quote:
Originally Posted by azarel View Post
 

lol yah. actually i think both hissound, fiio, ibasso have done the headfi community a great service by providing fantastic sounding daps for affordable prices. Granted there's alot of problems with the firmware and UI, but generally its a very positive step for the hobby itself. Hats off to them.

 

The main difference is that iBasso are pretty open about what they do and about their spec. Maybe HiSound have changed since the early days, but they really blew it with the AMP3. iBasso really are on another level.

post #930 of 18426
Quote:
Originally Posted by Greed View Post
 

 

Going to try it line out to my Pico Power to see how much I can improve its performance. If anyone is wondering the DX50 stacks nearly perfect ontop of the Pico Power. 

 

Eric, you are in for a real treat.  I listened to that combo for half a day today outside of my O2.....spectacular setup to go IMO.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016