or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 547

post #8191 of 18426
The sleep timer is a feature of the new firmware 1.2.6 but it seems to be hit or miss if the new firmware works properly.
post #8192 of 18426

Just updated to 1.2.6, went without an hitch… scanning times have improved tremendously, and I personally like the sound signature a LOT (after trying 1.2.5, I went back to 1.2.2 - but I think that I'll stay with 1.2.6). Haven't had time yet to see if the problems others have mentioned (new sleep feature not working properly, gapless working worse than before) are there for me too.

 

Overall, even if the problems others have mentioned will be there, I'm personally pretty happy with the new FW.

 

Edited to add: Oh, and I just noticed that the "grab the title and slide to the left to read it all" (when a song is playing) now works also on the album title… very good addition


Edited by geagle - 12/9/13 at 12:59am
post #8193 of 18426
Quote:
Originally Posted by punit View Post
 

 

I don't think there is a sleep timer feature, it only has auto shut down in case of no activity (I am running 1.2.5). Also when  the player shuts down, it starts again in scan files window, it doesn't start with playing the song , which it was playing when it shutdown. It is such a pain to go back to that album & select that song again.

 

I have X3  also, it is so much more user friendly & has much better features IMHO. Even HM601 is more user friendly, it may not look as good & have a slick UI , but is certainly better to use due to having more features.

What do you think about the SQ compared to X3 if we exclude the amp section? (Line out to other amp) So player and DAC only.

post #8194 of 18426

Hi All,

I have a problem which i wanted to share with you.

I am an owner of the amazing DX50 (latest software version) and been using it with my Beyerdynamic DT 770 PRO, 80 ohms.

Sound is amazing and detailed.

 

Last week i got the Westone 3  (3 drivers)..i connected it to my computer and my Cowon S9 and they all sounded amazing, detailed as it should be. The only MAIN problem is when I connect it to the DX50, it goes down the hill... no details.... no brights.. and I don't know what to do.

 

i have couple of אheories:

 

1. the beyer are 80 ohms and the W3 are 30 ohms and DX doesn't sound good with lower ohms (?)

2. maybe 1.2 software version doesn't go well with the W3, i need to roll back to the oldest ver and text

 

please advise.

post #8195 of 18426

Holly Crap, that is some big bass! Just upgraded to the new 1.2.6 FW and it is very different sound wise, more of a fun signature using my NT6 Pro. It is much warmer and smoother with fuller bass and more punch but retaining the detail and without bloat. I can't use my amp any more as it doesn't sound good, nor do I need it any more. IMO, this DAP no longer needs an amp to sound complete.

post #8196 of 18426
The W3 should pair well and the DX50 does well with lower impedance IEMs. Maybe it's just bad synergy like the RE400?
post #8197 of 18426
Done updating. I love the sensitivity of the touch screen.
Follow up for the impressions later
post #8198 of 18426
Quote:
Originally Posted by MusicFiMan View Post
 

Hi All,

I have a problem which i wanted to share with you.

I am an owner of the amazing DX50 (latest software version) and been using it with my Beyerdynamic DT 770 PRO, 80 ohms.

Sound is amazing and detailed.

 

Last week i got the Westone 3  (3 drivers)..i connected it to my computer and my Cowon S9 and they all sounded amazing, detailed as it should be. The only MAIN problem is when I connect it to the DX50, it goes down the hill... no details.... no brights.. and I don't know what to do.

 

i have couple of אheories:

 

1. the beyer are 80 ohms and the W3 are 30 ohms and DX doesn't sound good with lower ohms (?)

2. maybe 1.2 software version doesn't go well with the W3, i need to roll back to the oldest ver and text

 

please advise.

You are using the HP out and not the lineout, right?

post #8199 of 18426

I'm using it correctly with the HP connection... its not that. the line out i use with my National.

post #8200 of 18426
Quote:
Originally Posted by Varoudis View Post
 

What do you think about the SQ compared to X3 if we exclude the amp section? (Line out to other amp) So player and DAC only.

SQ wise both are same to me, no preference (both HP & Line out).

post #8201 of 18426
Quote:
Originally Posted by lin0003 View Post

The W3 should pair well and the DX50 does well with lower impedance IEMs. Maybe it's just bad synergy like the RE400?
IEM SE215 does not sound great with DX50 too.
It seems like DX50 like to work with big cans?
post #8202 of 18426
Quote:
Originally Posted by punit View Post
 
Quote:
Originally Posted by Varoudis View Post
 

What do you think about the SQ compared to X3 if we exclude the amp section? (Line out to other amp) So player and DAC only.

SQ wise both are same to me, no preference (both HP & Line out).

The output impedance of the HP out is very low (below 2 ohms I believe was measured) while the OI of the Lineout was measured to 120 ohms. That should make quite a difference, especially with multi-BA iems. I remember trying the Calyx Kong (32ohm OI) with the W3 and they sounded HORRIBLE from it. 

post #8203 of 18426
Quote:
Originally Posted by punit View Post
 

SQ wise both are same to me, no preference (both HP & Line out).

 

Quote:
Originally Posted by Sorensiim View Post
 

The output impedance of the HP out is very low (below 2 ohms I believe was measured) while the OI of the Lineout was measured to 120 ohms. That should make quite a difference, especially with multi-BA iems. I remember trying the Calyx Kong (32ohm OI) with the W3 and they sounded HORRIBLE from it. 

 

Sorry your post isin't clear to me. What I meant from my post was i do not have any preference between Fiio X3 HP out vs Dx50 HP out. (with Shure SE 530, SE 535 RED Ltd, Senn HD 25 Aluminium, Beyer DT 1350, DT 770 32 Ohm). Similarly  no preference  between X3 & Dx50 Line out connected to my Kenwood car stereo. SQ wise both X3 & DX50 are equal IMHO.


Edited by punit - 12/9/13 at 1:56am
post #8204 of 18426
Quote:
Originally Posted by punit View Post
 
Quote:
Originally Posted by punit View Post
 

SQ wise both are same to me, no preference (both HP & Line out).

 

Quote:
Originally Posted by Sorensiim View Post
 

The output impedance of the HP out is very low (below 2 ohms I believe was measured) while the OI of the Lineout was measured to 120 ohms. That should make quite a difference, especially with multi-BA iems. I remember trying the Calyx Kong (32ohm OI) with the W3 and they sounded HORRIBLE from it. 

 

Sorry your post isin't clear to me. What I meant from my post was i do not have any preference between Fiio X3 HP out vs Dx50 HP out. (with Shure SE 530, SE 535 RED Ltd, Senn HD 25 Aluminium, Beyer DT 1350, DT 770 32 Ohm). Similarly  no preference  between X3 & Dx50 Line out connected to my Kenwood car stereo. SQ wise both X3 & DX50 are equal IMHO.

Ah, my bad - I thought you meant that the linout and the HP out sounded the same :)

 

 

...still doesn't solve the mystery of the W3 performing poorly out of the DX50, though.

post #8205 of 18426
Could be the hiss - gain of the dx50's amp?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016