or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 430

post #6436 of 18427

Dx50 has been reliable here, so far,  enough to get rid of some extras but iPod stays :)

post #6437 of 18427

Guys,

 

big fan of the DX50 over here. I have both Sennheiser Momentum (over ear) and KEF M500's.

 

To my ears the KEF's beat the Momentums hands down when paired with the DX50, they shine with a level of clarity you just don't get with the Momentum's. I urge anyone auditioning the Momentum's to think about the KEF's they have blown me away with their clarity, they have excellent PRAT and a really good soundstage.

 


Edited by subseasniper - 11/9/13 at 7:09am
post #6438 of 18427
Thread Starter 
Quote:
Originally Posted by subseasniper View Post

Guys,

big fan of the DX50 over here. I have both Sennheiser Momentum (over ear) and KEF M500's.

To my ears the KEF's beat the Momentums hands down when paired with the DX50, they shine with a level of clarity you just don't get with the Momentum's. I urge anyone auditioning the Momentum's to think about the KEF's they have blown me away with their clarity, they have excellent PRAT and a really good soundstage.



Thanks for your comparison. I bought the KEF M500 a few weeks back and the Momentums afterwards when I brought the DX50 to an electronic store, compared both and returned the KEF maybe it required some burn-in, I just did not like the dull flat sound from the KEF, Momentum were livelier, fuller and impact full. I guess we do have different taste for what sounds right to our ears. smily_headphones1.gif
post #6439 of 18427

When I turn off/on my DX50 it makes a noise like a click or something like that. Is it normal?

 

Thanks in advance :)

post #6440 of 18427
Quote:
Originally Posted by L18Lodestar View Post
 

When I turn off/on my DX50 it makes a noise like a click or something like that. Is it normal?

 

Thanks in advance :)

 

Perfectly normal. There is a relay in there to protect again 'click and pop' of the amp section and the clicking sound means the relay is working.

post #6441 of 18427
Quote:
Originally Posted by Jpfe8851 View Post


Not a reset button but a reset procedure. Like Tin427 says, if the unit locks up press and hold the power and volume up button and keep holding after the unit shuts down until it restarts with the usual start screen. Release then. At boot up you will see a recovery screen. Try reboot first however this rarely works alone. Use the volume up and down buttons to scroll down to factory reset and wipe. MAKE SURE YOU REMOVE YOUR SD CARD TO AVOID REFORMATTING IT
After restarting which it should do, your DX will be set to factory defaults. Insert your SD card and scan. Should be all good after that.

I think Soren has put this in the FAQ in the Wiki section, but it does keep coming up here. If you have any other problems, check out Soren's FAQ first or the bugs thread which has a lot of issues covered there too.

EDIT: Seems it is not necessary to remove SD during reset. Thanks Musicheaven.

Yes, It works Wonderfullly.  SOUNDS AMAZING WITHOUT AMPING!  JH16 sings like PAVAROTTI!!

 

 

Thank YOU EVERYONE!

post #6442 of 18427
Quote:
Originally Posted by snapple10 View Post
 

Dx50 has been reliable here, so far,  enough to get rid of some extras but iPod stays :)

Is there a reason you use the headphone out to connect your amp and not the line out?

post #6443 of 18427

no, both sound the same to me

 

I just use the Pico to adjust the volume

post #6444 of 18427
So my DX50 just decided to die on me for seemingly no reason at all after 3 days of operation. Getting the orange exclamation mark when I power on? Can anyone help me out with this?
post #6445 of 18427

I thought I'd throw this out there. I've been following this thread since the 2nd batch and own a 3rd batch. From what I've seen here, and experienced with mine, is that there are many different opinions on SQ and hardware/firmware issues/non-issues. More than I would have thought, until I realized this is relatively new territory with a lot of things to work out, especially with a company with a limited R&D budget and not much similar product to copy from. Sorry, to get ideas from.

 

My personal findings are that the sound is not quite to my liking. Maybe you've already responded to that in your head, maybe with a little defense of the DX50. Excellent. Great. Maybe not. I've had zero problems with the HW/FW from the start (my first update was 1.1.6). A few suggestions for change, but nothing a few updates can't address.

 

I find all the various opinions more comforting as time goes by because it reminds me that I've paid a relatively low price for a pretty nice piece of kit in a sorta beta, not-ready-for-a-higher-price stage. For the ones that have no issues and love the sound, this is a hell of a deal. But I don't regret the purchase at all. I like how the 1.2.1 improved the SQ, so I'll just wait for each update and see how things progress. I'm pretty sure they'll do something with that crazy-ass EQ.

 

I'll end up keeping the thing, anyway. I saw the thread on the upcoming X5, and there'll be more and more of these hi-res beauties coming to our obsessive little hands in the near future. Hell, if Sony's gonna put their greedy mark on it, then hey. Man, I used to love Sony.

 

So, Go iBasso. Do this thing up right and get a nice bump in customers. Fix that frickin' EQ. Jeeez. Get some nice quality presets and I'll listen to it, instead of running it 24 hours, breaking-in headphones. And smooth out those case edges on the next batches. Really, you can cut somebody with that thing.

 

Through many IEM's and a few amps, my current kit is the DX50 - 627 - V6-S combo, though I'm substituting the DX50 with the J3 (on the BBE Headphone setting) currently. Easy now. Calm. My ears tell me they like this better right now. Again, opinion.

 

That's my story and I'm stickin' to it.

 

By the way, another deal I can recommend is the BH2. And if your IEM budget is $60, Amazon-US has the Monster Gratitude on some sort of close-out. Nobody bought the damn things, but after a break-in they sound more than the cost. I know, Monster. We're calm.

post #6446 of 18427
Thread Starter 
Quote:
Originally Posted by Idsynchrono_24 View Post

So my DX50 just decided to die on me for seemingly no reason at all after 3 days of operation. Getting the orange exclamation mark when I power on? Can anyone help me out with this?

I got that too, it was a discharge battery, I put it on a charger and came back to life.
post #6447 of 18427
Quote:
Originally Posted by Idsynchrono_24 View Post

So my DX50 just decided to die on me for seemingly no reason at all after 3 days of operation. Getting the orange exclamation mark when I power on? Can anyone help me out with this?
Recharge it wink.gif
post #6448 of 18427
Ah, thank you thank you guys
post #6449 of 18427
Thread Starter 
Guys the dap ain't running on solar energy lol biggrin.gif
post #6450 of 18427
Quote:
Originally Posted by musicheaven View Post

Guys the dap ain't running on solar energy lol biggrin.gif

Maybe the next firmware? Someone email iBasso! where is the solar power! :^)

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016