or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 428

post #6406 of 18427

I'm wondering if there is any plan, or if it's even plausible, to be able to scan external USB sources as well as the internal memory so that it can be browsed the normal way instead of just by directories.

 

64gb microSD card is in the mail, and it won't be nearly enough. It seems like a higher capacity microSD card isn't coming any time soon (it's supported from a file system standpoint but not from a mass producible  manufacturing process right now). It's going to kill me.

post #6407 of 18427
Quote:
Originally Posted by Jpfe8851 View Post

Ask them for a refund if they say it is not faulty, then a replacement will sound the same too most likely. If the sound is not to your liking and they have the DAP back it would seem the right thing to ask and do.

If they insist on returning it, sell it and cut your losses.

Must say, I cannot describe my DX50 in those terms myself and I have lost a little of my treble hearing with age.

My 2 cents.

I have asked for a refund...here's to hoping all goes well.
post #6408 of 18427
Quote:
Originally Posted by Frank I View Post
 

This was for a review so not sure what they want to do. In any event I have enough information to write the review over the last  few weeks. This was a first batch player .We are doing  a dual review on audio360.org and our other reviewer is on his second unit as the first one he had failed too. We are trying to get it done shortly.

 

That does not inspire confidence.

post #6409 of 18427

No, it does not.

 

Yet, if this is the only failure in the thousands out there this is a very low failure rate.

post #6410 of 18427

John,

 

Regarding The Wall album and gapless issues I am experiencing - my copy was ripped with Windows Media Player to MP3 format.  Plays absolutely perfectly on my Cowon J3 (along with the Queensryche).  Not sure why it would not play continuously on my DX50 - maybe I try ripping to FLAC or WAV and see if it is any different.

 

Appreciate your inputs.

 

Cheers,

Tim

post #6411 of 18427

Hey everybody I need some help here!  I was installing 1.2.3 beta.  Somehow, it froze and its not recovering...

I took out the battery, and still froze.

 

Did anyone had same problem or similar?

 

Thanks

post #6412 of 18427
How is the sound different between below situation:
Which sounds better?

Situation 1:
To bypass internal amp in DX50 and line out to RSA Intruder

Situation 2:
DX50 only acts as a transport and LO and Coaxial Out to RSA Intruder.
post #6413 of 18427

When I went to 1.2.3b it took several restarts/update system attempts before it finally worked.  Suggest trying a few times if you have not already.  If all else fails go back to 1.2.2?

 

Good Luck,

Tim

post #6414 of 18427

Hi happy DX50 owners,

 

I'm new here, and I went over the whole thread (four days!). I'd like to share my two cents with you guys.

 

After playing with this little thing for several weeks, I have a feeling that the internal amp of the DX50 may not be that bad. It might be its DAC volume control that lowers down the resolution and dynamic range of the headphone out. I started to think about this when I pluged a pair of cheap Ety kids' (300 Ohms) into it, cranked the volume all the way up at low gain and found it sounded really good with a lot of details and good dynamics.

 

I normally listen at volume about 200 with my diy ciem. I tried to amp the LO with O2 at the same volume and did an AB test (kind of) by quickly swithing the IEM between DX50's HO and O2's and I could hear little difference (the bass could be a little better on O2 if I have to say). However, if I set volume at 255 while lower down O2's, it sounded much better to my ears (I can't AB them in this case though, so it could be just my imagination...).

 

I then used this DAP as an amp: just start it up without playing anything, and use its line out as a line in, it does work as an AMP only (CAUTION: try this at your own risk!!! It may damage the DAP and/or your ears). In this setup I AB'ed DX50 and O2; I could feel some difference but failed to tell them when blind.

 

Could anyone running it with an good amp please help me confirm this? Just set DX's volume at 200 or even lower and turn up the amp's; see if you loose any SQ. I suspect that a lower volume  sacrifices dynamic range too much. If this is the case, I wonder if we can further lower the lowest gain so that the DAC can work at its full power. Two surface mount resistors may need to be changed and I don't think I can do this by myself...

 

The DX50 sounds good enough to me for portable use. At my desk, I also use it with a pair of Hafler TRM 8.1 monitors sometimes and the DX's LO volume control really helps!

 

BTW: I prefer the sound of 1.2.2 over 1.2.3beta. Simply better clarity.

post #6415 of 18427

Does this dx50 has physical reset button?

post #6416 of 18427
Quote:
Originally Posted by Jpfe8851 View Post
 
Quote:
Originally Posted by FatmanSize48 View Post

Does anyone remember my various complaints about the DX50 I received? As in, the bloated bass, tinny treble, and hollow mids? Well, iBasso just received my DX50 and said that there is nothing wrong with my unit. A good deal of my friends tried out the DX50 and compared it to several other amps--they all agreed that there was something very wrong with my it...

What to do...
Ask them for a refund if they say it is not faulty, then a replacement will sound the same too most likely. If the sound is not to your liking and they have the DAP back it would seem the right thing to ask and do.

If they insist on returning it, sell it and cut your losses.

Must say, I cannot describe my DX50 in those terms myself and I have lost a little of my treble hearing with age.

My 2 cents.

 

 

Quote:
Originally Posted by tak- View Post
 
I don't think iBasso is obliged to refund if the buyer doesn't like the sound. Wouldn't be surprised if they do though, given how accommodating they have been.

 

Guys, I think these comments are unfair. Let me explain why.  I had a DX100. I liked the sound. In all honesty, as DACs, the difference in sound between even an iPhone and most DAPs is relatively small. The headphone amps, well, YMMV depending on the headphones or IEMs used, but assuming a low output impedance and enough drive, they all are fairly decent.  I had a couple of situations where I was using the DX100 as a digital source and the resulting output, through another DAC was horrid-sounding. When I tried it with a known good DAC, I came to the conclusion that somehow the unit was distorting the digital output, as a reboot fixed the problem. As well, I felt the sound quality using ALAC files was worse than when using FLAC, which I hadn't expected. Knowing as we do that the software for these DAPs is quite poor in many ways, we can't really be sure what FatmanSize48 isn't hearing is a problem with the software.

 

So, honestly, I think what amounts to putting someone down because their bad experience, which could VERY well be the result of the poor software, is unreasonable.

post #6417 of 18427
Quote:
Originally Posted by gmahler2u View Post
 

Does this dx50 has physical reset button?

 

none that i know of...you just have to press and hold the power button unit the unit shuts down (if it freezes)

post #6418 of 18427
Quote:
Originally Posted by karloil View Post
 

 

none that i know of...you just have to press and hold the power button unit the unit shuts down (if it freezes)

Yes, I've been doing that for last 2 hours, It won't pass the IBASSo sign.  It wont scan the media. nothing, All you see is Ibasso sign.

post #6419 of 18427
Quote:
Originally Posted by gmahler2u View Post
 

Yes, I've been doing that for last 2 hours, It won't pass the IBASSo sign.  It wont scan the media. nothing, All you see is Ibasso sign.

 

have you tried pulling the battery out?

post #6420 of 18427
Quote:
Originally Posted by karloil View Post

have you tried pulling the battery out?
i think you should wipe the data by switching off the dx50. press volume up button and power button together for a few second and you see a androidish recovery screen. choose wipe data and i think you)'ll be fine after that
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016