or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 144

post #2146 of 18426

volume drop on eq is there to prevent clipping and decrease of sound quality...

post #2147 of 18426
Quote:
Originally Posted by madmax2011 View Post
 

Hello
 
I picked the player and have been loading tracks/albums. However, although
all the tracks are in the directory some will not play. I have tried to rename
them taking out the . , - ( ) etc and some still will not play. Can you assist.
Will the latest download 1.1.6 solve this. Please instruct me how to do this.
 
In addition, I tried to move albums from my media player without success.
I assume that they have to be folder.
 
I does sound great but this is frustrating.

 

Download the latest update and read the included readme.txt - It tells you how to perform the upgrad and that yes, that bug is fixed.


Edited by Sorensiim - 9/19/13 at 1:32pm
post #2148 of 18426
Thread Starter 
Quote:
Originally Posted by tak- View Post


Hey. Jokes aside, I have posted a working method to flash the firmware with the file loaded on a microSD card. More convenient I think, and the flashing process went smoothly. Updated in under 2 minutes. Can check it out at http://www.head-fi.org/t/680472/dx50-bug-list-wish-list-fix/420_30#post_9816949.

 

Well you learn a new thing once in a while, like they say if it works then why not!

:beerchug:

post #2149 of 18426
Just in case it wasn't obvious, I really was kidding about the 255 high gain nonsense. Cheers (:
post #2150 of 18426

Well, enjoying the DX50 mostly .. but one problem is still troubling me.. have loaded several albums to the internal storage and I can see them in album and directory view but they will not play when I select them from either view??  I see that most people talk about the scanning process and I am wondering if there is a way to force the scanning and see if that is the solution??

 

Help a newbie if you can

 

Thanks

Don J

 

Firmware is at 1.16.. loaded that immediately after unboxing so all music was loaded after the update was finished

post #2151 of 18426
I must have crap ears, I can hardly tell the difference with all my IEMs between using an amp and not using an amp with the DX50. It's a difference for headphones though
post #2152 of 18426
Quote:
Originally Posted by spurxiii View Post

I must have crap ears, I can hardly tell the difference with all my IEMs between using an amp and not using an amp with the DX50. It's a difference for headphones though

Because DX50 has a very good internal amp inside:) So no need extra amp for a lot of phones.

post #2153 of 18426
Quote:
Originally Posted by donaldj68 View Post
 

Well, enjoying the DX50 mostly .. but one problem is still troubling me.. have loaded several albums to the internal storage and I can see them in album and directory view but they will not play when I select them from either view??  I see that most people talk about the scanning process and I am wondering if there is a way to force the scanning and see if that is the solution??

 

Help a newbie if you can

 

Thanks

Don J

 

Firmware is at 1.16.. loaded that immediately after unboxing so all music was loaded after the update was finished

If you're not using an external card you don't need to scan. They should be available when you browse files and choose internal storage.

post #2154 of 18426
Quote:
Originally Posted by tak- View Post

Just in case it wasn't obvious, I really was kidding about the 255 high gain nonsense. Cheers (:

The problem is a newbie could come on here and read that post and believe that's what you're supposed to do so that's not cool.

post #2155 of 18426
Quote:
Originally Posted by Vidmaven View Post

The problem is a newbie could come on here and read that post and believe that's what you're supposed to do so that's not cool.

It's like telling people to drink 99 degrees celsius water. Definitely not cool.
post #2156 of 18426

Report:

 

iBasso DX50 1.1.6 Firmware.

 

I hear hiss with my Fitear 111, very low, like gain-sound from an amp, but very low, my jdslab cmoy even sound more worse than this, so I think its normal, BUT it will be better if the hiss gone and the player dead silent, LOL.

 

I love the screen, when I push the button the screen don't turn on, like other android device, it only on when you push the power button. I think its great, don't drain the battery while you change the track.

 

the player don't stop playing when I pull the plug.

 

the player had "delete" option.

 

and hey, its play *aiff files too, but don't show the album picture.

 

its sound farrrrrrrrrrrrrrrrrrrrrrrr better than my ipod classic 6g.


Edited by audiofreakie - 9/19/13 at 4:48pm
post #2157 of 18426
Quote:
Originally Posted by Berkovajazz View Post

Because DX50 has a very good internal amp inside:) So no need extra amp for a lot of phones.
Why do I see lots of pictures of people with external amps attached to the dx50 running IEMs. I see no point at all
post #2158 of 18426
Quote:
Originally Posted by audiofreakie View Post

Report:

iBasso DX50 1.1.6 Firmware.

I hear hiss with my Fitear 111, very low, like gain-sound from an amp, but very low, my jdslab cmoy even sound more worse than this, so I think its normal, BUT it will be better if the hiss gone and the player dead silent, LOL.

I love the screen, when I push the button the screen don't turn on, like other android device, it only on when you push the power button. I think its great, don't drain the battery while you change the track.

the player don't stop playing when I pull the plug.

the player don't have "delete" option.

and hey, its play *aiff files too, but don't show the album picture.

its sound farrrrrrrrrrrrrrrrrrrrrrrr better than my ipod classic 6g.

There is a "delete" shown in the context menu when you press on the file artwork placeholder.
post #2159 of 18426
Quote:
Originally Posted by spurxiii View Post


Why do I see lots of pictures of people with external amps attached to the dx50 running IEMs. I see no point at all

 

To give the desired flavor. Maybe the amps they are using are better than the DX50s internal amp sections as well which in turn improves the sound quality. If their IEMs are resolving enough to scale up even higher than the provided amp section. I see no reason not to. But it does defeat the purpose of the unit being portable and that I can agree on.

post #2160 of 18426

.


Edited by austonia - 1/16/15 at 3:12pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016