or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 143

post #2131 of 18426
Quote:
Originally Posted by kkcc View Post

Coz we AK1x0 users had bigger things to complain about.... biggrin.gif   j/k

But yea given it's price you should just buy one and listen for yourself... a guy at my local jaben joked he could have bought the dx50 just for the shipping cost he paid to get the ak100 and then the rwak then the S mods.....

ah yes, we Ak 1x0 owners could expect that people without Ak would feel jealous ... for what is worth AK can also mean Avtomat Kalashnikova known as just Kalashnikov in the west wink.gif
post #2132 of 18426
Quote:
Originally Posted by treal512 View Post


FWIW, I did ask iBasso to make this a selectable option rather than a default mode. Enable or disable the screen coming to life with any key input.
post #2133 of 18426
I think if suggestions and proposals of users for iBasso will be incoming in such quantities then iBasso dudes will spend next half year only reading them biggrin.gif
good news is iBasso is willing to listen to users, which is a big plus compared to Cowon or Colorfly.
post #2134 of 18426
The dx50 to me sounds better than the modified ak100.
post #2135 of 18426
Quote:
Originally Posted by jamato8 View Post

The dx50 to me sounds better than the modified ak100.

 

If they put any of the AK100, AK120, RWA100-S, RWA120-S, etc in a different casing, give a different name and raise the price, I bet each of those will sound better than itself to some audiophiles. :wink_face:  jkd

post #2136 of 18426
Quote:
Originally Posted by mingus View Post

I haven't used mine long enough to experience the volume bug. is there a way to limit the volume?

afraid to use it at this point, i value my ears.

A volume limit would be very useful. Let's hope it gets implemented.
post #2137 of 18426
The hiss detected on my 1964 triples is directly correlated to both gain and volume. The higher the volume or gain the more I can hear it. Not detectable when music is playing.

What is with the gapless selections? 10 seconds is the gapless setting? I have also had some problems with all of the albums appearing in album view. I have to go to directory view and select and than it loads onto album view.🙉
post #2138 of 18426

I don't have the hissing problem so far.

I did hear something when the music stops, but later found that the "hissing" is there WITHOUT headphone plugged lol

Maybe I should go visit a doctor :p

 

I do hope to have a fix on the volume-crazy problem.

Lucky for me that the volume went down not up in the total 4 bug occurance so far....

 

Oh It would be very good to read a plain cover file in the folder as album art.

Cowon support that so no need to write album art in each file ;)

post #2139 of 18426
Quote:
Originally Posted by mikescchen View Post
 

I don't have the hissing problem so far.

I did hear something when the music stops, but later found that the "hissing" is there WITHOUT headphone plugged lol

Maybe I should go visit a doctor :p

 

I do hope to have a fix on the volume-crazy problem.

Lucky for me that the volume went down not up in the total 4 bug occurance so far....

 

Oh It would be very good to read a plain cover file in the folder as album art.

Cowon support that so no need to write album art in each file ;)

 

Its weird because when I first turn on the unit, it doesn't hiss until midway through the SD scan, just before the home screen appears. Almost, like the amp turns on at that moment.

 

Also, whats with the annoying volume decrease when EQ is on? (All EQ settings) Is that normal?

post #2140 of 18426
Quote:
Originally Posted by Gintaras View Post
 

 

 

arrrrh, you already complaining, is this product not living up to your expectations? we, happy Iriver AK100 users, do not have such problems :tongue:

 

LOL Gint...you sir...are EFF'd  up. LOL

post #2141 of 18426

I should mention. Even with some issues, I really loved the DX50. It has some awesome features and that touchscreen is really nice. :k701smile:

post #2142 of 18426

I only get hissing out of my reshelled UM3X's. The other cans and IEM's don't hiss at all.

post #2143 of 18426
Quote:
Originally Posted by OneL0ve View Post

Its weird because when I first turn on the unit, it doesn't hiss until midway through the SD scan, just before the home screen appears. Almost, like the amp turns on at that moment.

Also, whats with the annoying volume decrease when EQ is on? (All EQ settings) Is that normal?

Volume decreases so your +db adjustments won't cause clipping. It's very normal and common and should be mandatory IMO.
post #2144 of 18426
Quote:
Originally Posted by icefalkon View Post

LOL Gint...you sir...are EFF'd  up. LOL

please please please, do not interrupt me as i am trying to talk my humble self out of buying dx50, so do not spoil it wink.gif
post #2145 of 18426

I did notice a volume drop when EQ is on, so I think it's normal.

I don't plan to use it anyway...

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016