or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 139

post #2071 of 18427
Sorry for the monster post, but DAMN you guys have been busy while I was catching Z's!
Quote:
Originally Posted by Vidmaven View Post
 

It's in the house! 48 hours from China to Illinois, not bad. Didn't take the screen protector off yet. Didn't update the firmware yet (downloading it now). Just slapped a 64GB card in, scanned for music and I am now listening to some Joe Walsh on my Denon D2000s. And a couple of shots with the Headstage Arrow for Sorensiim as promised.

 

 

Much appreciated! Looks like it's two patches of DualLock away from a compact kickass rig! I think it would still be smaller than the DX100...

 

Quote:
Originally Posted by uelover View Post

I am running on Mac so am performing the normal drag and drop. Filling up the 8GB (which is effectively only 6GB) took about 10mins. It is always much much faster to fill up an iDevice than other USB storage devices.

 

Luckily I could fill up my 64GB Micro SD card using the SD card reader inbuilt on the Mac. That beefs up the speed of transfer for SD card tremendously =)

There's a guy trying to do a review of the DX50 for a magazine, but he can't get the files loaded on his Mac. If you have 5 minutes, PLEASE shoot me a PM so we can help a brother out!

 

Quote:
Originally Posted by Girls Generation View Post
 

I don't know if this is backed by evidence but I can definitely detect hiss on any set up while music is playing. Hiss from the recording and hiss from the hardware also sounds different. But then again, the only time I'm bothered by hardware hiss is when I'm listening to well-recorded songs which should technically be buttery smooth with a complete blackground. If there's any kind of hiss detected, it makes the song, and the female vocal, grainier and ruins the whole picture.

I absolutely, positively just can't tolerate hardware hiss. Some recordings have a bit of hiss and I can live with that. As long as it's not as bad as Robert Plant & Allison Krauss trying to make their album sound like vintage vinyl. It was so bad I got my money back from HDTracks!

 

Quote:
Originally Posted by tak- View Post


Yup. First you need to wipe everything from your SD card, load the firmware file onto your SD card via a USB3.0 cable connected via the DX50. Unplug the battery once the update is finished to finalise your settings. It should run fine after that.

Make sure you set your volume to 255 on high gain with a set of earphones plugged in and have a song playing before initiating the firmware update, otherwise your unit might be bricked or have no sound when you restart by unplugging the battery.

Please don't try to trick people into damaging their headphones or ears. Welcome to my list of people to warn others about. 

 

Quote:
Originally Posted by mingus View Post
 

can someone link me top the original ibasso 1.16 file, I downloaded it from one of the links here and got "invalid image" i just put it on the root of the player. thx

Where did you grab the invalid file from? If the one I'm hosting is getting corrupted, I'd like to know it so I can take care of it. :beerchug:

 

Quote:
Originally Posted by swimmintunes View Post
 

 

"Holy cow you must be bored" great album!  Unfortunately it is so compressed that there is very little detail or separation despite the sound-stage being so amazingly deep! 

:tongue_smile:

 

Has anyone found a workaround to files not playing in album order?

 

Yep, I posted a workaround earlier: http://www.head-fi.org/t/679473/ibasso-dx50-appreciation-thread-new-2-firmware-update-v1-1-6/1920#post_9814587 - As a bonus it will clean up your tags and file names. While you're at it, adding DX50 compatible artwork is a doozie with Mp3Tag.

 
Quote:
Originally Posted by DigitalFreak View Post
 

With me mine won't mound no matter what cable I use. It's driving me batty

I had the same issue, but I knew how to fix it (assuming you're using Windows):

1) Make sure the DX50 is turned on before plugging it in

2) After plugging it in, right click on "My Computer" -> Manage

3) Go to "Disk Management"

4) Find the DX50 storage/SD Card in the Disk Management console. 

5) Right click the DX50 storage/SD Card and select "Change drive letter or path"

6) Assign new drive letters, like X: and Y:

7) Enjoy adding files to your DX50

8) If steps 1-7 didn't help, PM me. 

 

Quote:
Originally Posted by CobraMan View Post
 

Received my 3rd batch DX50 today - FW at 1.1.5.

 

Quick question:  Is the gain adjustment supposed to increase the output level for a given set of earphones/headphones (doesn't appear to do anything with my Vsonic GR99)?  Or maybe I misunderstand what the gain switch is supposed to do.

 

Observations:  Max volume does not appear anywhere near what my J3 puts out.  Puzzled considering the specs of each.  Really like the EQ custom setting and sound quality is impressive so far - only listened a short while though.

 

Any help or insight would be appreciated.

 

Cheers,

Tim

That doesn't sound good. Mine is LOUD with 350 ohm headphones at 210 volume on high gain, definitely blowing away a J3 without breaking a sweat. You might want to get in touch with Ibasso...

 

Quote:
Originally Posted by Girls Generation View Post

Ugh my ears have been spoiled by the dx50... Can't stand my iPhone headphone out...

An iDevice-toting coworker snatched my DX50 yesterday - I almost had to fight him to get it back two hours later. 

post #2072 of 18427

Hiss report: 

 

Using my Heir 4.Ai, Tzar 350, 8.A and another ciem, I have to dial the volume north of 240, with the silent file playing, to detect the faintest hiss, but only on high gain. On low and medium gain, there is NO hiss at all. When the music is paused, there is complete and utter silence. Nothing, nada, zip! 

 

Just the way I like it.

post #2073 of 18427
Quote:
Originally Posted by BucketInABucket View Post

Really? That makes me wanna buy an amp for it again smily_headphones1.gif my wallet is bleeding!

Dont expect such a big gain from amping. IMO there is a difference, but not night and day and certainly not enough to justify carrying the extra bulk for me. It sounds great unamped and this is driving the mad dogs 3.2. I'm comparing amped with my iBasso PB2 versus unamped
post #2074 of 18427
Anyone else thinks it takes too long to switch on? Can it be adjusted?
post #2075 of 18427

Ladiieeesssss!

 

It's about time I joined the DX50 party:)
Just received it this morning at 9am.

*

 

post #2076 of 18427
Quote:
Originally Posted by Sorensiim View Post
 

Hiss report:

 

Using my Heir 4.Ai, Tzar 350, 8.A and another ciem, I have to dial the volume north of 240, with the silent file playing, to detect the faintest hiss, but only on high gain. On low and medium gain, there is NO hiss at all. When the music is paused, there is complete and utter silence. Nothing, nada, zip!

 

Just the way I like it.

 

strange. I guess this kind of behavior was expected. guys reporting hiss on low gain and almost none at high is kinda weird...

 

I just hope mine will behave just like yours :D

post #2077 of 18427
Hiss report....

1st Batch DX50
Current V1.1.6 FW

JVC FXT 90's - no hiss
TDK IE800 - again, no hiss
post #2078 of 18427

Skybleu, how does it pair with the C5? 

post #2079 of 18427
Quote:
Originally Posted by SkyBleu View Post
 

Ladiieeesssss!

 

It's about time I joined the DX50 party:)
Just received it this morning at 9am.

 

Warning: Spoiler! (Click to show)

*

 

 


Whoever helped proxy that for you, must be very kind. ;)

post #2080 of 18427

Am I the only one who would like the screen to come on when you push the buttons?

post #2081 of 18427
Quote:
Originally Posted by Sorensiim View Post

Am I the only one who would like the screen to come on when you push the buttons?
It would be a pain if it turned on every every time you pressed a button.
post #2082 of 18427
Quote:
Originally Posted by Sorensiim View Post
 

Am I the only one who would like the screen to come on when you push the buttons?

I thought my unit was a defect when it wouldn't turn on, haha. I kinda like it this way. Saves some battery life.

post #2083 of 18427
Quote:
Originally Posted by DeepGroove View Post

The EMS tracker says my package has been in Guangzhou for 3 days... WTH. Anyone else in the same situation?

It is Chinese Moon Festival in these days, so it may be delay due to public holiday. Good luck!

Sent from my GT-I9505 using Tapatalk 4
post #2084 of 18427

What I would like to see however is lower selection for the screen time out, 30 seconds being the lowest is too long for me. I would prefer a 15 - 10 second option. Maybe down the road somewhere, after a few other things are sorted. 

post #2085 of 18427
Quote:
Originally Posted by H20Fidelity View Post
  Warning: Spoiler! (Click to show)

 


Whoever helped proxy that for you, must be very kind. ;)

Oh yes, very kind you are:) But hey, you already know that. ;)
:beerchug:

Quote:
Originally Posted by lin0003 View Post
 

Skybleu, how does it pair with the C5? 

O to the R to the G to the A, S, M, I, C! :gs1000smile:

 

Like one member mentioned a few pages back, the C5 does somewhat widen the soundstage of the DX50, and brings its mids a touch more forward. Either way, this was a good upgrade and improvement over my C3/C5 combo. Couldn't be any happier:')

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016