or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 130

post #1936 of 18426

you should be able to hear hissing when the music is paused, not when playing, because every music can have some hiss in it. just listen to some old recordings of jazz or whatever it may be for that matter...

 

 

Hope mine doesn't have any hiss on the max listening volume I can endure to listen. if it is so, it's good.

 

also, be sure t update the firmware - the hiss might be caused by some bug in certain cases....

post #1937 of 18426
Quote:
 Yes, it does
 
2013/9/19 Mike Roberts
Thanks.  I wish I understood digital audio better, then I wouldn't have to bother you so much.
 
In the latest firmware does the DX50 do all of these bit depth/bit rate pairs by S/PDIF over coax to an iBasso DB2?
 
16/44.1
16/48
16/96
16/192
24/44.1
24/48
24/96
24/192

So, I got the answer from iBasso to my deal breaker question!

 

One more question for any DX50 owners.  Can you browse by Artist and then by Album, and play that way?

post #1938 of 18426
Quote:
Originally Posted by jon parker View Post

Im super impressed that I can have a 64gb card AND a 32gb gig working through the usb !! o_0

This sounds cool! Really can't wait for mine, hope it arrives soon!
Not sure if I've missed it, but japanese and korean characters have been fixed?
post #1939 of 18426

So far, I'm finding V1.1.5 to be much warmer sounding. It seems to be rid of that ugly digital/cold sound from before, where I was actually trying to increase the bass bands on the EQ. Not sure if they just turned down the treble or bumped the bass (or both) Still excellent separation and clarity, I'm not sensing a mid-bass bloat or anything of the sort, just warmer/sweeter edges on the notes (particularly electric guitars).

 

Using my exact same set-up - lineout into Magni, listening with Mad Dogs (shure pads).

 

I seem to be set for the moment, with the 'play all' feature in action.

 

Edit: No hissing issues to report for mine.


Edited by GoldfishX - 9/18/13 at 9:42am
post #1940 of 18426
Quote:
Originally Posted by caracara08 View Post

are people exchanging their DX50 for hissing? I have hiss on all gain levels which I hate but I wonder if thats just how it is with my 4.Ai.  Anyone have any insight? I'd exchange it in a heartbeat if the new one had a black background.

Do you hear the hiss when there are no music playing? If you do, I get that too. I'm not convinced a change of player will help so I'm looking for other DX50s in my area to try before requesting for an exchange.
post #1941 of 18426

Japanese characters are ok for me. (FW 1.1.5 and 1.1.6)

I don't have any Korean files so don't know about the latter.

 

Pairing it with my Beyerdynamic DT1350 is quite awesome!

The treble's a bit too exciting and a little sibilant on DT1350, but may improve after break-in.

 

Tested with Fitear 334. Separation's good, but overall too dark for my preference.

Pairing with IE80 is surprisingly good!

 

I've also tested it with DT990/250 and HD650.

Better than imagined... great soundstage.

Bass maybe a little loose, but I plan to use DX50 as portable only.

The test is for curiosity's sake ;)

post #1942 of 18426

I hear a slight hiss on all gain levels, this is with the TG334 from fitear.  kkcc I think you use the same earphones, are you hearing a slight hiss also?  It's nothing that can be detected while listening to music just when there's nothing playing.

post #1943 of 18426
Quote:
Originally Posted by sensui123 View Post
 

I hear a slight hiss on all gain levels, this is with the TG334 from fitear.  kkcc I think you use the same earphones, are you hearing a slight hiss also?  It's nothing that can be detected while listening to music just when there's nothing playing.

 

Was listening this afternoon with the FitEar 223 when I was out, and for me the best sounding FitEar (C)IEMs with the DX50 so far.

 

Still have a few more pairs to try out........


Edited by spkrs01 - 9/18/13 at 9:54am
post #1944 of 18426
Quote:
Originally Posted by msromike View Post

So, I got the answer from iBasso to my deal breaker question!

One more question for any DX50 owners.  Can you browse by Artist and then by Album, and play that way?

Yes you can. I am now running the latest firmware v.1.1.6 and everything seems to be working perfectly for me except the Playlist tab is still not shown, but iBasso says that it will be present in the next firmware update.

I believe that with v.1.1.6 most of the bugs and issues have been satisfactorily resolved. Touchscreen response is snappy, I have had no freezes, shutdown time is now about the same as boot-up. My Album files seem to be in order, and random play of all music and albums is working just fine. Bitrate and kbps is now shown correctly in Music Info.

IMO, iBasso has done a superb job of improving the original firmware to a very intuitive and workable "Ready for Prime Time" edition. Of course, everyone will wish for more and more features that meet their individual wants, but keep in mind that iBasso must keep the UI intuitive, simple and reliable. Clearly the wishes of all individual users cannot be addressed.
Edited by HiFlight - 9/18/13 at 10:04am
post #1945 of 18426
The package arrived today. I haven't heard it yet, but it looks wonderful! I'll test it with my miracle and 2stepdance.
post #1946 of 18426
Quote:
Originally Posted by HiFlight View Post


Yes you can. I am now running the latest firmware v.1.1.6 and everything seems to be working perfectly for me except the Playlist tab is still not present, but iBasso says that it will be present in the next firmware.

 

 

WOW, they made ARTIST>ALBUM navigation possible? Take that fiio X3 LOL

post #1947 of 18426

I see some are files now being picked up and a few still missing but about 90 percent are being read now.Maybe the next firmware will resolve everything. 

post #1948 of 18426
Quote:
Originally Posted by Fatalethal View Post
 

Sorry if this post is a similar post to any other members posting but...

What is/are the reason/s to do a factory reset after each update? If it was ONLY to delete the .img file, we could jolly well delete it away manually via a computer, right?

I decided to skip the factory reset on this last update and everything is working just fine.

post #1949 of 18426
Quote:
Originally Posted by HiFlight View Post

Yes you can. I am now running the latest firmware v.1.1.6 and everything seems to be working perfectly for me except the Playlist tab is still not shown, but iBasso says that it will be present in the next firmware update.

I believe that with v.1.1.6 most of the bugs and issues have been satisfactorily resolved. Touchscreen response is snappy, I have had no freezes, shutdown time is now about the same as boot-up. My Album files seem to be in order, and random play of all music and albums is working just fine. Bitrate and kbps is now shown correctly in Music Info.

IMO, iBasso has done a superb job of improving the original firmware to a very intuitive and workable "Ready for Prime Time" edition. Of course, everyone will wish for more and more features that meet their individual wants, but keep in mind that iBasso must keep the UI intuitive, simple and reliable. Clearly the wishes of all individual users cannot be addressed.

Thanks for the report.  Guess it's time to order.

 

By the way, love the PB2 Topkit.

post #1950 of 18426

.


Edited by austonia - 1/16/15 at 3:12pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016