or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 937

post #14041 of 18426

2 BSODs within minutes while now having a total 3 BSODs since installation of Win7 x64 Ultimate years ago.

One shouldn't touch pre-alpha builds being named beta. ;-) And also remember that a DAC is a DAC and a DAP is a DAP so both of them do exist since they are optimized for their specific uses. I wouldn't mind iBasso doing a propper DAC some day, 24/384 or 2x 24/192 but if, then with software like the one for the D7 which runs rock solid.

Firmware 1.5.0 goes in line with the USB-DAC drivers. Since drivers fail, I get warnings about an incompatible USB device each minute if the DX-50 is in USB-Charge-Mode.

 

Until 1.2.8 it was quite ok, but now they simply tried to add feature which lower the quality since if somethings not there I'll vote that a -0.5, but if something simply fails or errors it's a -1.

Lucky one could downgrade as easy as upgrading.

post #14042 of 18426

You shouldn't be voting anything since it's Beta Drivers which are always use at your own risk.. You wouldn't review a half built bridge 'Was excellent until car plunged off the end, would not drive again..' so why would you do it to a DAP that is adding new features that aren't fully baked yet. They gave the Beta drivers to us as a courtesy knowing full well they probably won't work with a lot of peoples setup. 

post #14043 of 18426
Quote:
Originally Posted by Mysteri0 View Post

You shouldn't be voting anything since it's Beta Drivers which are always use at your own risk.. You wouldn't review a half built bridge 'Was excellent until car plunged off the end, would not drive again..' so why would you do it to a DAP that is adding new features that aren't fully baked yet. They gave the Beta drivers to us as a courtesy knowing full well they probably won't work with a lot of peoples setup. 

LOL

So true.

The purpose of beta software/drivers is to get some real world testing to improve the software/drivers. Beta is an acknowledgement that it will be buggy.
Edited by cel4145 - 7/7/14 at 8:24am
post #14044 of 18426

I'm actually happy they didn't include a Mac driver, or all of us would be on here trying to figure out how to make it work, just like all of the Windows people.  

 :deadhorse: 

post #14045 of 18426
Quote:
Originally Posted by juston View Post
 

2 BSODs within minutes while now having a total 3 BSODs since installation of Win7 x64 Ultimate years ago.

One shouldn't touch pre-alpha builds being named beta. ;-) And also remember that a DAC is a DAC and a DAP is a DAP so both of them do exist since they are optimized for their specific uses. I wouldn't mind iBasso doing a propper DAC some day, 24/384 or 2x 24/192 but if, then with software like the one for the D7 which runs rock solid.

Firmware 1.5.0 goes in line with the USB-DAC drivers. Since drivers fail, I get warnings about an incompatible USB device each minute if the DX-50 is in USB-Charge-Mode.

 

Until 1.2.8 it was quite ok, but now they simply tried to add feature which lower the quality since if somethings not there I'll vote that a -0.5, but if something simply fails or errors it's a -1.

Lucky one could downgrade as easy as upgrading.

Possible solution for power management and driver issues: http://www.fixedbyvonnie.com/2013/11/fix-usb-root-hub-power-management-issue-windows-7/#.U4yaXvlS2Ck

 

...and if You have problems somehow with driver signing, then there is DSEO: http://www.ngohq.com/?page=dseo

post #14046 of 18426

I recently updated from 1.28 to 1.50.  It seemed to go well and I enjoy the sound signature.  For my ears and the music I like (mostly folk and Irish Trad) it combines well with the ATH IM70s I've been playing around with lately.  One problem, however, is after a point, the whole unit would basically shut down (after a long-ish period of time, like an hour or so).  Right in the middle of a song.  The battery was fully charged.  It happened a few times, so the last time, I ejected the card and performed a factory reset.  I reinstalled the card and played a while longer with no further problems.  I haven't had the opportunity to do much further testing beyond a half hour or so on the reset.  I did not perform the factory reset as part of the update protocol since it seemed to be working well, up until the shut downs.  

 

I thought this was kinda funny and I hope it doesn't happen again.  If it does, I will probably go back to 1.28, which I was liking pretty well.

post #14047 of 18426

Doing a Factory Reset after an upgrade removes all traces of the previous firmware.  It's highly recommended.  Let us know if your device repeats this behavior.

post #14048 of 18426

In the end, i found out how to install it (i was doing it right all along), but i finally got to use it properly... and i'm quite dissapointed. I know they are beta drivers and whatnot, but still 44/16 and 48/16 from a DAP that actually supports 192/24 was pretty lame. Got to use it a few minutes with Foobar before i got a BSOD on Win7 x64 Home. I'll be expecting better sample rate support (at least something with 24-bits), and at least something signed... ATM, i'll keep using it as a DAP only...

post #14049 of 18426

Not sure if this is normal?  Just got my DX50 today and I've been charging it for awhile and haven't been able to use it yet.  When I plug in the charger, the green orb comes up and indicates its charging.  When DX50 is plugged in, I can hold the power button for a bit and turn it on (and reads my sd card no problem), but...no sound from HO & LO.  Once I unplug the charger, everything goes black and I can't turn the player on no matter what.  Its been plugged in for a couple hours now and acting the same...is there something I'm doing wrong?  Really appreciate all the help.

post #14050 of 18426
You might want to take the back off and try to re-seat the battery, might have shifted during shipping. If that doesn't help probably a defective unit..
post #14051 of 18426
Hi, can you guys recommend me a good portable amp below $200? I would like to pair it with my dx50, this is due to I cannot bear the hiss when i plug in my se535ltd into dx50
post #14052 of 18426
Quote:
Originally Posted by wonglokchai View Post

Hi, can you guys recommend me a good portable amp below $200? I would like to pair it with my dx50, this is due to I cannot bear the hiss when i plug in my se535ltd into dx50

The JDS Labs C5 matches perfectly with the DX50 form factor and pairs well with it too.

post #14053 of 18426
Quote:
Originally Posted by wonglokchai View Post

Hi, can you guys recommend me a good portable amp below $200? I would like to pair it with my dx50, this is due to I cannot bear the hiss when i plug in my se535ltd into dx50



Either JDS C5 or C&C BH.
 
I will give you the BH thread: http://www.head-fi.org/t/644363/c-c-bh-portable-headphone-amp-80-hours-from-a-single-charge-buyer-review

Yes, I did create the thread but below my mini review all the members impressions are logged,take note of those and be sure to read them. C5 is the better amp I have openly admitted that in the BH thread though whether the extra money is worth it is debatable . 

I only came in here actually to say how fond I've become of my DX50 / JDS C421 / SHR940 pairing.

When I want a dose of detail or a quick fix all I need do is crank up some female vocals with this rig.




It would be my full-time rig though some headphones hurt my neck when laying down, SHR940 is one of those headphones.


Edited by H20Fidelity - 7/8/14 at 1:19am
post #14054 of 18426

Thanks for the recommendations. Is there any other option? I would like to hear more recommendations by other dx50 users. :)

post #14055 of 18426
Quote:
Originally Posted by H20Fidelity View Post


I only came in here actually to say how fond I've become of my DX50 / JDS C421 / SHR940 pairing.


 

 

i'm using the same dx50/c421 pairing too! simply awesome :D

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016