or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 928

post #13906 of 18427

MicroSD speed class important maybe? 

post #13907 of 18427
Both MicroSD cards are UHS-1 compliant, and rated at 48 MB/s. Surely that should be sufficient?
post #13908 of 18427

Well, it's the cards or the files.  The DX50 shouldn't be part of the equation, as it apparently plays the files from a stick.  So the files, on a stick, are fine.  That leaves the cards or the way the files got to the cards or the way the files work on the cards.  

post #13909 of 18427

Regarding the "skip" issue. It does not seem to be directly related to the reading of the SD card:

1. The problem occurs even on files I have listened to very repeatedly with no issue with FW versions up to 1.2.8.

2. If I use the digital output and connect it to an external DAC, I notice no problem.

 

My understanding is that changes to the internal DA conversion is leading to the use of exceeding resources for the DX50.

post #13910 of 18427

try format them in exfat, dont remember which sistem files are supported but try some

post #13911 of 18427
Quote:
Originally Posted by olddude View Post
 

I just tried the Sound Explosion v2 based on 1.5.0 and it just seemed a bit too bright in the mids.  I liked it, but I think it would be a bit tiring using my Dunu1000s.  I reverted back to stock 1.5.0.  

Where can I get the Sound Explosion v2? On the first page of this thread is only the one based on DX90. Could you just post the link or link the post? ;)

 

thanks

post #13912 of 18427

Go back7-15 pages until you find the links.

post #13913 of 18427
Quote:
Originally Posted by abissoxd50 View Post
 

Am I the only one to face this issue: DX50 + standard 1.5.0 would occasionally skip a fraction of second in the middle of a track being played resulting in a very bad listening experience.

 

I have never had such an issue with 1.2.8 or previous version. Nobody met with this issue?

 

As far as I am concerned, this means... back to 1.2.8.

 

I was having this issue shortly after upgrading to 1.5.0, but actually it has never happened again since the day I performed the upgrade last week.  I was worried it would be a continuous problem but for me it completely went away.  Can't say I know why that is. 

post #13914 of 18427
Quote:
Originally Posted by olddude View Post
 

Go back7-15 pages until you find the links.

Got it, thanks :)

post #13915 of 18427

Hello I have been a very satisfied dx50 user, also thanks to this thread, but now I have a problem, after the latest firmware update the dx50 gets stuck on the golden welcome screen, holding the power button shuts it down after 10 seconds but it immideatly reboots and gets stuck on the start screen again. holding + and power after I removed and reinserted the battery did give me the recovery screen but factory reset did not help, reinstalling from recovery does not work, it says it can't find the update image or it is corrupt. Optimistic as I am at this point I was still confident that I did not have aproblem and I would be able to plug it in to the computer and put the update image back on again but i does not get recognized by the pc :(, I even tried rkbatchtool but it does not get recognized, even though I do hear the sound of an usb device being connected/disconnected.

 

anybody that has any idea on what to try next?
thanks in advance!

post #13916 of 18427

Btw, to anyone who couldn't install the driver...try extracting it first from the .rar and then right click > run as administrator, this worked for me and there was no signature pop up, will test if the driver functions tomorrow when i receive my DX50.

post #13917 of 18427
Quote:
Originally Posted by erceve View Post

Hello I have been a very satisfied dx50 user, also thanks to this thread, but now I have a problem, after the latest firmware update the dx50 gets stuck on the golden welcome screen, holding the power button shuts it down after 10 seconds but it immideatly reboots and gets stuck on the start screen again. holding + and power after I removed and reinserted the battery did give me the recovery screen but factory reset did not help, reinstalling from recovery does not work, it says it can't find the update image or it is corrupt. Optimistic as I am at this point I was still confident that I did not have aproblem and I would be able to plug it in to the computer and put the update image back on again but i does not get recognized by the pc frown.gif, I even tried rkbatchtool but it does not get recognized, even though I do hear the sound of an usb device being connected/disconnected.

anybody that has any idea on what to try next?

thanks in advance!
Where you or have you reinstalled 1.2.8 or any other thing? Have you ever updated a fw before? Did you get rid of the last fw when loading the new one? It sounds like you are just missing a step.I or someone here will be able to help you get through this, we just need a little more info.
post #13918 of 18427
Thread Starter 

I have to say DOC2008 V1.1 MEGA EXPLOSION beats iBasso 1.5.0, hard to believe but true, now If I could only get rid of DOC's popup orange window. :ksc75smile: 

 

BTW I have just added DOC's DX50 MEGA Update on the version download page, just let me know if I messed up. :beerchug:


Edited by musicheaven - 6/30/14 at 4:49pm
post #13919 of 18427

 

 

what do I do now? :D the yellow triangle thingy is there because of - you guessed it - no signature... it tells me there is latest version installed when I try to update it and all...

post #13920 of 18427
Quote:
Originally Posted by musicheaven View Post

I have to say DOC2008 V1.1 MEGA EXPLOSION beats iBasso 1.5.0, hard to believe but true, now If I could only get rid of DOC's popup orange window. ksc75smile.gif  

BTW I have just added DOC's DX50 MEGA Update on the version download page, just let me know if I messed up. beerchug.gif
Thumbs up for the mega explosion v1.1! The sound is enhanced with clarity, details, separation and with smooth vocals. Slightly upfront vocals. Bass level is also much tighter and deeper with both greater quality and quantity than 1.5. Slightly brighter sounding than 1.5 though. Really worth a try for those who haven't!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016