or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 915

post #13711 of 18427
Quote:
Originally Posted by olddude View Post
 

Yeah, the inmates took over.  :tongue_smile:

 

BTW, I thought it'd be interesting to select the USB/DAC in Settings and then plug my Mac into the DX50 and see what happens.  No drivers available through iBasso, of course, but you never can tell what a Mac can do on its own.  Well, the player lit up w/DAC on the splash screen but nothing else happened.  Oh well, worth a try.  :etysmile:

 

Send iBasso a mail. A lot of people are asking for USB DAC support for Mac as well

post #13712 of 18427

BTW, for those who are interested, Gapless seems to work fine on In Order mode, but I get gaps when in Shuffle mode.  Might just be a matter of it having to find the next song, which takes some small amount of time.  

post #13713 of 18427

I installed the USB DAC drivers but the computer doesn't recognize the DX50 as a USB DAC. What do?

 

EDIT: I should add that I have 1.5.0 installed on the DX50.


Edited by BucketInABucket - 6/24/14 at 6:48pm
post #13714 of 18427
Thread Starter 
Quote:
Originally Posted by BucketInABucket View Post

I installed the USB DAC drivers but the computer doesn't recognize the DX50 as a USB DAC. What do?

EDIT: I should add that I have 1.5.0 installed on the DX50.

I had to install it four times. Bring the device manager and see if the Mango USB is properly installed. Mine was in a broken state so I kept uninstalling it from there and running the install again, after a few attempts it showed up properly and was finally shown from the sound control panel. Keep your player in dac mode connected to the USB port at all times when loading the software. I assume you initially followed the instructions to install an unsigned driver in windows, correct?

Oh are your running windows 32 or 64-bit?
Edited by musicheaven - 6/24/14 at 7:24pm
post #13715 of 18427

I noticed that the color scheme of the screen now has slightly less contrast with the new firmware.. I adjusted the brightness to the same levels as with the previous firmware but it still looks slightly off to me.. is it just me..? :confused_face:

post #13716 of 18427

Hi, is there a way to have the stock 1.5.0 with Rockbox? If not, DOC2008's 1.5.0 based ones are also ok. It seems these don't come with CWM recovery.

 

How does the "ROCKBOX for FIRMWARES BASED on v. 1.5.0" work?

 

 

 

 

Quote:

 

 

DX50 SOUND EXPLOSION V2 BY DOC2008



-based firmware DX50 v. 1.5.0
-Fixed: Russians tags


DOWNLOAD



DX50 SOUND EXPLOSION DARK BASS EDITION V2 BY DOC2008



-based firmware DX50 v. 1.5.0
-Fixed: Russians tags


DOWNLOAD



ROCKBOX for FIRMWARES BASED on v. 1.5.0


-installation via CWM recovery (a reference to the statement in the header)


DOWNLOAD

 

post #13717 of 18427
AT LAST! GAPLESS WORKS!!!


However, The random stuttering (like an unsynchronized DAC) is annoying.
post #13718 of 18427

I've spent 2 hours listening today with no random stuttering.  Did you do a factory reset after the update?  Remove the update from your device?  

post #13719 of 18427
Quote:
Originally Posted by musicheaven View Post
 
Quote:
Originally Posted by BucketInABucket View Post

I installed the USB DAC drivers but the computer doesn't recognize the DX50 as a USB DAC. What do?

EDIT: I should add that I have 1.5.0 installed on the DX50.

I had to install it four times. Bring the device manager and see if the Mango USB is properly installed. Mine was in a broken state so I kept uninstalling it from there and running the install again, after a few attempts it showed up properly and was finally shown from the sound control panel. Keep your player in dac mode connected to the USB port at all times when loading the software. I assume you initially followed the instructions to install an unsigned driver in windows, correct?

Oh are your running windows 32 or 64-bit?

I've been trying to get it to work, but haven't had any luck. Can you explain how you did it step by step so that even a caveman could do it? I'm running Windows 7 32-bit with the service pack(s). And I did type those two lines into the command prompt and it even shows test mode on the bottom right of my screen on the desktop.

post #13720 of 18427
Quote:
Originally Posted by CJG888 View Post

AT LAST! GAPLESS WORKS!!!


However, The random stuttering (like an unsynchronized DAC) is annoying.

 

 

I thought it did too on my end, but no go.  Three tracks were perfect on ASOT 2014 then back to the skip.  Looked at what it was doing carefully and it seems on some tracks it's eating the last two seconds. Tried cues w/ flac and split tracks.  No go

 

Are you on a card CJG or internal?


Edited by HeatFan12 - 6/24/14 at 8:45pm
post #13721 of 18427
Quote:
Originally Posted by musicheaven View Post


I had to install it four times. Bring the device manager and see if the Mango USB is properly installed. Mine was in a broken state so I kept uninstalling it from there and running the install again, after a few attempts it showed up properly and was finally shown from the sound control panel. Keep your player in dac mode connected to the USB port at all times when loading the software. I assume you initially followed the instructions to install an unsigned driver in windows, correct?

Oh are your running windows 32 or 64-bit?

I'm using 64-bit windows 7 so there's no need for the unsigned driver installation guide I would assume. How do you even uninstall them though?

post #13722 of 18427

I am hearing a very obvious change in SQ with this new fw : much better instrument separation (24bit  jazz and some electronic CD flac rips) and much better balanced bass frequencies (Shure se846). 

 

I`m coming from that 3rd-party fw explosion thing. 

post #13723 of 18427

I love the space in the sound. Live recordings come across extremely well, IMO. Listen to Dreamin' Man Live, Neil Young. 

post #13724 of 18427
Quote:
Originally Posted by HeatFan12 View Post
 

 

 

I thought it did too on my end, but no go.  Three tracks were perfect on ASOT 2014 then back to the skip.  Looked at what it was doing carefully and it seems on some tracks it's eating the last two seconds. Tried cues w/ flac and split tracks.  No go

 

Are you on a card CJG or internal?

Hey guys, did you do the upgrade by the book, ie do a factory reset after the update and remove the update from your device?

I believe this is required before the developer/manufacturer will take any error reports into account, be it an iBasso DX50 FW or any other new HW or SW iteration to a device.

post #13725 of 18427

I manged to get the dac driver working.

 

Here is what i did. I hope it helps those who have trouble installing it.

I'm running windows 8.1 64bit, but I'm sure this procedure should work with other window system.

 

Jump to 7 if your not running windows 8.1

For Windows 8.1 user you have disable driver signature enforcement first.

1. Hold onto shift on your keyboard, then press restart.

2. Troubleshoot

3. Advanced Option

4. Startup Setting

5. Press 7

6. You have disabled your driver signature enforcement.

7. Right click my computer then select property/go to control panel

8. Open device manager.

9. Install 1.5.0 on your dx50

10. In usb setting switch select dac mode.

11. Connect your dx50 to your pc

12. In the device manger you should see an unknown device called 2kxxx(forgot the exact name, but you should know it is the dx50)

13. right click that -> select update driver

14. browse driver from your pc

15. Extract the dx50/90 beta 2 driver downloaded from the ibasso website.

16. If your running 64bit choose the 64x folder/ 32bit choose the 86x folder. (make sure sub-directory is included)

17. Once the driver is installed, you should see mango device.

18. Right click the sound icon on your taskbar

19. click on playback devices

20. Select ibasso mango hifi audio device as default device

21. Enjoy


Edited by Ishera - 6/24/14 at 10:28pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016