or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 914

post #13696 of 18427
Quote:
Originally Posted by H20Fidelity View Post


I'm not going to bother, 1.2.8 is where I'm staying, all this talk of the dark side doesn't exactly turn me on. We need to be heading towards the light. Towards the light iBasso!

Try it.  I'm liking it.  We use basically the same amp, and I'm not hearing "darker."  I'm getting more punch in the low end using the Dunus.  Fills up the sound, but it's certainly not overpowering it or making it muddy.  Treble is still fine (I tried Taxman by the Beatles, my go-to for "almost too bright," and it is still right on the edge.  Stuff by Buffalo Springfield, which is a bit thin, gained a slight bit of "deeper," while stuff by George Michael, which is already plenty deep, gained more punch in the area of kick drum.  Vocals are fine, mids are fine.  I think 7S Cameron got it right, above, when he said the bass is improved.  I tried one of the earlier custom firmwares, which I found both too bass-y and too shrill.  This is neither.  If you were willing to try the "sound explosion," even though you reverted back to 1.2.8, you REALLY should try the 1.5.  C'mon, you've never led ME astray, I'm just returning the favor.  :darthsmile:

post #13697 of 18427

The sound of the latest 1.5 factory firmare coming from Doc2008's Mega Sound Explosion.

 

The  mids are rich/present and warm, really pleasing on well recorded vocal mixes. There is good depth layering but width maybe seems ever so slightly narrower, this might because the depth seems improved (instruments etc panned to extreme left and right are still extreme left and right!). There seems to be a perceived low frequency shelf increase starting from 20hz.  I do prefer this a lot over 1.2.8 and I prefer the mids and low frequency level over Mega Sound Explosion but I reckon MSE maybe has ever so slightly better soundstage, MSE definitely does not have as much low end energy. I think Ibasso have done pretty well with the sound sig' 1.5, I really quite like it.

 

It's not dark, it might be with headphones already leaning to the dark side (I am your father,noooooooooooooo)

 

The Startup logo is rather nice....for the short time you actually look at it!

There is a very slight change between the filter fast and slow rolloff, detectable in the way the HF come across maybe 12k up

Got the 64bit  USB DAC working after some jiggery pokery with a driver signing application and windows test mode. (though I won't be using this feature until Ibasso get a signature) . At least it works in principal.

Gapless FLAC seems to work, no clicks or cutoffs so far.

 

Anyway, Doc2008 is already doing his thing on this firmware and has V2 of Sound Explosion based on 1.5 (and bass edition). Not sure when mega will arrive, but just for fun I am going to give this a go and compare with Mega and 1.5.

 

 
Quote:
 
DX50 SOUND EXPLOSION V2 BY DOC2008



-based firmware DX50 v. 1.5.0
-Fixed: Russians tags


DOWNLOAD



DX50 SOUND EXPLOSION DARK BASS EDITION V2 BY DOC2008



-based firmware DX50 v. 1.5.0
-Fixed: Russians tags


DOWNLOAD



ROCKBOX for FIRMWARES BASED on v. 1.5.0


-installation via CWM recovery (a reference to the statement in the header)


DOWNLOAD

 


Edited by polyrhythm - 6/24/14 at 2:02pm
post #13698 of 18427
Quote:
Originally Posted by hikari50 View Post

Same problem here. Moments before you posted this I was actually doing the exact same thing, except that in the end I couldn't get it to show up as a DAC. Which installer did you select? The one in mango_ad or mango_usb?
I just selected the driver folder and let windows do the rest. Driver appears to have installed sucessfully.
post #13699 of 18427

I'm going to keep going with it for a few days, just to see what it's like.

post #13700 of 18427

Thanks for the quick reply but I'm not bothered about the size in the slightest; I'm wondering if its worth saving for the X5 over the DX50 (esp. Now the DX50 has DAC functionality) and losing out on a pair of Fidelio X1's for a while if the SQ is really that much better.

post #13701 of 18427
Quote:
Originally Posted by MCImes View Post

This problem is new to this FW: I will get "lag" pauses/jerky playback in a song. Meaning on 3 different tracks (so far) it will stop playing for 1/10 of a second then continue to play, similar to when your computer is lagging and the music gets choppy. I've listened to these tracks many times before on previous FWs and its never happened. Anyone else?

Its only been on 3 songs out of 3 hours of listening. I know for sure the songs played fine in the past.

Did you do a factory reset? I do this out of habit. I get smooth fast response and it is playing everything so far. 

post #13702 of 18427
I didnt do a factory reset, but I just did one. Ill see if it will repeat. In the mean time, 90 minutes of listening and no more problems though. maybe it was just a fluke

Also, just curious, if I want to compare EQ on / EQ off sound, does anyone know how many volume steps are equal to 6db? or does it depend on the phones?
Edited by MCImes - 6/24/14 at 2:41pm
post #13703 of 18427
I had some problems but after system reset I've solved them

Inviato dal mio Nexus 5 utilizzando Tapatalk
post #13704 of 18427
Well someone can explain me what the digital filters are?

Inviato dal mio Nexus 5 utilizzando Tapatalk
post #13705 of 18427

Just got back from a 40 minute walk, which is how I usually listen to my music.  Gotta say the new firmware really shined during this test.  I put a walking compilation on shuffle and let it just feed me random songs.  Nothing I listened to was too bass-y or shrill.  Even stuff that has always been on the edge (Robert Palmer's Which Of Us Is The Fool for example) played well.  No fatigue, and now that I'm back and writing this I'm still listening.  Vocals seem a bit more forward, I'm noticing.  Bass is not too much, just more than before.  Mids are still fine and pop out of the mix with no problem.  All in all I'm very happy with the firmware.  Now, it iBasso would just do folder to folder and crossfade play, I'd be a happy camper.

 

Oh, and no skips, as someone reported.  I think that may have been a matter of them not doing a factory reset, which is called for after doing an update.  

post #13706 of 18427
Thread Starter 

I guess I am bit late here :blink:

Loading the upgrade. BTW I have added 1.5.0 to the software upgrade list on page 1. :beerchug:

 

Wow the splash screen looks cool!


Edited by musicheaven - 6/24/14 at 5:23pm
post #13707 of 18427
Quote:
Originally Posted by musicheaven View Post

I guess I am bit late here blink.gif
Loading the upgrade. BTW I have added 1.5.0 to the software upgrade list on page 1. beerchug.gif

Wow the splash screen looks cool!

Maybe update the thread title to 1.5.0 wink.gif
post #13708 of 18427
Thread Starter 
Quote:
Originally Posted by Twinster View Post


Maybe update the thread title to 1.5.0 wink.gif


Oops :ksc75smile:

Done!

post #13709 of 18427

I like this very much!!!!

My commute ATH-A900x just got musical.:D

Bravo, iBasso:beerchug:

post #13710 of 18427
Quote:
Originally Posted by musicheaven View Post
 

I guess I am bit late here :blink:

Loading the upgrade. BTW I have added 1.5.0 to the software upgrade list on page 1. :beerchug:

 

Wow the splash screen looks cool!

Yeah, the inmates took over.  :tongue_smile:

 

BTW, I thought it'd be interesting to select the USB/DAC in Settings and then plug my Mac into the DX50 and see what happens.  No drivers available through iBasso, of course, but you never can tell what a Mac can do on its own.  Well, the player lit up w/DAC on the splash screen but nothing else happened.  Oh well, worth a try.  :etysmile:

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016