or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 910

post #13636 of 18426
Quote:
Originally Posted by chailee80 View Post
 

Latest firmware version does indeed add a usb dac function but it seems theres no 64 bit driver yet so i cant test  it sadly :(

I did try to plug my samsung galaxy s5 into it but it didnt work :\

UM..ibasso told me that dac is not available for phones

post #13637 of 18426
Quote:
Originally Posted by paleredfox View Post

.Yeah, I saw the http://www.ibasso.com/download/DX50&DX90_WindowsOS_USB-DAC_Driver_Beta2.zip that was added to the download section but hadnt found the above link.

Yah, i sent an email to ibasso, and it replied me with this link.

post #13638 of 18426

the link to download the 64bit driver is by clicking on the "DX50&DX90 USB-DAC driver for WindowsOS, Jun 21st, 2014".

 

but to download the non beta version which is only the 32bit driver you need to click on the "Download"...

 

Although its on the same line... the 2 links are for 2 totally different files...

post #13639 of 18426
Quote:
Originally Posted by PChoon View Post

the link to download the 64bit driver is by clicking on the "DX50&DX90 USB-DAC driver for WindowsOS, Jun 21st, 2014".

but to download the non beta version which is only the 32bit driver you need to click on the "Download"...

Although its on the same line... the 2 links are for 2 totally different files...
Thanks for the tip, I'm downloading the driver now. Can't wait to see how it fares as a DAC for my gaming sessions. Any impressions on FW 1.5.0's sound yet?
post #13640 of 18426

I got a little Problem with my DX50. I installed the DX90 firmware modified by DOC2008 a few days ago.

 

Today I wanted to install the new 1.5.0 DX50 FW from the internal memory and suddenly got into the CWM recovery menu and could not manage to install the new FW. Now the DX50 does not start any more, it does not go beyond the "iBasso Audio" startup screen.

 

I found out that I can go back to the CWM menu by pressing vol. up + power. The next step I tried was to transfer the supposedly helping stock_recovery.zip file to my external SD since the DX50 does not boot into the OS and as a result cannot be mounted to my computer to access the internal memory. When I now chose install zip from sd card > choose zip from external sdcard it says E:Can't mount /external_sd/

 

So at the moment I find myself unable to do anything … does someone have any idea to fix my problem?

post #13641 of 18426
as far as i know is your need to go back on the stock recovery since the ibasso FW extension is .IMG..CWM is can only flash .ZIP files..

1. make sure that you only have stock_recovery.zip on your dx50 internal memory.
2. boot to recovery then install zip from sd card > choose zip from external sdcard

If all fails.. Try to remove the battery and try it again..
Edited by cub0ne - 6/24/14 at 4:04am
post #13642 of 18426

In the changelog for FW 1.5.0 it reads, "optional digital filter added". I'm not very knowledgeable about these stuff so could someone explain what a digital filter is?

post #13643 of 18426
Finally a new firmware is out! Can't wait to try it and compare to the mega sound explosion! smily_headphones1.gif
post #13644 of 18426
Quote:
Originally Posted by hikari50 View Post

In the changelog for FW 1.5.0 it reads, "optional digital filter added". I'm not very knowledgeable about these stuff so could someone explain what a digital filter is?

same here mate..more like a dac function i think
post #13645 of 18426
Quote:
Originally Posted by PChoon View Post
 

the link to download the 64bit driver is by clicking on the "DX50&DX90 USB-DAC driver for WindowsOS, Jun 21st, 2014".

 

but to download the non beta version which is only the 32bit driver you need to click on the "Download"...

 

Although its on the same line... the 2 links are for 2 totally different files...

The link on the "Download" seems to be the one for the line below which is what the name of the file would suggest "DX90 USB-DAC driver for 32bit WinXP and Win7, May 17th, 2014". So I'd go for the one on the "DX50&DX90 USB-DAC driver for Windows OS, Jun 21st, 2014" link.

The 1.50 FW seems to be on the iBasso download site also.


Edited by LPP6 - 6/24/14 at 4:10am
post #13646 of 18426
Quote:
Originally Posted by hikari50 View Post

In the changelog for FW 1.5.0 it reads, "optional digital filter added". I'm not very knowledgeable about these stuff so could someone explain what a digital filter is?

It 's how the cut at both ends of audio spectrum (20Hz to 20Khz) is done. There are usually 2 options slow and fast roll off. For Fast roll off the cut both ends is steep and almost vertical slope. For slow roll off the end rolls at a shallower slope. For example a slow roll off sends more ultrasonic data/noise to DAC.
post #13647 of 18426
Been having a few issues getting my dx50 up and running reliably. Turns out that the driver installer wasnt installing properly even with driver signature enforcement disabled. I ended up manually installing it from the device manager window. Seems to be working pretty good most of the time on my 64 bit windows 8.1 now. Still have an issue every now and then where the dac wont show up when plugged into the computer and also if i press the play button on the dx50 when in dac mode it seems to crash the device and gets stuck in dac mode when unplugged. Turning it off then on again seems to fix the issue. Few bugs to iron out I guess.
post #13648 of 18426
Quote:
Originally Posted by headwhacker View Post

It 's how the cut at both ends of audio spectrum (20Hz to 20Khz) is done. There are usually 2 options slow and fast roll off. For Fast roll off the cut both ends is steep and almost vertical slope. For slow roll off the end rolls at a shallower slope. For example a slow roll off sends more ultrasonic data/noise to DAC.
Thanks for the explanation!
post #13649 of 18426
Quote:
Originally Posted by chailee80 View Post

Been having a few issues getting my dx50 up and running reliably. Turns out that the driver installer wasnt installing properly even with driver signature enforcement disabled. I ended up manually installing it from the device manager window. Seems to be working pretty good most of the time on my 64 bit windows 8.1 now. Still have an issue every now and then where the dac wont show up when plugged into the computer and also if i press the play button on the dx50 when in dac mode it seems to crash the device and gets stuck in dac mode when unplugged. Turning it off then on again seems to fix the issue. Few bugs to iron out I guess.
Same problem here. Moments before you posted this I was actually doing the exact same thing, except that in the end I couldn't get it to show up as a DAC. Which installer did you select? The one in mango_ad or mango_usb?
post #13650 of 18426
Quote:
Originally Posted by headwhacker View Post

It 's how the cut at both ends of audio spectrum (20Hz to 20Khz) is done. There are usually 2 options slow and fast roll off. For Fast roll off the cut both ends is steep and almost vertical slope. For slow roll off the end rolls at a shallower slope. For example a slow roll off sends more ultrasonic data/noise to DAC.
I see. Thanks for the explanation. Is one "better" than the other?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016