or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 90

post #1336 of 18427
I received my DX50 Wednesday, loaded it with some files and the very first song of course had a hash tag or something so it just froze. I shut it off, erased my sd card and within a couple of hours re tagged some albums and loaded it back up. The player played nicely and sounded fantastic. Last night I updated the firmware, loaded the player and sd card with music, many with symbols, tags, etc. I have been listening to it all day without a single issue so far. At this point I'm quite happy with it but I've gone through the hiccups of the DX100 to be patient. iBasso has comes through when needed. I love Fiio products and have considered purchasing the X3 but held out for the DX50 based on my appreciation for the DX100's sound and glad I did. I am still considering buying the X3 for a different flavor in sound and commend James for his involvement in the threads. I wouldn't hesitate to support either brand.
post #1337 of 18427
Quote:
Originally Posted by spkrs01 View Post
 

 

Do I need to hide ???..........................................

 

:blink:

 

You don't need....but I do as he is chasing after me for my diyimods. LOL

post #1338 of 18427

I know, that the firmware update is overshadowed by other bugs, etc. etc. bla bla

 

Did anyone noticed a change in SQ, because at the moment, or maybe it is just my head, but the DX50 now sounds a bit smoother. Also the lows changed somehow. It sounds now "more like the Wolfson 8740". Maybe its just me.

post #1339 of 18427

What's the LOST.DIR file?

 

Is it necessary?

post #1340 of 18427

I've just installed the new firmware and now my DX50 hangs on the "iBasso Audio" test screen.

One time it did scan my microSD card. I can see the DX50 internal drive if i boot it with a cable plugged in but I cannot access the player. And no the lock is not enabled.

 

I've pulled the battery, held down the power but all it wants to do is sit on that screen.

 

Grrrrr....

post #1341 of 18427
Quote:
Originally Posted by RAFA View Post
 

I know, that the firmware update is overshadowed by other bugs, etc. etc. bla bla

 

Did anyone noticed a change in SQ, because at the moment, or maybe it is just my head, but the DX50 now sounds a bit smoother. Also the lows changed somehow. It sounds now "more like the Wolfson 8740". Maybe its just me.

 

I wish that was the case, but not for me. 

post #1342 of 18427

Listened to a friends X3.  Solely on SQ; DX50 is definitely a step up.  Clarity, separation, soundstage and imaging is better on the DX50.  Never really liked the Fiio sound as its just not my cup of tea.  Using line out on both daps; the difference wasn't as apparent.  Didn't have enough enough time to make a judgement using the line-out.

post #1343 of 18427
Quote:
Originally Posted by caracara08 View Post
 

 

I wish that was the case, but not for me. 

 

Hmm, must be my imagination then.

post #1344 of 18427

Well, did the update and now it won't play anything.  I have done a hard reset, rescaned the card and everything.  If I click on either the artist, album, or genre buttons it shows a quick iBasso Audio graphic and then goes to a blank play screen.  I can see all my files in the directory but none of them will play.  I just checked the one button that I hadn't tried, 'All Music' and it will play a song from there but only one at a time.  If I touch anything on the screen it blanks for a second and goes to a blank play screen saying it is ready.  Well guess what, so am I.  I'm ready for this thing to start playing music correctly.  I need the 1.0 firmware back.  I at least had it playing semi-OK with that firmware.

post #1345 of 18427

Just for giggles I did a 2nd factory reset and now it is working.  Don't know why the first one didn't take.

post #1346 of 18427
Quote:
Originally Posted by RAFA View Post
 

 

Hmm, must be my imagination then.

 

No, you could be right but for me, I havent noticed.   Thats my main gripe with this player (after the FW update)... something in the treble. 

post #1347 of 18427
Quote:
Originally Posted by caracara08 View Post

No, you could be right but for me, I havent noticed.   Thats my main gripe with this player (after the FW update)... something in the treble. 

Well, I came home and did not listen to it at all today. Imidiatelly updated the fw and then listened afterwards. The sound kind of reminded me of the T51 in smoothness (it never did before) also I remembered it much more agressive sonding.
post #1348 of 18427
So with the bug fixes aside, would you guys say the FW update was beneficial for the sound?
post #1349 of 18427
Quote:
Originally Posted by SkyBleu View Post

So with the bug fixes aside, would you guys say the FW update was beneficial for the sound?

As I said, maybe a tad bit, but I am not sure.
post #1350 of 18427
Quote:
Originally Posted by SkyBleu View Post

So with the bug fixes aside, would you guys say the FW update was beneficial for the sound?

 

A bit, yes. 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016