or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 788

post #11806 of 18426
The freezing and volume. Spikes have happened to me on all software versions. If they use the sames firmware on the DX-90, I would never pay 400.00
For a DAP this buggy! These things are made for portable use and this is the area that has the most issues. I have been thinking about switching to the X5.
post #11807 of 18426
Quote:
Originally Posted by headwhacker View Post

Quote:
Originally Posted by canikickit1 View Post

Thanks.. using the headphone out.. or line out when connecting to an external amp

?

 



Always connect the external amp to the Line Out of DX50. You are double amping if you connect it to the headphone out. Just max out the volume in DX50

Turning the volume all the way up while connected to LO may cause clipping, 250 seems to work better.
post #11808 of 18426
Quote:
Originally Posted by Room40 View Post

I have V1.1.5 on my DX50 still (second batch) and am thinking is it worth it to upgrade to 1.2.8? Have deliberately stayed away from all the Version hype that I got sucked into with my DX100. The fact is it worked for what I wanted and so I just stayed with it smily_headphones1.gif

Anybody who has been on the whole journey of the DX50 care to chime in as to whether I should upgrade the software or whether I shouldn't 
Mine is v1.2.8 , haven't heard other FW version , but the latest FW sounded good to me , just hope that next FW update can improve on UI , especially to change the wall paper .
I think you could always try to flash it to latest version to try for yourself after you have listen to current version long enough . If you don't like it , just flash it back . I understand it is very simple step to do that .
Now , Fiio X5 is out , read couple of review all confirming that X5 is way better than DX50 in terms of sound quality and amplifier portion . I am so tempted to get one on my hand .
China is selling it at rmb 2098 exclude international shipping . Seems to be a very good price .
Cheers
post #11809 of 18426
Quote:
Originally Posted by wickson View Post



Turning the volume all the way up while connected to LO may cause clipping, 250 seems to work better.

 



Why? Not if your amp can properly match the voltage gain required by the headphone in use.
post #11810 of 18426
Quote:
Originally Posted by headwhacker View Post

Quote:
Originally Posted by wickson View Post



Turning the volume all the way up while connected to LO may cause clipping, 250 seems to work better.

 



Why? Not if your amp can properly match the voltage gain required by the headphone in use.

Maybe I should have finished my sentence, no clipping with the RSA shadow and pico slim at 250. 255 causes clipping.
post #11811 of 18426
What amp are you using headwhacker?
post #11812 of 18426
Quote:
Originally Posted by wickson View Post



Maybe I should have finished my sentence, no clipping with the RSA shadow and pico slim at 250. 255 causes clipping.

 



How do you perceive clipping in the shadow and slim? are they both in the high gain? Or you hear clipping at low gain?
post #11813 of 18426
Quote:
Originally Posted by wickson View Post

What amp are you using headwhacker?

 



UHA-6S MKII and O2
post #11814 of 18426
Quote:
Originally Posted by headwhacker View Post

Quote:
Originally Posted by wickson View Post



Maybe I should have finished my sentence, no clipping with the RSA shadow and pico slim at 250. 255 causes clipping.

 



How do you perceive clipping in the shadow and slim? are they both in the high gain? Or you hear clipping at low gain?
I don't perceive it... I see it on my oscilloscope. smily_headphones1.gif
By gain do you mean volume?
The shadow and slim don't have gain control.
post #11815 of 18426
Quote:
Originally Posted by headwhacker View Post

Quote:
Originally Posted by wickson View Post

What amp are you using headwhacker?

 



UHA-6S MKII and O2

When connected to lo at max gain, with my amps... The bass becomes extremely muddy as the volume goes up.
post #11816 of 18426

I want to ask why i cannot play the flac file ? It didnt showed in the all music section, instead on the folder directory which i put the songs.

 

I tried to play it but it said media scanning. Is there any solution to this? I just bought this DAP and the sound was great ! Sorry if it was a repost question

post #11817 of 18426
Quote:
Originally Posted by wickson View Post


I don't perceive it... I see it on my oscilloscope. smily_headphones1.gif
By gain do you mean volume?
The shadow and slim don't have gain control.

 

Are you saying you see the clipping in the LO @ 255 or after the amp? If it is only after the amp, obviously the problem is with the amp and has noting to do with the LO volume directly. Some amp just ain't capable of accepting a high voltage,

post #11818 of 18426
It's the amps that's clipping not the LO is it?
post #11819 of 18426
Quote:
Originally Posted by ClieOS View Post

Are you saying you see the clipping in the LO @ 255 or after the amp? If it is only after the amp, obviously the problem is with the amp and has noting to do with the LO volume directly. Some amp just ain't capable of accepting a high voltage,
After the amp of course... Never said there was a problem.
Simply stated the ideal LO gain when connected to the RSA shadow and pico slim.
I wouldn't call it a problem at all.
post #11820 of 18426
Quote:
Originally Posted by Room40 View Post
 

I have V1.1.5 on my DX50 still (second batch) and am thinking is it worth it to upgrade to 1.2.8? Have deliberately stayed away from all the Version hype that I got sucked into with my DX100. The fact is it worked for what I wanted and so I just stayed with it :)

 

Anybody who has been on the whole journey of the DX50 care to chime in as to whether I should upgrade the software or whether I shouldn't 


Just do it. I went through all firmware changes since 1.1.0 (or it might have had 1.0.0, can't remember right now), and right now, 1.2.8 is the more stable and usable so far (SQ is another subject... and i won't refer to it). All you need to do is follow the instructions that come with the firmware step by step, and it should work flawlessly. 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016