or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016 - Page 745

post #11161 of 18426
Quote:
Originally Posted by Sorensiim View Post
 

Am I the only one having issues with the playback order on 1.2.8? :frown:

Fixed mine - Cleared the .audio data folder and the two-disc album that was giving me grief is no longer in two folders (disc 1, disc 2) but instead the tracks are renamed to Disc 1 - 01 - Track title.flac. Works perfectly now :beerchug:

post #11162 of 18426
Quote:
Originally Posted by Sorensiim View Post
 

I couldn't live with that. I just jumped on a pretty good deal for these puppies. Now the waiting game begins...


wow, looking forward to your impressions....:beerchug:

 

on a serious note, y u buy speakers on head fi? :evil:

post #11163 of 18426
Quote:
Originally Posted by CosmicHolyGhost View Post
 


wow, looking forward to your impressions....:beerchug:

 

on a serious note, y u buy speakers on head fi? :evil:

I didn't. Got a killer deal on a set here in the EU so the time had come to finally upgrade from my Sony all-in-one bluray/surround atrocity.

post #11164 of 18426
Quote:
Originally Posted by Cotnijoe View Post

Mannn... My DX50 still skips the first like second and a half of a song... Anyone know how to fix?

 

I turned the "gapless" feature on, and I don't see such issues now. All my tracks seem to start from the very beginning.

post #11165 of 18426
Quote:
Originally Posted by wickson View Post

Dx50 paired with RSA shadow isn't what I hoped. Using shure 535, dx50 sounds better without it.
Anyone else amping with the shadow?
Bass is muddy to my ears, sounds cleaner without...

 

Quote:
Originally Posted by wickson View Post


What amp are you using now, if any?
The for sale section seems flooded with RSA shadows lately.
Might wait to unload it.

 

I like the sound better directly from the dx50 than paired with a C5 with my W4s. This is with fw 1.2.8. I like the C5 with 1.2.7 and 1.2.6. I will be selling the C5 and did put up a wanted ad for the shadow last night. Might have to reconsider now and just go without an external amp.

post #11166 of 18426
Quote:
Originally Posted by revolutionz View Post

I have my Shadow/DX50 paired up with my Shure SE846.  I love it.  It sounds better than the Shadow paired with my Sony F series.  I also tried a vamp at a meet, I liked the shadow better. I don't find the low end muddy at all. Maybe I'll try it with some of my other IEMs and see what I find.

Do you have the LO set to full power?
post #11167 of 18426
Quote:
Originally Posted by molika View Post


I like the sound better directly from the dx50 than paired with a C5 with my W4s. This is with fw 1.2.8. I like the C5 with 1.2.7 and 1.2.6. I will be selling the C5 and did put up a wanted ad for the shadow last night. Might have to reconsider now and just go without an external amp.

I briefly tested it with reduced lo power, clipping was reduced. Going to a/b it better this evening.
post #11168 of 18426
Quote:
Originally Posted by wickson View Post

I briefly tested it with reduced lo power, clipping was reduced. Going to a/b it better this evening.

I have the dx50 volume maxed out on lo. somehow I prefer the sound either directly from the DX or the ho with the c5. via lo there is clipping, loss of detail, and I notice some sibilance, also less texture esp on piano notes. however it is tighter and more control at the lower end. let me know how you go. I'll try with reduced lo power. interestingly I preferred the sound with c5 and fw 1.2.6 and 7. for me a lot of improvement on 1.2.8 which probably defeats the purpose of having an amp unless its a very good one and most probably a very expensive one. better spend the money on better iems in that case. no criticism on the c5, its a good portable amp but not doing it for me. I was looking at upgrading to the shadow but I'm a bit hesitant from what I've read now. think my c5 will go to my other half to use with her sansa fuze and W3s.
Edited by molika - 2/5/14 at 4:59am
post #11169 of 18426
Quote:
Originally Posted by Shinigami View Post


Thanks for the report. Guess thats it, as much as i want to buy dx50, due to this issue, i decided i will no longer dx50. I'll just wait for dx90 and x5. Thanks a lot smily_headphones1.gif


Im waiting on a preorder for the dx50, i read good and bad news but this is the worst, taking in risk my hearing while i care a lot is in no debate

Any one else reporting this? maybe on a selected playback config? (repeat, shuffle etc)

very sad news if it is forcing me to cancel my preorder

post #11170 of 18426
Quote:
Originally Posted by Marco Angel View Post
 


Im waiting on a preorder for the dx50, i read good and bad news but this is the worst, taking in risk my hearing while i care a lot is in no debate

Any one else reporting this? maybe on a selected playback config? (repeat, shuffle etc)

very sad news if it is forcing me to cancel my preorder

Mine did it once, on FW 1.1.5, but a co-worker was using it at the time so I don't know exactly how it happened. 

post #11171 of 18426
Hi all. I have had no problems with my DX50. I love it. I pair it with a headstream arrow 4N which is very thin, ultra portable, clean, only adding power . Using HD500's. I recommend checking out this amp.
post #11172 of 18426
Quote:
Originally Posted by wickson View Post

What amp are you using now, if any?
The for sale section seems flooded with RSA shadows lately.
Might wait to unload it.

Since updating the firmware to 1.2.8, I have not used an external amp. As I mostly use the DX50 with my Cardas EM5813 IEM's, there is no need for external amplification. If I do need more horsepower for some of my over-ear cans, I use either my T1 or PB2 via balanced output.
Edited by HiFlight - 2/5/14 at 5:53am
post #11173 of 18426
Quote:
Originally Posted by gmm1 View Post

Hi all. I have had no problems with my DX50. I love it. I pair it with a headstream arrow 4N which is very thin, ultra portable, clean, only adding power . Using HD500's. I recommend checking out this amp.


do you use any play setting? like repeat the song-album

im used to use non of those features, just play the album or song as it

post #11174 of 18426
.
Edited by MCImes - 2/5/14 at 6:25am
post #11175 of 18426
Gapless play works perfectly on my DX50. Load time is short but probably because my music is in folders organized well and I am predominantly playing flac files. I can even hook up a 500 GB hard drive to the DX50 and it scans fast and plays great. The drive does need additional power that the DX 50 does not provide. My take on reading DX50 posts exhaustively is that some people get defective units.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.9.4 - January 24, 2016