Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.6.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.6.0 - Page 498

post #7456 of 15896
Quote:
Originally Posted by teaough View Post
 

Guys - Thanks for the bad news :-)  I was afraid of that.  I'll wait to see what the iBasso guys say and report back to this thread.

 

:o give us update as soon as you can. I hope they'll ship a new unit for you soon.

post #7457 of 15896

Yeah - it might be interesting to others how iBasso deals with defective units.  I'm certainly interested to find out.  China is a long way from Upstate New York (USA).  :-)

post #7458 of 15896
Quote:
Originally Posted by teaough View Post
 

Yeah - it might be interesting to others how iBasso deals with defective units.  I'm certainly interested to find out.  China is a long way from Upstate New York (USA).  :-)

I live in Italy instead :)

 

Surprisingly Fedex priority (bought on MP4 Nation) was really fast and my 9th batch is arrived in Italy today and the estimated delivery is on monday or tuesdey. Anyway things could be long in the case of a defective unit..

 

So keep us updated :)

post #7459 of 15896
Yeahhh wink.gif Waiting Ibasso next day!
post #7460 of 15896
Quote:
Originally Posted by simonsullivan1 View Post
 

I thought I'd share some further findings that seem to dramatically impact scan times.

 

I usually keep my tags pretty clean but even after the suggestions I made in post#6841 I was still not getting some of the scan times I've seen quoted in this thread.  I've heard people say it takes around 5 mins to scan a 64GB card, well mine was scanning correctly but still took around 30 mins.

 

Here are the further steps I took to reduce my scan times:

Using Mp3Tag I brought in all the tracks on the 64GB card and removed all but the ARTIST, ALBUM, TRACK NO., TITLE, YEAR and GENRE.

Initially I thought that was it, no other tags to clean, but after some digging around I found that there are extended tags, some what less supported but still locations to store further information about the track.

In Mp3Tag, highlight all your tracks [CTRL+A] in the menu bar, select 'View' and select 'Extended Tags', this brings up an additional box that lists all the other types of tags hidden in your music files.  To remove all unwanted tags (again I removed all but the ones listed above), click on a tag and hit the red cross (it should now say'<blank>'), then select the next tag you want to remove and hit the cross again. Work your way down the list and repeat as needed, but be careful not to delete ones that you want.  Once you've repeated this for all unwanted tags simply press okay, and this will automatically prompt the save tags dialog.

 

Initially I had around 50 extra categories of information buried across my library and I am pretty certain that this added load to the scan process and was the reason for taking so long.

 

Just to clearly outline what I now have:

Scandisk MicroSD Class 10 64GB card with 2,525 tracks on it, totaling 55.7GB.  This is made up of 1,532 flac files totaling 47.9GB and 993 mp3 files totaling 7.8GB.

It used to scan in around 30 mins, I have just scanned it in 5mins 09secs.

 

One additional point worth noting is that if I changed content on my card and had to rescan it would always freeze.  It seemed to be unable to clear the old database/rebuild the new one on top of it.  I could only get around this by [volume + and power] factory resetting it and then starting the 30min scan start. Now if I change content on the card it is able to rebuild the new database without requiring me to factory reset.

 

For those of us that have and still are experiencing freezing or endless scans then I think it's seriously worth looking at the tags of the files.  If you have converted your own CD collection then perhaps your library is far less cluttered with unwanted tags but if you download your music (and I'm on about purchased downloads too) then it's worth spending 5 mins to take a look!!

What a great useful post... doing this now!!! I knew there were these extended tags but not taken the time to clean them out.

post #7461 of 15896
Quote:
Originally Posted by Jpfe8851 View Post

What a great useful post... doing this now!!! I knew there were these extended tags but not taken the time to clean them out.

Glad this is working out for you, but I feel like you quoted me in my posts earlier and somewhat criticized me for recommending doing pretty much the same thing.

Anyway, I hope it works out for you. I know it has worked for me.
post #7462 of 15896
Quote:
Originally Posted by HiFlight View Post

I am still unable to accomplish a factory reset using the Settings/Advanced/Factory Reset option. It always hangs up on the "See You Later" screen after I acknowledge the reset confirmation screen. I am running v.1.2.5 final firmware and installed it from an empty SD card. After a long period of time hanging it finally times out and the player shuts off. I am assuming that a factory reset was not accomplished as my play mode, volume and gapless settings are not changed back to the defaults.

Previous versions prior to 1.2.5 would accomplish the factory reset in a very short period of time, usually less than a minute.

Anybody else experiencing this issue?

Other than this, I have experienced no freezes or other abnormalities when using this firmware.

 

I'm about 500 posts behind - no time until today to upgrade to 1.2.5. I just did and the Factory Reset went without a hitch after the upgrade. Maybe the file I downloaded yesterday (DX50FW_V1.2.5) is further updated? 

 

Way to early to conclude anything but it does seem to be part way between 1.2.2 and 1.2.3beta. I have been listening to 1.2.2 right through to this morning and the soundstage is wider and airier with the upgrade. However it also seems that it may have retained some of the the "soul" that went AWOL on 1.2.3beta. So far, I am cautiously optimistic....

post #7463 of 15896
Quote:
Originally Posted by Sorensiim View Post
 

Finally got around to making a better IC for my stack:

 

 

More info here, I don't want to derail this thread: http://www.head-fi.org/t/687288/so-im-looking-for-that-perfect-amp/480#post_10002669 :o

 

Drool!

post #7464 of 15896

Okay, now I am starting to get excited. The jangly leading edges on acoustic guitar that I disliked in 1.2.3beta are not present in 1.2.5. Folk is sounding very good. It's not quite as warm and full as 1.2.2 but it is more open I believe, rendering space and detail in the soundstage nicely.
 

So far 1.2.5 is sounding clean and neutral to my ears. (Rig: DX50 > Pico Power > Heaven VI)

post #7465 of 15896
Day 3 of the DX50 and my experiences of the new machine.

Having taken out unnecessary tags, I realised that I had lost some artwork again, so I just decided to copy my music from iTunes unedited and have encountered no problems at all. I have copied 40g across so far, which are my based on my favourite artists and albums, to a new sandisk 64g card. So I reckon Ibasso have got rid of most of the scanning bugs by now, as my music has come from many sources and the tags are very inconsistent.

I have decided to use the internal memory of the player to swap in & out my less played music and keep my SD micro card relatively unchanged.

Onto to the music playing capability - it's pretty good isn't it? I have been listening to it through Sennheiser 600 over the weekend. And it has performed brilliantly across Led Zeppelin, Yes, Riverside (Polish band) and Vivaldi with great 3d soundstage, clarity, with a good depth of bass as well as producing a lovely warm almost tubey sound. I am now using it with UE Fi pros on my commute to work - no hiss, just near to perfection.

As mentioned before my first impression was that I could really tell the difference between using the Dx50 on its own or with the GS Voyager on the Sennheiser 600s. After more in depth A/B testing, I still can't, well not enough to justify keeping the GSV. It maybe has a little more warmth, but less detail but too be honest I am not sure I could really tell.

So I there is no point keeping the GSV and I have decided to buy a Leckerton UHA 6S mkii with the tubey OP 627s, which I snapped up on eBay yesterday. My logic was that the amp has had great reviews, it's not too price prohibitive, and I could try the coaxial out on the Dx50 and I can even roll the OPamps as well.

To sum up, I think my expectations were well managed by all the beta testers on this forum here, so thanks. What I expected to find was a player that has a few quirks, and whose interface might be a bit glitchy compared to my IPod classic, but that the the player's musicality would win out and that is what I have found.
post #7466 of 15896
Quote:
Originally Posted by headwhacker View Post

For Portability.

2 - 1 - 4

On my desk

4 - 2 - 1

UHA-4 extracts more details especially on the highs compared to DX50 amp. Bass much cleaner and tighter on UHA-4 than DX50. I think this is due to the volume control of DX50 is implemented on the DAC itself. With UHA-4 or any other external amp you can crank up the volume to 255 and let the UHA-4 get the maximum dynamics and control the volume the goes to your phone. With DX50 amp of course you can't set the volume up to 255 without busting your hearing so it appears the DX50 lose out on details. Also the bass gets muddy and bleed out to the mids when you set the volume load enough to hear the minute details in the mids and highs. I suppose if they had implemented the volume control on the amp and set the DAC volume fixed to 255 then the DX50 amp may have performed equally with UHA-4.

UHA-4 and O2 appears to be on the same level extracting details out of DX50's LO. Again I think that is because in both case I can crank the volume all the way up to 255.The bass on O2 has more thump amd impact compared to UHA-4. Separation appears to be on the same level. I can't really tell if there is a difference in soundstage. Another thing to note using O2 with sensitive IEM is very limited when it comes to volume travel. I suppose with bigger cans I'm pretty sure O2 will win hands down against UHA-4.

Apparently UHA-4 offers more portability compared to O2 and SQ wise with sensitive IEM UHA-4 doesn't lose out to O2. But on the desktop setup O2 is much more flexible against UHA-4. Having said that, I tried UHA-4 with my Beyerdynamic T1 and it has no problem driving it. With my current collection of headphone/IEM UHA-4 as an amp pretty much covered all my usage scenario.

However, I'm planning to get an ODAC board and upgrade my O2 to O2+ODAC which I intend to serve as my desktop rig. Seems like I can let go of the PHA-1 and Hifi-M8.

But at the end of the day, if I am left with only Dx50 and no amp, it won't bother me I will still enjoy listening to it's sound.

-- 3. UHA-4 does not have coaxial input. So this scenario is not applicable.


Cool - thanks for taking the time & very helpful . I didn't read your first response clearly enough in that you had a UHA 4 and not a UHA 6 and therefore coudn't test the coaxial side.

Anyway I have decided to go ahead and buy it.
post #7467 of 15896
Quote:
Originally Posted by DrGonzo View Post


Glad this is working out for you, but I feel like you quoted me in my posts earlier and somewhat criticized me for recommending doing pretty much the same thing.

Anyway, I hope it works out for you. I know it has worked for me.

You've completely misunderstood me. I certainly did not intend to criticise you if you took it that way. You should be commended for trying to help out. 

 

I am not sure if you've been reading this thread since the beginning so you may also have missed my many posts about cleaning tags and so on in the same effort as you to help others overcome the apparent inconsistent scan times and so on of the DX. I also totally agree that iBasso is to be commended for taking the time and effort to remedy them. But that doesn't mean I should forgive them for the time it's cost me fiddling with files that worked perfectly well on their sister DAP the DX100.

 

My earlier comment that you thought I was being critical of you was to purely say that with so many competitively priced and some not so competitively priced DAPs on the market each with their idiosyncracies, we (that is you AND I) should not be forced into all these hoops and hurdles to get a player to simply list our albums and show the songs without having to reformat our files every time we get a new one. I've got or had a DX100, DX50, AK100, RWAK100 and a Sony Z-1070, plus Android phones and iPhones and iPads and iPods, Rockboxed and standard. AND everyone of them I have had to go through this process of adding tags deleting tags, changing artwork from embedded to folder.jpg insertions.

 

Wouldn't it be nice to just load up the music and have the thing display and play? 

 

No, definitely no criticism intended...  just pointing out that none of us should have to do this when digital music standards have been around for over a decade and reading files should be sorted out by now. 

post #7468 of 15896
Quote:
Originally Posted by teaough View Post
 

OK - I'm in the club now too.  Got mine a few days ago from MP4Nation and am very happy with the sound through my ancient history Sennheiser 580s.

 

I poked around this forum and others to come to a decision about Fiio vs. iBasso and went with iBasso.  Got mine from batch 9 with 1.2.5 firmware.  Bought 2x 64GB Sandisk micro SD cards from B(ig) B(ox) store for cheap, loaded up a full card worth of Medieval, Renaissance, and Baroque tunes and off we go.  Sounds great.  But I have a problem - the middle physical button doesn't do anything.  The screen button works just fine though.

 

When song is playing pressing middle button doesn't pause.

When song is paused (with screen "button") middle button doesn't resume.

 

Is this a 1.2.5 firmware problem or do I have to send the player back to China?

 

Wrote to iBasso just before this and am awaiting a response.

 

Bummer.

 

Same issue, same batch :( mines going back today. 

post #7469 of 15896

* is dx50 shows battery indicator with remaining percentage.

* is there any low battery status indicator.

post #7470 of 15896

Not to get too enthusiastic but... I just had my best day ever with the DX50. I walked all over Hong Kong listening to my DX50 (1.2.5) + Pico Power + Heaven VI rig. These components have great synergy and it was just a pleasure. This is my read of the recent evolution of the DX50 firmware: 1.2.2 was highly euphonic but a bit close around the head. 1.2.3beta had deep grinding bass but jangly treble and the soundstage, while very wide was not well integrated. There was a sense of artificial separation of the centre sounds and the out-there periphery sounds. 1.2.5, at least with my rig, has great coherence from left to right and also a nice 3D quality on the periphery. It is not as overtly euphonic as 1.2.2 but since I am using one of the most euphonic IEMs out there, it is a better source to bring the natural qualities of the Heaven VI to life. The bass is not quite as strong as 1.2.3beta but I find it to be well balanced. Again I am enjoying great synergy as the Pico Power already produces deep detailed bass; the DX50 with 1.2.5 is a nice clean source to feed it.

 

I had a great day of music. 

 

Actually I did a comparison with the AK120 headphone out at Jaben and with the same song: Suck My Kiss by the Red Hot Chili Peppers, both with the Heaven VI. (I think that the song on the AK120 was higher resolution too; mine is a Lame 320 CBR MP3.) The AK120 had nothing on my rig and frankly the tight bass slam of the DX50 + Pico Power blew the AK120 away. Much of that would be attributable to the Pico Power but I otherwise saw no advantage to the AK120's sound. I thought my rig was as good or better across the board. The DX50 really is a very good source to feed a top-end amp and - to my taste with my equipment - it has never sounded better than with 1.2.5.

 

Happy.  :-)

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.6.0