Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.6.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.6.0 - Page 452

post #6766 of 15612

Ah yes. v1.2.0. Its done updating now. Thanks

post #6767 of 15612

 

 

 

post #6768 of 15612
Quote:
Originally Posted by headwhacker View Post


If you want to stack DX50 on top of O2, you will need an LOD cable at least 10cm in length. Preferably both ends have right-angled connector.


LOD IS NOT GOING TO WORK!  NEED A 3.5 MALE TO 3.5 MALE.

post #6769 of 15612
Quote:
Originally Posted by BeBop Lives View Post
 


LOD IS NOT GOING TO WORK!  NEED A 3.5 MALE TO 3.5 MALE.

 

You do realize in DX50/O2 context it should be the same? No?

post #6770 of 15612

Got my HP50s. Sound good but not quite as comfortable as my HD25s ;-;

post #6771 of 15612
Quote:
Originally Posted by Jason36 View Post

My Desktop office rig for today :

DX50 -> O2 Amplifier -> Sennheiser Momentum smily_headphones1.gif





Extremely impressed with this set-up. Just need to look at getting a new Cable to connect DX50 to O2, current one is OK but at about 3m long is a bit unmanageable. Something about 25 to 30cm would be ideal.

 

ALO Audio

 

Can be purchased in various lengths. also have one on my O2. very good sound.

 


Edited by glockhit - 11/14/13 at 9:52am
post #6772 of 15612
Quote:
Originally Posted by headwhacker View Post
 

 

You do realize in DX50/O2 context it should be the same? No?


OK, LOD WILL NOT WORK WITH DX50 TO 02 AMP....YOU NEED A 3.5 TO 3.5 MALE

 

http://www.amazon.com/Cable-Pailiccs-adater-Professional-ZY-014/dp/B00A2QJVRK

post #6773 of 15612

Ok genius I suppose you just need a bump on post count.

post #6774 of 15612
Quote:

Originally Posted by BeBop Lives View Post
 

 

OK, LOD WILL NOT WORK WITH DX50 TO 02 AMP....YOU NEED A 3.5 TO 3.5 MALE

 

http://www.amazon.com/Cable-Pailiccs-adater-Professional-ZY-014/dp/B00A2QJVRK

You don't need ALL CAPS BOLDED LETTERS you know, it makes it seem like you're yelling on the internet, never a good thing to give the impression of :p 

post #6775 of 15612
Quote:
Originally Posted by BucketInABucket View Post
 

You don't need ALL CAPS BOLDED LETTERS you know, it makes it seem like you're yelling on the internet, never a good thing to give the impression of :p 


SURELY YOU JEST!!

post #6776 of 15612
Quote:
Originally Posted by BeBop Lives View Post

Quote:
Originally Posted by headwhacker View Post

 

You do realize in DX50/O2 context it should be the same? No?

OK, LOD WILL NOT WORK WITH DX50 TO 02 AMP....YOU NEED A 3.5 TO 3.5 MALE

http://www.amazon.com/Cable-Pailiccs-adater-Professional-ZY-014/dp/B00A2QJVRK
caps_off.jpg

caps_on.jpg
post #6777 of 15612
Quote:
Originally Posted by Sorensiim View Post


caps_off.jpg

caps_on.jpg

Couldn't agree more..

post #6778 of 15612

Hey!  What's that AARP reference! ;)

post #6779 of 15612
Quote:
Originally Posted by Sorensiim View Post

Awesome Oatmeal comic (Click to show)
caps_off.jpg

caps_on.jpg

Pleased to meet you, fellow oatmeal-er beerchug.gif
Quote:
Originally Posted by BeBop Lives View Post

Quote:
Originally Posted by BucketInABucket View Post

 
You don't need ALL CAPS BOLDED LETTERS you know, it makes it seem like you're yelling on the internet, never a good thing to give the impression of tongue.gif  

SURELY YOU JEST!!
Obnoxiously large bolded caps-lock text (Click to show)
I SPEAK 120% TRUTHS DO NOT QUESTION INGSOC!
post #6780 of 15612
Quote:
Originally Posted by headwhacker View Post


I have a 64mb card full of ALAC files. So far no issues. Just make sure you let DX50 scan all your files. If possible make sure you have properly tagged all your files.

 

 

Quote:
Originally Posted by Jason36 View Post


I have ALAC files on one of my SD Cards and I have just copied them across from my iTunes library file having made no amendments to the tags from when they were imported.......I have been using these for the last month with no problems......album art displays and all files seem to,play ok showing artist, song and album.

Hope that helps

 

Hmm, then there seems to be something wrong with the tagging on my file, because when i copy all the music over in one lump, the player  stops scanning after only a few albums (say 20 out of 120).

 

I've been copying music over in lots of 3-5 albums and so far it has been working.   But I wonder if either XLD or Phile is doing something funny with the rips.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.6.0