Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.6.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.6.0 - Page 214

post #3196 of 15880
Quote:
Originally Posted by mahesh View Post
 

hI all lucky dx50 owners

 pLease post your impressions if you have tryed with akg k3003

Thx :beerchug:

 

I'm personally not too crazy about this pairing.  I hear transparency and clarity with a wide soundstage but kind of cold.  The highs are over prominent, even fatiguing to me.  Bass is rather weak as well.  I actually find the pairing with the X3 much better.  Smaller, more intimate sound stage but warmer, with more body to the sound.  But remember this is only my opinion.  I believe someone else earlier in this thread expressed a liking of this pairing.

 

In case it makes a difference, I use the K3003's with the reference filter.

post #3197 of 15880
Updated to 1.2.0 FW without issue, went very smoothly. However, the issue of songs in albums not 'lining' up continues. I already took another member's expert advice to re-pad and re-tag, still it is not 100%, in that regard I think it is disappointing that such well straight forward issue is not 100% addressed.

All my other Android players in my Note 2 read all files without problem and need zero retag.
post #3198 of 15880

Does anybody know how these fare with Macs? I just bought one...

post #3199 of 15880
Quote:
Originally Posted by kkcc View Post


Did you factory reset and rescan the sd card after the update?

With OGG files and Monkey´s audio (ape), there are problems with the read of the TAGS.

Images are not displayed. With the next firmware you want to resolved.


Edited by pnix - 10/2/13 at 12:13am
post #3200 of 15880
Quote:
Originally Posted by frankrondaniel View Post

I'm personally not too crazy about this pairing.  I hear transparency and clarity with a wide soundstage but kind of cold.  The highs are over prominent, even fatiguing to me.  Bass is rather weak as well.  I actually find the pairing with the X3 much better.  Smaller, more intimate sound stage but warmer, with more body to the sound.  But remember this is only my opinion.  I believe someone else earlier in this thread expressed a liking of this pairing.

In case it makes a difference, I use the K3003's with the reference filter.
Buy ak120 smily_headphones1.gif
post #3201 of 15880
Quote:
Originally Posted by aikhong16 View Post

Buy ak120 smily_headphones1.gif

I had the k3003 and didn't like it with my source at the time and sold it, and I specifically went back to test it with the ak120 in May when I got my ak120 and still didn't like it. The best I had heard it on was the Tera but I cannot get pass its unique design... YMMV.

Haven't hears how DX50 pairs but my other hybrids the 1plus2 and the asg2 both pairs very well
post #3202 of 15880
Thread Starter 
Quote:
Originally Posted by CosmicHolyGhost View Post

Hey, you still rocking it with D12? Hows it? I have been listening to the dx50 with the db2/pb2 combo...even with single ended iem, the soundstage is so spacious and the sound is so refined.. I even like it better than my 901 bal card.. Ibasso does some awesome dual 8740 implementation which i hope its the same case for you with your d12...

The D12 sounds grand, I agree with you iBasso does great 8740 dual implementations. Using the D12 in coax mode is the best but someone said it's like having a cheaper AK120. I haven't listen to any of the AKs so can't comment on that. I did try it on the D12 LI, sounds is very good, it does feel like a very different setup, more like a desktop rig.
Edited by musicheaven - 10/2/13 at 6:09am
post #3203 of 15880
Thread Starter 
I did a few LO and HO tests with my SE535 which are sensitive. First the famous hiss is more of a low background noise along the lines of white noise, similar to when I crank my Pico Slim amp to the max. So that noise comes from the DX50 amp. I do not get that noise when connected to the LO. Now because of being low, as soon as the music plays, it just get buried and you can't tell it's there. It does not increase with the volume control. Really wondering about the noise to signal ratio with the SE535 impedance. I'd like to know what's being used in the amp section, I have the impression it's his Achilles’ heel. I hope I am wrong.
Edited by musicheaven - 10/2/13 at 12:45am
post #3204 of 15880
As mentioned after FW 1.2.0 I continue to have file tag issue and this is one of the albums having problem, ie, play not in sequence, can anyone see if there is any gross errors?

post #3205 of 15880
@Breadvan, You can try retag it.
Example
File Name : "Dream The ater - Another Day"
Title : "Dream Theater - Another Day"
Artist : "Dream Theater"

That's it.
post #3206 of 15880
Thread Starter 
Wow the piano on the DX50 sounds so sweet it's as if I am sitting on the pianist's bench when he hits the notes smily_headphones1.gif
post #3207 of 15880
Quote:
Originally Posted by musicheaven View Post

Wow the piano on the DX50 sounds so sweet it's as if I am sitting on the pianist's bench when he hits the notes smily_headphones1.gif
Iem pairing pls....
post #3208 of 15880
Quote:
Originally Posted by musicheaven View Post

I did a few LO and HO tests with my SE535 which are sensitive. First the famous hiss is more of a low background noise along the lines of white noise, similar to when I crank my Pico Slim amp to the max. So that noise comes from the DX50 amp. I do not get that noise when connected to the LO. Now because of being low, as soon as the music plays, it just get buried and you can't tell it's there. It does not increase with the volume control. Really wondering about the noise to signal ratio with the SE535 impedance. I'd like to know what's being used in the amp section, I have the impression it's his Achilles’ heel. I hope I am wrong.

 

That trouble shoot doesn't necessarily point to the amp stage. The volume control will be before the last stage of the SOC or line amp so if there's any residual noise on that stage, a quiet amp will still pass it. It's actually more likely elsewhere than the amp stage but there's no way to tell without checking the separate stages. 

post #3209 of 15880

My wife just called: the Eagle has landed. the DX50 is at home!!! (4th batch)

post #3210 of 15880

can someone elaborate as to what the '.album_img' folder is for? i'm having trouble with artwork on a certain album show up. the artwork is embedded in each file and shows fine on my fiio x3.

 

is there a database stored anywhere on the dx50 that i can wipe?


Edited by alphabetagaga - 10/2/13 at 5:50am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.6.0