Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.5.0 - Page 557

post #8341 of 15203
Quote:
Originally Posted by Cotnijoe View Post
 

ooo! nice looking recabled Gr07!

 

Edit: wait... is it? 

That's the GR07 Bass Edition

post #8342 of 15203
Quote:
Originally Posted by Hellkitchen View Post
 

Guys I've some problem with DX50. It doesn't play with some album I have. Don't kwow why. It's just show 0kbs and 0khz and is unable to play tracks. 

Any idea or someone has already experienced this?


is it on main storage or the sd card?

post #8343 of 15203
Thread Starter 
Quote:
Originally Posted by Hellkitchen View Post

Guys I've some problem with DX50. It doesn't play with some album I have. Don't kwow why. It's just show 0kbs and 0khz and is unable to play tracks. 
Any idea or someone has already experienced this?

I had this exact same issue days ago and in my case even though I checked the tags to make sure it was ok what fixed my problem was to convert the files to the same format using a conversion utility. That fixed it so it sounds as if something was not quite right in the file. Mine were flac files. I noticed that by what you saw with 0 kbs and 0 kHz showing up and no way to play the files.
post #8344 of 15203

Quote:

Originally Posted by Langenfelds View Post
 

 

 

If anyone is interested in iBasso DX50 Leather Case, you can order them from: http://ido.com.vn/goods-777-ibasso-dx50-leather-case.html

I was gonna get one of those when i first saw it few hundred pages ago. I couldn't connect to the site at first. Then i found it is all in that language. I don't know how to order... so i opted for the silicon case.

 

Quote:
Originally Posted by Cotnijoe View Post
 

Just a quick question. How are you guys charging the DX50? I tried using one of those apple plug to USB jack things and it the DX50 doesnt seem to recognize that. I can only charge via laptop right now and that takes a good while :(

try using a different cable.

post #8345 of 15203

No, it's GR07 Bass Edition.

post #8346 of 15203
Quote:
Originally Posted by nihontoman View Post


is it on main storage or the sd card?

Internal
Quote:
Originally Posted by musicheaven View Post

I had this exact same issue days ago and in my case even though I checked the tags to make sure it was ok what fixed my problem was to convert the files to the same format using a conversion utility. That fixed it so it sounds as if something was not quite right in the file. Mine were flac files. I noticed that by what you saw with 0 kbs and 0 kHz showing up and no way to play the files.

Uff longest way as I was afraid of

Anyway thanks guys
post #8347 of 15203

I thought about getting one of those leather cases, someone linked their facebook page.

https://www.facebook.com/Ido.com.vn

post #8348 of 15203
Quote:
Originally Posted by Hellkitchen View Post
 

Guys I've some problem with DX50. It doesn't play with some album I have. Don't kwow why. It's just show 0kbs and 0khz and is unable to play tracks. 

Any idea or someone has already experienced this?

 

My machine always does this after an update / factory reset (on the first screen after you youve done it) - I just go back into 'Music' choose an album and its good to go again...unless you have a different issue? I think it just defaults to the last album played but as it hasn't done a scan yet it say it isn't sure yet so it shows 0  0 

post #8349 of 15203

I have updated twice now, just to see how it goes and each time it goes fine. I download the FW, do the steps, do a factory reset and everything is good to go. I even forgot and left a SD card in and it was fine. The scan time is fast and a rescan if already scanned, is about 1/3 the time. Also, I like the sound. It doesn't sound artificial to me and the bass, is fine. If the bass were too heavy, my Fostex TH900 would sound terrible to me as they produce good bass but if too at all, it overpowers the music for me. So all is good for me and the DX50. 


Edited by jamato8 - 12/10/13 at 3:16pm
post #8350 of 15203
Quote:
Originally Posted by Langenfelds View Post









If anyone is interested in iBasso DX50 Leather Case, you can order them from: http://ido.com.vn/goods-777-ibasso-dx50-leather-case.html

Is it real leather or faux leather ?
post #8351 of 15203
Quote:
Originally Posted by highfell View Post


Is it real leather or faux leather ?

I don't know, but it looks and feels like real leather to me.

post #8352 of 15203

Firmware Update 1.2.6

Some thoughts...

 

I LOVE

~ the new sensitivity of the screen

~ the new media scanning bar

~ the new background

~ larger and better album art

 

~~~ So thank you for those

 

but...I HATE

 

~ The sound quality. Now to some degree this is relatively subtle but even then it isn't pleasant. . .

The bass i find is bloomy, large and in general over bearing. It is now a main feature of the sound. (bear in mind I listen on Grados which are known for their clarity and highs so if the bass is too much on these then...!?)

It should be an equal partner between mids and highs and should not stand out

The characteristics of the bass assail my ears in quite a rude and over bearing way. By that I mean there are parts of words or instruments that punch through in an unpleasant way. For example if you go close to someone's ear and speak loudly but then really accentuate certain words, especially the 'p's and the 'b's. This is an exaggerated example of how the audio is now coming into my ears.

For example, in terms of headphones - Sometimes more bass = regular consumers out there thinking the headphone is better but I would think that this is really an Audiophile piece of kit and in that way I would imagine the emphasis going towards a perfect balance between low/mid and high would be the goal (in general!)

 

~ The EQ. The good news is I can now 'just about' hear the difference of the different presets but when I tries to alter the bass I refering to above it didn't work. Its hard to explain exactly why it didn't work but I will just say I have no confidence at all in the programming or implimentation of the iBasso DX50 EQ

 

~ With gapless -off- song endings and beginings are sometimes cut off and and with gapless -on- . . . well lets just say cross fades are interesting...but they are not a gapless function. gapless should be = gapless!!

 

~ I still think this is a magnificant player which I love but aside from v1.2.2 and 1.2.3 I have been quite dissapointed with the sound quality.

If iBasso wants to keep these different sound signatures as presets that would be wonderful and would keep everyone happy but I fear they might eventaully finally get the player OS right but leave it with a signature I / others wont like? (Being a player of this quality I believe that people headphones/IEM's makes a big difference)

 

Anyhoo, just some thoughts on the magical mystery tour of the dx50 :)


Edited by jon parker - 12/10/13 at 3:18pm
post #8353 of 15203

The gapless will be fixed next FW. 

 

The comments on the bass I don't get. It is not overpowering on any of my music where it is recorded correctly. I also like the output very much to an amp and with the fi.Q, the sound to my ear is often reference when paired. 

 

It would be nice if the FW link and first page got an update. 


Edited by jamato8 - 12/10/13 at 4:36pm
post #8354 of 15203
I personally like the SQ of v1.2.6. better than any previous version. I have some well-done recordings of acoustic performances done by a friend of mine who I have heard live many times. These recordings when played through my reference IEM's sound amazingly similar to the live performances. I find I am much less inclined to now use an external amp.

Gapless seems to be working OK at the 5 sec. setting, however the sleep timer does not work properly. Most of the time it just stops the playback without shutting down the player and reverts back to the same file each time. Only once did I find that it actually shut down the player.
post #8355 of 15203
As has been noted, the gapless cum crossfade will be reverted in the next OS update. Here's hoping that is sooner rather than later.

As for the bass? It's not boomy or bloomy or bloated to my ears or my KRK's and those sound really bad when the bass is cranked. It's certainly less of a bass boost than 1.2.3b compared to either 1.2.2 or 1.2.5, perhaps 2-3dB across the low range, and the mids and highs are clearer than 1.2.3b so I'm surprised that you find 1.2.6 worse than 1.2.3b in all three departments. It's a silly little thing, but did you accidentally enable your amplifier's bass boost or leave it enabled from your last foray into 1.2.5?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0