Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.5.0 - Page 474

post #7096 of 14417
Quote:
Originally Posted by jj69 View Post
 

$8 + shipping isn't exactly a bargain for low quality silicone. 

If FiiO could package the X3 with a free silicone case, then why couldn't iBasso do the same with the DX50? 

actually this iBasso's case is much better quality then X3's provided in their package.

iBasso's one is made from a thick and solid silicone material though. not feeling as cheapo as X3 hahaha

post #7097 of 14417
Quote:
Originally Posted by jj69 View Post
 

$8 + shipping isn't exactly a bargain for low quality silicone. 

 

If FiiO could package the X3 with a free silicone case, then why couldn't iBasso do the same with the DX50? 

You are aware that the DX50 does come with a soft carry pouch?

 

Personally, I dislike covers at the best of times. I know we all want to protect these things but I've stopped putting my phones in cases a while back. As a rule the damn things stop working after a few years so why worry about a couple scratches? I just avoid carrying them in pockets with things like keys and so on....

post #7098 of 14417
Quote:
Originally Posted by CardosoPMV View Post
 

 

I have exactly the same problem and told it to iBasso. This behaviour started on the 1.2.5 release (1.2.0, 1.2.2 and 1.2.3beta don't have it). My scan takes much longer because I have >7000 mp3 files on a MicroSD card.

I advise you to send an email to them as well so that the people with loaded MicroSDs get the respect they deserve. :tongue:

 

By the way, if you hold the power button for a few seconds when the "Media Scanning" starts you can access the home icon and bypass it.

 

Meanwhile, I'll use the 1.2.3 Beta until this is fixed.

So I emailed iBasso today and got pretty quick replies... the email stream is below. Pretty surprising actually....

 

ME:

Hi,

 

Sending this direct as the website seems to be down at the moment… 

 

Since updating to 1.2.5, my DX50 scans the media every time I boot up. This takes 3 minutes and is very frustrating. Never happened on any previous firmware. Can this be changed back to when you reinsert a SDcard or add an option to auto or manual scan in the advanced menu.

 

Regards,

 

THEM:

Hi,

Please try factory reset and scan your SD card again.  We didnt change anything about the media scan after the V1.2.3.

 

Sincerely

iBasso Audio

 

ME:

 

Gee thanks for that quick reply. I will try again but I have tried that several times and also a recovery reset and wipe too but still the same scan every boot. I am not the only one. There are many others saying the same thing on HeadFi but most of them it only takes a few seconds. Can only think something else has changed that causes this. 

 

With my 64gb card and 5000 tracks it takes too long. 

Regards,

 

THEM:

 

Hi,

There is a media scan process when boot up on every firmware version. But, it should take you less than 10 secons even you have more than 5000trakcs.  

 

Sincerely

iBasso Audio

 

 

ME:

That is curious...

 

I have never seen the media scan screen at boot on any previous FW from 1.1.5 thru 1.2.3. Only when I insert a SD card and it prompts to scan. These are very slow. About 20 mins although I've not timed them because I only have had to do a scan when I have reset after a FW update.

 

For your info, there are no other files than 450 Flac and 4980 mp3 and my tags are cleaned. All filename are formatted track# title.extension and no more than 40 characters long.


Regards,

 

 

THEM:

 

Hi,

The media scan on boot up exists on the previous firmwares.  It is very short, less than 10seconds.  Also, it is shorter if you have less music on your SD card.

 

Sincerely

iBasso Audio

 

So, that answered nothing....

 

I reinstalled 1.2.5... reset, both types. I've even gone through my tags and filenames to remove "." and "," just in case they were an issue because I noticed in the album.img file the filenames were not showing correctly. 

 

Now it's taking 7 minutes to boot.

 

I'm going back to 1.2.3Beta like you and staying put. 

 

This is getting frustrating...

 


Edited by Jpfe8851 - 11/23/13 at 9:40pm
post #7099 of 14417
Well.... Some people like to drive a shiny new car around with a car cover on........ I'm guessing the same group of people would want to hide the true beauty of the DX50 too smily_headphones1.gif
post #7100 of 14417
Quote:
Originally Posted by ipush View Post

Yes Jaben Hong Kong is selling the case in 4 coulours (red,blue,black,pink if not mistaken).I got my DX50 there together with the case at the same time smily_headphones1.gif



 



Last night I updated the firmware to 1.2.5 and it is awesome! Don't really notice the difference with 1.2.2 in SQ wise as I'm a newbie, but what do I notice straight away is the memory card scanning is in lightning speed! It was turned off after factory reset, plugged in the SD Card, turned on, and seems like no scanning at all! I went to directory and yes it is updated! Tried to play a single file and it did media scanning but only last like 3-4 seconds and good to go.



 



Touch screen sensitivity also ok (no problem with scrolling) and load very fast between screen to screen.



Satisfied!


 



You are playing a song by directory browsing. Scanning definitely is quck as it only scans one file or at the most the whole album which the file belongs to.

If you browse by album or artist (aka DB browsing) then you will see DX50 will do a full scan of your SD card. I doubt it's lightning quick smily_headphones1.gif
post #7101 of 14417

Quote:

Originally Posted by Jpfe8851 View Post
 

CAUSE: I know we all want to protect these things but I've stopped putting my phones in cases a while back.

EFFECT: As a rule the damn things stop working after a few years so why worry about a couple scratches? 

post #7102 of 14417
Does it help if you run a quick format on the drive after connecting it to your PC? Wipe the internal storage clean, do a factory reset again and see if it helps.
Quote:
Originally Posted by Jpfe8851 View Post

So I emailed iBasso today and got pretty quick replies... the email stream is below. Pretty surprising actually....

ME:



Hi,



 



Sending this direct as the website seems to be down at the moment… 



 



Since updating to 1.2.5, my DX50 scans the media every time I boot up. This takes 3 minutes and is very frustrating. Never happened on any previous firmware. Can this be changed back to when you reinsert a SDcard or add an option to auto or manual scan in the advanced menu.



 



Regards,




THEM:



Hi,



Please try factory reset and scan your SD card again.  We didnt change anything about the media scan after the V1.2.3.

Sincerely
iBasso Audio

 



ME:

Gee thanks for that quick reply. I will try again but I have tried that several times and also a recovery reset and wipe too but still the same scan every boot. I am not the only one. There are many others saying the same thing on HeadFi but most of them it only takes a few seconds. Can only think something else has changed that causes this. 

 



With my 64gb card and 5000 tracks it takes too long. 


Regards,

THEM:

Hi,
There is a media scan process when boot up on every firmware version. But, it should take you less than 10 secons even you have more than 5000trakcs.  

Sincerely
iBasso Audio


ME:
That is curious...

 



I have never seen the media scan screen at boot on any previous FW from 1.1.5 thru 1.2.3. Only when I insert a SD card and it prompts to scan. These are very slow. About 20 mins although I've not timed them because I only have had to do a scan when I have reset after a FW update.

 



For your info, there are no other files than 450 Flac and 4980 mp3 and my tags are cleaned. All filename are formatted track# title.extension and no more than 40 characters long.


Regards,
John Pfeffer


THEM:

Hi,
The media scan on boot up exists on the previous firmwares.  It is very short, less than 10seconds.  Also, it is shorter if you have less music on your SD card.

Sincerely
iBasso Audio

 



So, that answered nothing....

I reinstalled 1.2.5... reset, both types. I've even gone through my tags and filenames to remove "." and "," just in case they were an issue because I noticed in the album.img file the filenames were not showing correctly. 

Now it's taking 7 minutes to boot.

I'm going back to 1.2.3Beta like you and staying put. 

This is getting frustrating...

 


post #7103 of 14417
Quote:
Originally Posted by alv4426 View Post
 

CAUSE: I know we all want to protect these things but I've stopped putting my phones in cases a while back.

EFFECT: As a rule the damn things stop working after a few years so why worry about a couple scratches? 

Fair comment if I abuse my gear. I don't. I'm just saying a few little marks aren't worth the hassle and bulk of a cover.

post #7104 of 14417
Quote:
Originally Posted by tak- View Post

Does it help if you run a quick format on the drive after connecting it to your PC? Wipe the internal storage clean, do a factory reset again and see if it helps.

Im over it frankly.... I have another card. I'll try that later on when I feel less frustrated. :deadhorse:

post #7105 of 14417
Quote:
Originally Posted by Jpfe8851 View Post

Fair comment if I abuse my gear. I don't. I'm just saying a few little marks aren't worth the hassle and bulk of a cover.

 



I just don't get it. Some people I know buy gadgets (e.g. idevices) purely because the look cool and thin. Only to wrap it with bulky, sometimes ugly cases.

Having said that, DX50 looks cool to me. The black silicone case probabaly is the only choice for me. But I will go and wrap it with transparent film protector (gmask) similar to invisible shield.
post #7106 of 14417
Thread Starter 
Quote:
Originally Posted by karloil View Post

i'm hesitant to get the silicone case too, i believe the 3m dual lock adhesives won't stick properly to them...on to leather cases!

Back to the rubber band maybe? wink.gif

Or cut couple of holes in the silicone case for the dual lock to protrude. biggrin.gif ouch...
Edited by musicheaven - 11/18/13 at 12:53am
post #7107 of 14417
Quote:
Originally Posted by headwhacker View Post
You are playing a song by directory browsing. Scanning definitely is quck as it only scans one file or at the most the whole album which the file belongs to.
If you browse by album or artist (aka DB browsing) then you will see DX50 will do a full scan of your SD card. I doubt it's lightning quick smily_headphones1.gif

Previously on 1.2.2 it did an automatic media scanning once the device turned on for around 5 minutes. But in my 1.2.5 such scanning is taking a very short time, even like no performed at all.

Perhaps your saying is correct, will try to browse by artist when I updated my library next time :)

post #7108 of 14417

Well, from all the freezing I was getting on firmware 1.2.5 I reverted back to the most stable firmware they have released thus far... 1.2.3beta.  Lol.  No more issues.

 

It seems that they did something that sort of fixed my issue in that beta, that they took back out again in the final release.  

 

Also after doing a direct A-B comparison between the sound quality of these two firmware versions, (I didn't even do a factory reset going back to 1.2.3beta), the audio sounds completely identical.  Whereas that's to say, it sounds really good, as it always has, and always will :p

post #7109 of 14417

Don't forget to do factory reset every time after up or downgrade your firmware.

post #7110 of 14417
Quote:
Originally Posted by Judy View Post
 

This is Judy from China, we got high taste leather case and silicone case for iBasso DX50, if you guys like to get one, please visit our store, link below,

http://www.aliexpress.com/store/product/Free-shiping-handmde-ibasso-DX50-leather-case/715669_1479216073.html

 

 

That is a really cool case.  It appears however, the case seems primary designed around being able to use the dx50 while it's in the case.  However there seems to be a belt loop on the back (which is good as I'd want it on my belt).  However it's a closed loop belt loop, meaning it can't be removed without undoing one's belt, and with the headphones plugged in the dx50 gets locked in place essentially to where you can't pull it up to look at the screen without unplugging the headphones or undoing one's belt.  Hmmmm.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.5.0